Unmet dependences! when install Cuda 6.5 on a freshly installed ubuntu 14.04

I follow the tutorial here to install Cuda 6.5, and when I try apt-get install cuda,I get the following errors:

    The following packages have unmet dependencies.
 libcheese-gtk23 : Depends: libclutter-gtk-1.0-0 (>= 0.91.8) but it is not going to be installed
                   Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
 libcheese7 : Depends: libclutter-gst-2.0-0 (>= 0.10.0) but it is not going to be installed
              Depends: gstreamer1.0-clutter but it is not going to be installed
 libclutter-1.0-0 : Depends: libcogl-pango15 (>= 1.15.8) but it is not going to be installed
                    Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I already got some solutions from google, but none of them solved my problem. And as new system, the only software been installed is a chrome browser.

Solved, by removing all libcheese* packages and then to reinstall the ubuntu-desktop after finish installing Cuda. I am not sure whether its a good solution, but I successfully installed Cuda and until now didn't find any problem.

Answers

I had essentially the same problem with CUDA 7.0 on Ubuntu 14.04. Just adding the packages that apt-get claimed have unmet dependencies to the apt-get install cuda worked for me:

sudo apt-get install cuda libcheese-gtk23 libcheese7 libclutter-1.0-0 libclutter-gtk-1.0-0 libcogl15
Posted on by Ulrich Stern

Use the Synaptic package manager. https://help.ubuntu.com/community/SynapticHowto I think it tends to do better with finding dependencies.

Make sure to update your installation before trying to install it. Make sure there are no package conflicts as this tends to create problems. If you find any conflicts, uninstall the packages and try again.

Posted on by Christian Sarofeen