php 7.2 and libcurl

php 7.2 as i think use libcurl with version 4 but when I set this version of libcurl in my Ubuntu, some programs became not working and more than this, system try to delete these programs. They are at least: Viber, Joxi and so on, and a lot of libraries which not works if libcurl3 is not installed But without libcurl4 my php7.2 can't work with php-curl

So what should I do to make work apps like Viber and php-curl on php7.2 togeter?

Here is some command output from console to see more visual what I mean:

sudo apt-get install php-curl
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  fonts-dejavu-extra libatk-wrapper-java libatk-wrapper-java-jni libdouble-conversion1 libgif7 libice-dev libmcrypt4 libpthread-stubs0-dev libqt5core5a libqt5dbus5 libqt5gui5 libqt5multimedia5 libqt5network5
  libqt5qml5 libqt5quick5 libqt5script5 libqt5sql5 libqt5sql5-sqlite libqt5svg5 libqt5widgets5 libqt5x11extras5 libqt5xml5 libqt5xmlpatterns5 libsm-dev libx11-dev libx11-doc libxau-dev libxcb-icccm4
  libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0 libxcb-xinerama0 libxcb-xkb1 libxcb1-dev libxdmcp-dev libxkbcommon-x11-0 libxt-dev python-apt python-pycurl qml-module-qtquick2
  qt5-gtk-platformtheme qtdeclarative5-qtquick2-plugin qttranslations5-l10n x11proto-core-dev x11proto-dev x11proto-input-dev x11proto-kb-dev xorg-sgml-doctools xtrans-dev
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libcurl4 php7.2-curl
The following packages will be REMOVED:
  joxi libcurl3 viber
The following NEW packages will be installed:
  libcurl4 php-curl php7.2-curl
0 upgraded, 3 newly installed, 3 to remove and 0 not upgraded.
Need to get 245 kB of archives.
After this operation, 433 MB disk space will be freed.
Do you want to continue? [Y/n]