Tailwindcss error when trying to build css

trying to learn tailwind but when I try to build the CSS I keep getting errors. I've followed multiple videos and every time I run into this error.

this is the error that I keep getting. $ npm run build

> [email protected] build C:\Users\ghost\Dropbox\portfolio project\Discovery TV Platform
> tailwind build assest/styles.css -o public/styles.css

internal/modules/cjs/loader.js:463
  throw e;
  ^

Error: Package exports for 'C:\Users\ghost\node_modules\colorette' do not define a valid '.' target
    at resolveExportsTarget (internal/modules/cjs/loader.js:460:13)
    at resolveExports (internal/modules/cjs/loader.js:393:16)
    at Function.Module._findPath (internal/modules/cjs/loader.js:492:20)
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:787:27)
    at Function.Module._load (internal/modules/cjs/loader.js:693:27)
    at Module.require (internal/modules/cjs/loader.js:864:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at Object.<anonymous> (C:\Users\ghost\node_modules\autoprefixer\lib\autoprefixer.js:3:17)      
    at Module._compile (internal/modules/cjs/loader.js:971:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1011:10) {
  code: 'MODULE_NOT_FOUND'
}
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] build: `tailwind build assest/styles.css -o public/styles.css`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the [email protected] build script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\ghost\AppData\Roaming\npm-cache\_logs\2020-11-22T07_01_12_878Z-debug.log

here is my json file

{
  "name": "platfomr",
  "version": "1.0.0",
  "description": "",
  "main": "index.js",
  "scripts": {
    "build": "tailwindcss build assest/styles.css -o public/styles.css"
  },
  "author": "",
  "license": "ISC",
  "dependencies": {
    "tailwindcss": "^2.0.1"
  }
}
enter code here

any help would be greatly appreciated. Thank you in advance.

Answers

npm i [email protected] [email protected]

solved the problem for me

Posted on by yodamaster72