"Unable to find remote helper for 'https'" during git clone

I am unable to clone HTTPS repositories. I can clone SSH repos fine, but not HTTPS repos. I cannot test the GIT protocol since I am behind a corporate firewall. This is what I am trying to do: $...

Using the RUN instruction in a Dockerfile with 'source' does not work

I have a Dockerfile that I am putting together to install a vanilla python environment (into which I will be installing an app, but at a later date). FROM ubuntu:12.04 # required to build certain...

Clone private git repo with dockerfile

I have copied this code from what seems to be various working dockerfiles around, here is mine: FROM ubuntu MAINTAINER Luke Crooks "[email protected]" # Update aptitude with new repo RUN apt-get...

UnPack / rePack android img with Ubuntu simg2img/make_ext4fs

I'm playing with these 2 tools on ubuntu 14.04.1 : simg2img make_ext4fs The first tool work great. But when I try to compile the image changed with the second tool I have in output this...

Ansible Do Task If Apt Package Is Missing

I'm looking to do a series of tasks if a specific apt package is missing. for example: if graphite-carbon is NOT installed do: - apt: name=debconf-utils state=present - shell: echo...

Install node in Dockerfile?

I am user of AWS elastic beanstalk, and I have a little problem. I want to build my CSS files with less+node. But I don`t know how to install node in my dockerfile, when building with...

Install OpenCV in a Docker container

I'm attempting to Dockerise a Python application, which depends on OpenCV. I've tried several different ways, but I keep getting... ImportError: No module named cv2 when I attempt to run the...

docker entrypoint running bash script gets "permission denied"

I'm trying to dockerize my node.js app. When the container is built I want it to run a git clone and then start the node server. Therefore I put these operations in a .sh script. And run the...

How to replace Python 3.4.3 by 3.5

Im on Ubuntun 17.2 and I have Python version 3.4.3 installed. However for a package to install I need Python 3.5. Trying to simply use the apt-get routine only that python3 is up to date. Trying...

How to clone git repo using Dockerfile

I am a beginner to Docker. I have written a small Dockerfile to start with. I am not able to clone my repo using following Dockerfile. FROM mattes/hello-world-nginx RUN apt-get update && apt-get...

"sh: 1: react-scripts: not found" In Docker

I have a Docker container that fails to do a npm install for a react.js app that is cloned in the container when it is built. Would anybody know how to resolve the issue? Error: sh: 1:...

Executing a script at each restart of an AWS EC2 instance

I would like to ask you this question: is it possible to execute this script at each restart of an AWS Ec2 instance? #!/bin/bash sudo apt update sudo install docker sudo install...

GITLAB CI Error loading key "/dev/fd/63": invalid format ERROR: Job failed: exit code 1

Here is my code giltlab-ci.yml : before_script: ## ## Install ssh-agent if not already installed, it is required by Docker. ## (change apt-get to yum if you use an RPM-based image) ## ...

How to resolve a maven dependency in a bitbucket pipeline that exists in another repo

I'm setting up a deployment pipeline for my companys mulesoft APIs using bitbucket-pipelines. This technology is attractive to us because of the built in integrations with Jira. The problem is...

Compiling xv6 code but giving the errors on assembly instruction

I am using Ubuntu 18.04.2 LTS under windows 10 by using "Windows subsystem for Linux." I am experiencing some issues with XV6. I set up XV6 by using the command: git clone...

Package 'python-software-properties' has no installation candidate

I cloned this project : https://github.com/sayems/kubernetes.resources/tree/master/k8s-vagrant And when i try to execute : vagrant up I'm getting this error : ==> k8s-master: Running...

Failed to fetch packages from jonathonf repository while running Dockerfile from AzureDevOps

I have a Dockerfile which is getting the packages from a source called jonathonf but it's failing to download some packages from this repository. Could any one please help me with the solution? I...

Cloud Run app responds with "503 Service Unavailable" when using Micronaut HTTP Client

My application is based on Micronaut and GraalVM (java 11) and does a simple call to http://httpbin.org/get: @Controller("/api") class HelloWorld( @Client("http://httpbin.org") private val...

Unable to install `gattlib`

I am trying to install gattlib in Python in order to use some of its Bluetooth-tools. The OS is ubuntu 18.04.4 LTS. I have by now tried the following (as e.g. here): sudo apt-get install...

SSH-forwarding during build only works for root

Here's a Dockerfile that works: # syntax=docker/dockerfile:1.0.0-experimental FROM debian:buster-slim as base # setup APT operation for noninteractive use # This avoids a bunch of warnings like #...

Certificate / SSL connection problem in docker build on macOS

I am building a docker image on macOS. This is the part of my Dockerfile: FROM ubuntu:18.04 # Dir you need to override to keep data on reboot/new container: VOLUME /var/lib/mysql #VOLUME...

How do I fix the "No known features for CXX compiler" while compiling with CMake (Linux Mint)

I am trying to install this plugin: https://github.com/CatxFish/obs-v4l2sink I followed all the steps (Installed QT, got obs-studio source code and then tried to build the plugin): sudo apt...

Yocto poky build fails on function do_rootfs

I've been following the steps on https://www.linux4sam.org/bin/view/Linux4SAM/PokyBuild to build a core-image-minimal and a microchip-headless-image for SAMA5D27 eval kit using Yocto. I am stuck...

Error compiling coreutils - error: function might be candidate for attribute 'const' [-Werror=suggest-attribute=const]

I try to compile coreutils on Ubuntu 18.4. Here is what I did so far: sudo apt install bison gperf make textinfo git clone git://git.sv.gnu.org/coreutils cd...

Docker openCV installation Issues

I'm currently trying to run an application using Docker but get the following error message when I start the application: error while loading shared libraries: libopencv_highgui.so.4.4: cannot...

How do I deal with an internal compiler error (cc1plus: gimplify) when installing c based python libraries (OpenCV2) on a Raspberry PI?

I've been trying to install the OpenCV2 libraries for Python 3 on my Raspberry PI 3B. I started this process by installing Python 3 through apt and using pip3 to install OpenCV. However the...

Can not get asdf-direnv work in docker when building

I'm trying to use asdf-direnv in docker. Following the README of asdf-direnv, I make this Dockerfile FROM nvidia/cuda:10.2-devel-ubuntu18.04 RUN chsh -s /bin/bash SHELL ["/bin/bash", "-ic",...

How to Deploy Multiple Django Apps on Single server using Ngnix & GUnicorn?

I am trying to Deploy Two Django apps with single AWS EC2 Instance having same IP. But it always failed when I have added the second App.sock and test Supervisor. I fond some body asked similar...

compiling with MKL, OpenBLAS, and other libraries by using Makefile

I have tried to compile one probabilistic model posted on github (https://github.com/gerowam/influence), but for the person who is not familiar with C language and compiling, it is really hard to...

Adding imagemagick into my php 7.4 docker raised error

I need to add imagemagick into my php 7.4 docker, so in file Dockerfile.yml I added : FROM php:7.4.1-apache RUN apt-get update && \ apt-get install -y \ python \ ...