Installing MariaDB: unmet dependencies, mariadb-server-10.0

ubuntu:~$ sudo apt-get install mariadb-server Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that...

apt-get update' returned a non-zero code: 100

I am trying to create a docker image from my docker file which has the following content: FROM ubuntu:14.04.4 RUN echo 'deb http://private-repo-1.hortonworks.com/HDP/ubuntu14/2.x/updates/2.4.2.0...

vendor folder is not present in my docker image

I'm trying to build a deployable image of my laravel app into docker. Here is my dockerfile: FROM php:7.1.14-fpm ENV node_version 8.4.0 ENV npm_version 5.7.1 RUN echo "deb...

Ignore key error on apt-get update from ansible playbook

I have a playbook in ansible that install packages from a repository that has invalid keys: - name: Add Cloudera key apt_key: keyserver: keys.gnupg.net id:...

Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running? inside a Dockerfile

I have the following Dockerfile: FROM ubuntu ENV NPM_CONFIG_LOGLEVEL warn ENV admin_user="PeerAdmin" network_name=$1 version=$2 hversion=hlfv1 fabrik_path=/fabric-tools project_dir=$(pwd)...

Remote offer sdp: Failed to set remote video description send parameters

I am using Simple Peer to connect 2 clients over webRTC While trying to send the offer to the receiver I am getting Failed to set remote video description send parameters. Here is the...

"E: Invalid operation update" error while running shell scripts in WSL

I have a shell script called setup_wsl.sh which contains: #!/bin/bash echo "hai" sudo apt-get update sudo apt-get install \ apt-transport-https \ ca-certificates \ curl \ ...

Apt-get update error on ubuntu 16.04 by using Ansible playbook

I have written ansible playbook for installing the docker on Ubuntu 16.04 LTS. While running the ansible playbook, I am getting apt-get update error I have tried running the attached playbook...

ASP Net Core Linux ERR_CONNECTION_REFUSED

I'm testing net core app deployment to a Digitalocean droplet running Ubuntu 18.04 and Nginx 1.14. For testing, I'm using the templates available from 'dotnet new'. The dotnet new web and dotnet...

docker build failed after pip installed requirements with exit code 137

I am starting a new django project and want to dockerize the project, on my ubuntu. when I run docker-compose up --build I got a strange Error. It seems that it has problem with pip install...

public key is not available: NO_PUBKEY F76221572C52609D

For the below docker file: FROM microsoft/aspnetcore-build:1.0.1 ENV DOTNET_SKIP_FIRST_TIME_EXPERIENCE 1 # This is FROM openjdk:8-jdk RUN apt-get update && apt-get install -y...

CVAT(Computer Vision Annotation Tool) installation issue

I'm trying to install CVAT and I'm following this installation guide: https://github.com/opencv/cvat/blob/develop/cvat/apps/documentation/installation.md#windows-10 I installed Docker and Git as...

Docker container - How to set GID of socket file to groupID 130?

This is docker in docker scenario. Below is the corresponding code in Dockerfile that has docker client installed: FROM jenkins/jenkins:2.190.2 ENV DEBIAN_FRONTEND=noninteractive # Official...

Install .NET Core on Google Colab

I am trying to install .NET Core on Google Colab. I follow the instructions given (for Ubuntu 17.10): ! wget -q https://packages.microsoft.com/config/ubuntu/17.10/packages-microsoft-prod.deb !...

(Closed) Error on apt-get update (sury.org) [linux]

I'm trying to apt-get update on my virtualmin (debian) but it fails with some package (packages.sury.org) then I check the package with: curl --verbose -SLO...

Install PHP 7.4 met with "unmet dependencies", how to solve this?

I know a lot of topics have the same question but I've tried everything and nothing works for me. So I'm trying to install php 7.4 on my ubuntu stretch. I've done the following commands I found on...

Building from Dockerfile and getting "The following signatures couldn't be verified because the public key is not available: NO_PUBKEY"

I'm trying to build a PHP 5.3/Apache for local use using a Dockerfile that starts: FROM php:5.3-apache RUN apt-get update && \ apt-get install -y \ libfreetype6-dev \ ...

Unable to get heroku started on cloud9 ide

I am running the command - curl https://cli-assets.heroku.com/install-ubuntu.sh | sh Which throws the following error - % Total % Received % Xferd Average Speed Time Time Time ...

Redash Docker installation problem: sqlalchemy.exc.OperationalError: (psycopg2.OperationalError)

I'm trying to install Redash on Ubuntu 20.04.1 I used this method of installing: https://github.com/getredash/setup I downloaded the files I cd in to the folder I run 'sudo ./setup.sh' I get the...

useradd invalid user in Dockerfile

I'm trying to use a docker image with Laravel + Microsoft SQL drivers. My dockerfile: FROM php:7.2-apache ENV ACCEPT_EULA=Y # Microsoft SQL Server Prerequisites RUN apt-get update \ && curl...

Deploy Azure Function with an Alpine - Unhandled 'error' event

I want to deploy Azure function (node and/or python) from the lightest DockerFile. So I need to be able to run az login and func. For now the only one which work well is 2.27GB. I tried a lot of...

GPG error The following signatures couldn't be verified because the public key is not available

I'm following this guide for the installation of Docker inside a Jenkins container This is the Dockerfile of the Jenkins container: FROM jenkins:1.596 USER root RUN apt-get update RUN echo...

Error: Handshake inactivity timeout (MySQL + Node.js)

Using docker-compose with ngnix, node backend and mysql.js. This error has occurred: api | there was an error connecting to pool: Error: Handshake inactivity timeout api | at...

Couldn't find any package by glob 'php8.0' in debian

hi am using a Kali linux Rolling 2020.4 last update and every thing is okay from 2 years until now after i add the PPA of php and update every thing for last update when i run sudo apt install...

How to run the python script within a docker container through nextflow seemlessly without any path or env related issues?

I am trying to run a python script using nextflow and docker. I am using a dockerfile (as shown below) to create a docker image. Nextflow script has a simple launch of a python script. The issue...

Error while installing Docker on Raspberry Pi 4

I am trying to install Docker on a Raspberry Pi 4, but I am getting an error. May you tell me, how to fix this? Thanks a lot! [email protected]:~ $ curl -fsSL https://get.docker.com -o...

Docker run inside Ubuntu on Windows WSL

My error [email protected]:~/temp2607/reaction-development-platform$ sudo apt-get update Hit:1 https://download.docker.com/linux/ubuntu focal InRelease Hit:2 http://archive.ubuntu.com/ubuntu...

Sbt-native-packager cannot connect to Docker daemon

Here is my configuration which worked for more than one year but suddenly stopped working. variables: DOCKER_DRIVER: overlay2 DOCKER_TLS_CERTDIR: "" stage: deploy image:...

Dockerfile that Builds both ASP.NET Core and C++ binaries

I have the need to build both an ASP.NET Core application, which calls a C++ executable to get some work done. I have the docker file to build both images for .NET Core and C++ working great, but...

How to make docker-compose work on M1 chip?

I'm new to m1 macbook and face an issue with running my docker-compose which looks like this: version: "3.7" services: search: platform: linux/x86_64 build: context: . ...