How to install rabbitmq management plugin (rabbitmq-plugins)

Brief: Is there a way to install rabbitmq-plugins via a ubuntu package? Details: I have rabbitmq running ok in my ubuntu system, and now I'm trying to monitor what's going on via the management...

how can i run cron jobs with PHP?

I'm running ubuntu 10.04 and have installed php5 via the following: sudo aptitude install libapache2-mod-php5 php5 php5-common php5-curl php5-dev php5-gd php5-imagick php5-mcrypt php5-memcache...

Uninstall MySQL completely from Ubuntu

I have trouble in uninstalling MySQL from Ubuntu. I used the following commands, it doesn't seem to help as I still find the MySQL folder in \etc directory 1.aptitude remove...

debian apt packages hash sum mismatch

From the Debian command line, I'm getting a hash sum mismatch after executing aptitude update; aptitude upgrade. Below is the command line output. I've tried an aptitude clean, but this does not...

ImportError: No module named mysql.connector using Python3?

trying to import python-mysql.connector on Python 3.2.3 and receiving an odd stack. I suspect bad configuration on my ubuntu 12.04 install. [email protected]:/usr/share/pyshared$ python3 Python...

debugging ld, "Inconsistency detected by ld.so"

I am trying to use a widget library called GLV for an application I am developing. I am running Linux Mint 17. I installed all the libraries and I have succeeded in building the GLV library, but...

Ubuntu : Unable to correct problems, you have held broken packages

trying to install this, I am getting the 'Unable to correct problems, you have held broken packages' error message. Apache version Server version: Apache/2.4.2 (Ubuntu) Server built: Jun 27 2012...

Android linux deploy (localhost LAMP server configuration)

Hello my fellow humans! I have two rooted android phones, each running a chroot environment using the "Linux Deploy" app (HTC desire 510 running Kali Linux and vodafone smart 4 mini running...

pg_config shows 9.4 instead of 9.3

I am using Postgres 9.3, however my pg_config points at 9.4, preventing me from building extensions (pgTap). $ sudo aptitude search postgresql | grep ^i i postgresql-9.3 -...

Debian: dist-upgrade removes gnome and many other stuff

I am (was) running the Debian Sid and faced a major update problem few days ago. It was weekend and I was just going to upgrade stuff, did sudo apt-get update, then sudo apt-get upgrade. Then I...

How to install rsyslog-pgsql via preseed file wile install linux with default answers

I have a postinstall script: unset DEBIAN_HAS_FRONTEND DEBIAN_FRONTEND DEBCONF_REDIR DEBCONF_OLD_FD_BASE export DEBIAN_FRONTEND=noninteractive aptitude -y install rsyslog-pgsql > /var/tmp/log...

Not able to install apache2 on Ubuntu 14.04

I am not able to install apache2 on Ubuntu 14.04. On executing sudo apt-get install apache2 getting the below error:- The following packages have unmet dependencies: apache2 : Depends:...

vagrant provisionning in packer build

I would like to create a Vagrant box with Packer. For that I use a packer project on github : Packer ubuntu 14.04 LTS As they are, the 'packer build' command run correctly and I can use my vagrant...

password define for ssh connection into docker container

I would like to connect with SSH into my docker container. For that I created image with this Dockerfile and this command docker build -t test/toto . : FROM ubuntu:14.04.4 MAINTAINER Darkomen...

Qt5, Ubuntu. Failure in building an app with Opengl

I'm a novice in Qt5, want to make a simple programm with interactive 3D graphics. I create a new Qt Widgets app, following manuals I do QT += opengl in .pro, #include<QtOpenGL> in .h, and that's...

Possible to create stackscripts from A to Z with instruction from howtoforge.com - perfect server?

I tried to deploy below stackscripts following the tutorial from howtoforge.com https://www.howtoforge.com/tutorial/perfect-server-debian-8-4-jessie-apache-bind-dovecot-ispconfig-3-1/ From linode...

MariaDB never starts within docker image

I'm creating a docker image with ubuntu trusty and MariaDB 5.5 but I can never get MariaDB to start unless I actually connect to the running VM. Dockerfile: FROM ubuntu:trusty # Upgrade...

Post install script: OpenSSH fails

I am currently working on a post install script for servers (mostly for myself, since I know what I need/want), targeting debian 8. But I have issues by make OpenSSH. First of...

PHP 7 install on Ubuntu 14.04 now fails due to libssl dependency that can't be resolved?

I am using shippable to build my project and part of it requires PHP. The build script is this: apt-get update apt-get install -y software-properties-common python-software-properties...

Unable to install any package due to unmet dependencies of python-minimal

Whenever I try to install any software on my ubuntu syatem, I am prompted with 'Unmet dependencies' error and is being suggested to do apt install -f. I tried below command and n number of other...

Changing ansible loop due to v2.11 deprecation

I'm running a playbook which defined several packages to install via apt: - name: Install utility packages common to all hosts apt: name: "{{ item }}" state: present ...

Flutter setup failing, lib32stdc++6 won't install under Ubuntu 18.04

I just sat down to try flutter out today and no matter what I've tried I can't get it working. I started by cloning out the repo, and then did a flutter doctor command, hoping it would work. The...

Doesn't connect host's DB using docker container with php7.0-fpm

I'm currently trying to link the host's database with php-fpm inside the docker container. However, I have to ask you a question because the area is not working properly. I didn't use php offical...

Fail to install nautilus on Ubuntu 18.04. (unmet dependencies)

Previsouly, my ubuntu coule not load USB disk, and I tried to sudo apt-get remove nautilus. But that did not fix the USB loading issue, and now I can not install nautilus as well. When I ran sudo...

Ansible docker_network fails on missing docker module

I keep getting the following error on the "Create a network" step of my Ansible role on the first run. Every second time I run the ansible script it seems to be working. Am I missing something?...

strict.pm did not return a true value at (eval 1) line 2

I have a VPS with the following System installed: CPU model : Common KVM processor Number of cores : 1 CPU frequency : 2499.998 MHz Total size of Disk : 30.0 GB (6.0 GB...

pkgProblemResolver error when running apt --fix-broken install

I am trying to run an apt upgrade, but it is requiring me to run apt --fix-broken install first. However, when I run that command, I get the following output: Reading package lists......

Question on updating packages using Ansible

My Ansible playbook contains packages that I want to install with the latest versions; however, it does not occur. I understand with apt you won't get the latest updates but what would be the best...

cannot open /usr/share/dbconfig-common/internal/mysql: No such file

Good afternoon all. Iḿ having this problem in a debian OS Setting up phpmyadmin (4:4.9.7+dfsg1-1) ... /var/lib/dpkg/info/phpmyadmin.config: 144: .: cannot open...

Broken package installation using Ansible on debian 11 Bullseye

I woud like to install debian packages using Ansible 2.7.7 on Debian testing (yet) I try to execute this simple task: tasks: - name: install basic packages apt: name: ['mc', 'htop',...