How to install and run phpize

I have been meaning to install ffmpeg as an extension to my PHP setup. So before I can install it, I need to phpize it. I installed php5-dev by sudo apt-get install php5-dev. But now when I run...

Makefile conditional with automake/autoconf

can anybody tell me if there is a way to insert a conditional block to Makefile.am so that it will be passed further to a Makfile created by autotools? Here is an example: ifeq "$(SOMEVAR)"...

CFLAGS, CCFLAGS, CXXFLAGS - what exactly do these variables control?

I am using GNU make to compile my C++ code, and i would like to understand how to make my compilations customizable. I read in different places that CFLAGS, CCFLAGS and CXXFLAGS are used for this...

Is there a way to tell automake not to interpret part of the automakefile?

Is there a way to tell automake not to interpret part of the Makefile.am? Specifically, I am trying to encode a Makefile conditional in a Makefile.am. As other people have noticed, this doesn't...

possibly undefined macro: AC_MSG_ERROR

I have the following in configure.ac: AC_CHECK_PROGS(MAKE,$MAKE make gmake,error) if test "x$MAKE" = "xerror" ;then AC_MSG_ERROR([cannot find a make command]) fi This has been in our project...

installed libtool but libtoolize not found

im trying to build libxml2 from source on my mac. so i have autoconf libtool and automake installed using mac ports autoconf and automake seem to be working fine as expected. i try running...

Run gcov tool using c++ compiler

I am working, for the first time, with the coverage tool gcov to analyze a large project. I have a directories structure like this: HW -FooHW1.cpp -FooHW1.h -FooHW2.cpp ...

Why did I get "Requirements installation failed with status: 1" error with RVM?

This is the message my terminal gave back to me when trying to update Ruby using RVM on a Macbook Pro, OS X Lion 10.7.5, with Command Line Tools, XCode, and Homebrew installed. Error running...

Configure error with Mac OS X 10.8.5 Xcode 5.0.2: clang: error: argument to '-V' is missing (expected 1 value) clang: error: no input files

on MacOSX 10.8.5, after upgrading to Xcode 5.0.2 (and upgrading/installing the Command Line Tools (from within Xcode preferences) I was installing FFTW 3.3.3 and Open MPI 1.6.5 by configuring them...

Installing thrift on CentOS 6.5 64 bit and Cassandra PDO

Possibly my first question in this space. I have been trying to get around this issue from last 2 days. Yeah that seems to be a lot. Here is whats going on To install thrift I am following...

Error running '__rvm_make install'

I'm new to programming trying to add Ruby 2.2 using RVM and receiving the below error. I've run rvm get stable and tried reinstalling, but getting the same error. $ rvm reinstall...

vendor folder is not present in my docker image

I'm trying to build a deployable image of my laravel app into docker. Here is my dockerfile: FROM php:7.1.14-fpm ENV node_version 8.4.0 ENV npm_version 5.7.1 RUN echo "deb...

autoconf/automake/libtool - how to undefine PACKAGE_NAME, PACKAGE_TARNAME, PACKAGE_VERSION and so on

Build log: 20:10:36 make[3]: Entering directory `/home/ubuntu/build/ColossusCoinXT/distsrc-i686-pc-linux-gnu/src/minizip' 20:10:36 /bin/bash ./libtool --tag=CC --mode=compile gcc -m32...

How to compile FFmpeg as static (single file)

I would like to compile FFmpeg 4.1.3 as static or single file, After compiled. It's shared binary. Here is what I do Install the dependencies apt-get -y install build-essential autoconf automake...

Can't install Flutter on Mac

This is the only install that fails, I have already installed Flutter on 2 other Macs without any issue. It's a MBP 15-inch, 2018 running Mojave. What might interfere with the installation is...

How to fix pod install error glog is too old or missing react native ios in windows 10

I wanted to detach expo in my expo project to get the bare react native project after expo detach i run pod install bring me this error that during installing glog that script is too old or is...

Podman (libpod) fails to run while mounting shm with SELinux context

I am currently trying out Podman on Gentoo Linux: # grep -i selinux...

C compiler cannot create executables (installing Cocoapods)

While installing RNPermissions and its dependencies I run into an error. Seems to be a problem with my compiler or the package that is being installed. The error: checking whether the C compiler...

Issue with "pod install"

I have install cocoa pod using "sudo gem install cocoapods" command. cocoapods installation seems fine. Then I ran "pod install" command and below is the output on my terminal. Muqiturs-MBP:ios...

Unable to install packages correctly in docker

I was able to install all packages with npm, but two days ago I'm getting this error. Step 8/12 : RUN npm install ---> Running in aedc04c5281e > [email protected] install...

AWS Lambda Alpine Python Container shows IMAGE Launch error exec format error

I am writing a Lambda function to convert an excel file to PDF using unoconv with libreoffice, for this I am using alpine base image. The Dockerfile is as follows. # Define global args ARG...

react-native pod install (C compiler cannot create executables)

I'm trying to setup a new react native project on my Mac (M1). After initing the project with npx react-native init test I get the output: ✔ Downloading template ✔ Copying template ✔...

xcrun: error: SDK "iphoneos" cannot be located

I'm not experienced so I can't really pinpoint what is the problem. Thanks for the help. I cloned this repo: https://github.com/flatlogic/react-native-starter.git And was trying to follow the...

I can't install libpostal library on Windows

I am having a hard time trying to install the library libpostal on a Windows system. I tried many times to install this library even with an other computer, but I didn't succeed. I have followed...

Rootless docker causes "failed to resolve address for github.com"

In my dockerfile i'm installing cryptography python dependency however when building wheel from rootless docker i'm getting following error: ... generating cffi module...

How can I install php8.0-ssh2 from an Alpine Docker image

Here is the Dockerfile (see below) that I use for my projects. Could you explain to me how to install php8.0-ssh2 from this Dockerfile. FROM php:8.0.0-fpm-alpine ARG UID ARG GID RUN apk add...

Cocoapods, pod install error, How do I fix this?

[email protected]:~/ALL_MINE/REACT/REACT_NATIVE/PhotoEditor$ cd ios [email protected]:~/ALL_MINE/REACT/REACT_NATIVE/PhotoEditor/ios$ pod install Adding a custom script phase for Pod RNFBApp: [RNFB] Core...

cocoa pods does not work on Mac OS Monterey

I have updated to Xcode 13.0 on the latest beta of macOS Monterey and since then cocoapods stop working. Whenever I try to run any pod command (pod init, pod install, pod --version) it gives me...

Docker build fails with "The command '/bin/sh -c yarn install' returned a non-zero code: 1"

I have a react project which is built inside docker with the next config: FROM alpine:3.14 as build RUN apk add --update nodejs npm RUN npm install -g yarn RUN yarn set version berry RUN yarn set...

VSCode hits breakpoints then stops

So first of all since October for some reason my previously working Xdebug config for VSCode + Docker stopped working. I switched over to an Xdebug 3 config to try it out, since 2.9 appears to...