webpack build to multiple files

I have web pack application and want to build output multiple files not a single javascript file. for example if I have such folder structure components 1.js 2.js actions 1.js. 2.js my...

Why is "npm install" really slow?

What am I doing wrong when setting up my packages ? Is there any way to speed this up ? packages.json : { "name": "testing node", "version": "0.0.0", "description": "", "main":...

webpack externals setup not working, files being included

I'm repackaging react-toolbox for cljsjs and of the things I need to do is not include react and react-dom in the finished package, so, I obviously added: externals: { "react": "React", ...

Which babel plugin is declaring this var?

I'm trying to start auth0-lock this electron project. In one of auth0's nested dependencides (node-formidable), there's this line at the top of a file: if (global.GENTLY) require =...

Why (and How Can I FIx) ESLint import/no-extraneous-dependencies Failures on Installed Packages?

When I run ESLint I get the following errors: 1:13 error 'joi' should be listed in the project's dependencies. Run 'npm i -S joi' to add it import/no-extraneous-dependencies 2:16 error ...

"Npm Start" Is Not Working

I'm in the middle of making a website, and I use the command npm start to put it up on localhost. However, all of a sudden it stopped working after I had created two workspaces on Visual Studio...

error while running npm install

When running npm install I get the following error: npm ERR! code 1 npm ERR! Command failed: /usr/bin/git checkout ~3.9.0 npm ERR! error: pathspec '~3.9.0' did not match any file(s) known to...

Babel 7 Jest Core JS "TypeError: wks is not a function"

After upgrading my project to Babel 7, running tests through Jest is throwing the following error. The tests used to run without any issues in Babel 6, but they are failing in Babel 7 with the...

Jest - Cannot find module 'source-map' from 'source-map-support.js'

I've got the problem that I get the error: Cannot find module 'source-map' from 'source-map-support.js' Ran all test suites matching /Foo-test/i. T:\public_html\testProj>jest Foo-test FAIL ...

SyntaxError: Cannot use import statement outside a module

I've got an ApolloServer project that's giving me trouble, so I thought I might update it and ran into issues when using the latest Babel. My "index.js" is: require('dotenv').config() import...

ReactJS Error: Module Build failed: SyntaxError: Unexpected token '<'

My ReactJS code throws an error when I try to compile it. I used ReactJS before but I never ran into this error (see below) ERROR in ./kapiche/@kapiche_react/teacher/login.jsx Module build failed...

"RNCSafeAreaView" was not found in the UIManager

I try to open a bundle, but when the android is running it shows the next message 2020-01-05 23:15:45.366 26210-26210/com.note.principal W/.note.principa: Accessing hidden...

Rollup + Babel transpiling still creates `const`

I have this setup to transpile ES6 Modules with rollup + babel to browser targets. I tried a lot of things (atm is "ie10") but the transpiled JS still contains const instead of var. I also had a...

Babel throws a type error when exporting aggregates

When running my gulp task, I get the following error: SyntaxError in plugin "gulp-babel" Message: /Users/******/Repos/******/src/scripts/config/index.js: Unexpected export specifier type > 1 |...

NPM Install is broken

I have tried everything and persistent npm errors stop me doing a npm install please does anyone know how to fix and get rid of these errors to allow me to do a normal npm install. 21 verbose...

Unable to use jest to test Svelte components which import SCSS from inside node_modules

I'm attempting to add Jest testing to a project which uses svelte-material-ui. I was following along with this issue on GitHub, but could not get it to...

Corrupted Javascript bundle in Production but running fine in Development mode

I've a React app with node server and I had perfectly fine production bundle a few days ago but recently my production bundle is corrupted. However my dev bundle is working perfectly fine. Can...

Configuring webpack and babel to transform rest arguments in a node_modules dependancy

I'm using webpack and babel to compile my JavaScript to ES5. It's working nicely on my own code, but my library started throwing errors in Internet Explorer browsers when I added debug as a...

AzureDevOps pipeline - Nightwatch selenium standalone installation issue - Unable to run npm run 'e2e-setup' (contains 'selenium-standalone install')

I am trying to setup selenium standalone server with various browsers the script works fine on my local machine but same has issues working on Azure cloud using Azure DevOps tool. From the logs...

Optional-Chaining does not work in create-react-app

In a create-react-app project, I am using @babel/plugin-proposal-optional-chaining in my `.babelrc However, I have this error: Module parse failed: Unexpected token (22:16) You may need an...

Babel not handling ES6 import of react-native package

In Babel 7.11, with react-native 0.63.2 and react-native-web 0.13.9, I cannot get webpack-dev-server to build the app because it does not recognize 'import' within react-native. I have taken...

Error Installing Gatsby Starter 'Something went wrong installing the "sharp" module'

Problem I am trying to set up a Gatsby starter project on Windows. Specifically, this starter project: https://www.gatsbyjs.com/starters/hasura/gatsby-gitbook-starter/ Versions: Node:...

"Error: Command failed with exit code 1: npm install" when create a gatsby site

I'm a newbie in gatsby, everytime I try to create a gatsby site I am getting this error: Error: Command failed with exit code 1: npm install I tried this : $ gatsby new gatsby-simplefolio...

Webpack and Babel configuration problem on Chrome Dev Tools

i'm trying to build new project, i wanted it to have webpack and babel, app works, refreshes on webpage but i'm having issue with what i get in Chrome Dev Tools. I tried with adding...

module.exportDefault is not a function

I'm not sure if this is a Meteor problem, but I can't find anything like it out there. Version: Meteor2.0-beta.4, but also Meteor 1.11, 1.12 With a fresh checkout and meteor npm install, I run up...

Laravel Mix: "npm run prod" fails but "npm run watch " works fine- React

I have a laravel 8 app and i'm running react on it. I have successfully built my application but now I need to compile my app for production, but it keeps failing whenever I run npm run prod. And...

Tree Shaking issues - Rollup with preserveModules set to true

First of all great work with such a superb library that has taken bundling in JS by storm. I really like how the contributors continually push themselves to make this library even more...

Uncaught ReferenceError: exports is not defined when using React-Native web

I am trying to use React-Native web to convert an existing React Native App to Web App. The App is getting compiled successfully now, but the page appears blank and I get the following error on...

Configuring Jest with Rollup and Typescript

I created an app within a monorepo (Lerna) using yarn workspace. The architecture of the app is as follow: my-monorepo ├── node_modules ├── packages │   ├── package1(shared...

Error when trying to run a test file on React component

I encountered this error when I tried running a unit test for my React component. I use VSCode so I notice that when I wrote the expect().toBe(..), it doesn't auto suggest the term so I think...