Babel does not find a plugin

I have an app module and common module that is shared by several app modules. - app - src - package.json - webpack.config.json - .babelrc - common - lib - package.json -...

Babel plugin: what's the difference between "transform-object-rest-spread" and "syntax-object-rest-spread"

there are not so much detail in the documentation about these two plugins, I know both of them make syntax like {...obj} works. But how do I decide which plugin to use ?

Configure Webpack, Node, and the Babel object rest spread transform

I am building a Vue application with Vuex, and want to use the ... operator to merge objects, but I can't seem to install the Babel transformer. Here's my configuration file. It is the last const...

Unable to use the transform-object-rest-spread while piping to babelify from browserify

I'm trying to use the transform-object-rest-spread babel plugin in my gulp build pipeline. Normally I would add this as a plugin in the .babelrc file, but this pipeline is a new addition that...

Installing the ES2018 object spread operator babel plugin error

I want to use the new ES2018 spread operator for objects, and I found that this NPM package should enable it: babel-plugin-transform-object-rest-spread My package.json: "scripts": { ...

Why is babel-loader not transforming object rest/spread?

I recently discovered in one of my projects that almost all of my JS code breaks in Edge 18 after the use of object rest/spread syntax. That was surprising to me as I expected that babel is...

Babel error: "Error: Cannot find module 'babel-plugin-transform-object-rest-spread' from '/vagrant'"

I'm trying to upgrade from Babel 6 -> 7. I used npx babel-upgrade --write to assist with updating the package.json and then ran a npm install. When trying to run our webpack dev server, it fails...

Babel: can't get "@babel/plugin-transform-destructuring" plugin to work

<b>PS: It's the first time I've given up to the point of composing my first question here. Would be really grateful if someone could help. Thanks!</b> I'm trying to load my ReactJS web app in iOS...

object-rest-spread doesn't transform the spread syntax

Nothing seems to work to get webpack to recognize the spread operator. I've also tried adding the 7.0.0-beta's for babel-core and object-rest-spread. When I run, I get the message I need an...

Not able to spread an object with babel-plugin-transform-object-rest-spread added for vue cli 3 setup

This is partial code I am trying to get it working const myarr = [ {a: &#39;haha&#39;,}, {b: &#39;yoyo&#39;,} ]; const myobj = { a: &#39;some&#39;, b:...

Error: .plugins[3] may only be a two-tuple or three-tuple

I'm trying to get storybookJs to work, when i run the command npm run storybook i get this error: Error: .plugins[3] may only be a two-tuple or three-tuple This is my file .babelrc { ...

Webpack & Babel-Loader - Unexpected Token on Object Rest Operator, with transform-object-rest-spread Plugin Installed

I'm attempting to create a simple VueJS project, and am having trouble following one of the example instructions given in the Vuex documentation. I've created a Vuex module to encapsulate the...

Babel 7 spread syntax in IE/Edge not working

So i have babel 7 installed, along with the plugin "@babel/plugin-proposal-object-rest-spread" included within my preset-env, however I'm still getting the following error as it hasn't transpiled...

Can't import @fullcalendar in vue.js

import FullCalendar from '@fullcalendar/vue' throws ../../ullcalendar/vue in ./node_modules/babel-loader/lib?{"cacheDirectory":true,"presets":[["env",{"modules":false,"targets":{"browsers":[">...

Babel Preset does not provide support on IE11 for Object.assign - "Object doesn't support property or method 'assign'"

I am using babel-preset-env version - 1.6.1 for my react app, i am getting a error on IE :- Object doesn't support property or method 'assign' this is my .babelrc :- { &quot;presets&quot;: [ ...

How to fix the warning when use @babel/plugin-transform-typescript to compile typescript

When I use @babel/plugin-transform-typescript to compile typescript, the warning happens This problem is likely caused by another plugin injecting "_class" without registering it in the scope...

Module build failed: SyntaxError: Unexpected token (save-dev babel-plugin-transform-object-rest-spread plugin IS already installed)

OS: Windows 10 Pro NPM Version: 3.8.6 So, when I run npm start, the app runs fine. But when I run npm run build, I get the following error message: <!-- begin snippet: js hide: false console: true...

create-react-app with react-navigation

i have created an application from create-react-app and it works well. When I added react-navitation I got this error: ./node_modules/react-navigation/src/routers/StackActions.js Module parse...

Add "proposal-object-rest-spread" plugin to babel.config.js to fix Microsoft Edge error SCRIPT1028

EDIT: This issue seems to be fixed with the new beta of Microsoft Edge Chromium. (January 18, 2020) I need to add this Babel plugin to babel.config.js to get rid of the Microsoft Edge Browser...

How to polly fill in Parcel Bundler?

I am playing around with parcel bundler and I am a bit unsure how to get some of my stuff working. before in my .babelrc file I had this { &quot;presets&quot;: [&quot;@babel/env&quot;,...

Can't Install babel Plugin `transform-es2015-destructuring`

I'm trying to use the Babel plug-in transform-es2015-destructuring in my Mocha tests, but I'm having a problem: $ node_modules/mocha/bin/mocha --compilers js:babel-core/register...

webpack 4 : bundle js not found

I recently upgraded to webpack 4. The page is getting loaded successfully and whenever changes happened it refreshes the page automatically using webpack-dev-server. It does very nice but in the...

Cannot find module 'babel-plugin-transform-decorators-legacy'

After npm run eject (this was needed in order to change the webpack.config), I've run into the following problem during the app compilation: Cannot find module...

Enable destructuring objects rest properties with Babel?

I noticed that Babel wasn't transforming this: function({ param, ...rest }) {} This syntax is already supported in the latest popular browsers. However, according to Mozilla...

plyr polyfilled, Module parse failed with babel and webpack

i have an issue while compiling with symfony/webpack-encore when i upgrade the plyr video player library. Symfony version : 4.3 a snippet from my package.json file: &quot;devDependencies&quot;:...

babel-plugin-styled-components not work with preset-typescript

I use Typescript in my project and use Babel7 preset-typescript to transform Ts. And I want to add babel-plugin styled-components to my project, but it does not show component display class...

Uncaught Error: Element type is invalid: expected a string (for built-in components) or a class/function... after clicking the Add button

I am trying to run my React application, it compiles successfully (with warnings) but get this error message when I try to click the button. Here is my App.js: ``` import React from...

ES6 destructuring and spread operator not working correctly

I've got a strange behaviour when destructuring an object with only numbers as key and using the spread operator to collect all other objects. This problem happens in my ReactJS app with babel set...

Babel doesn't compile es6 to es5 when trying to test with Mocha

I need some help. I am trying to use Mocha for testing in a react/readux application. Unfortunately there seems to be a problem with compiling the code to es5, because I get this error: Unexpected...

Upgrading from using Gulp to Webpack with Laravel Mix

I have been in the process of upgrading a project originally built in Laravel 5.2 to Laravel 5.6. Back in Laravel 5.2, we were using Gulp with Laravel Elixir. In Laravel 5.6, they are now using...