binfmt-support - not allowing me to echo to register

I am using ubuntu linux. Trying to add support of ARM interpreter to binfmt. I am getting permission denied error. Just added support to binfmt on my machine :--- sudo apt-get install...

apt-get install build-essential not working on vagrant through provision

I have the following in my Vagrantfile. It install vim, but it does not install nodejs, git etc. How to change it so that it run apt-get install build-essential git-core python-software-properties...

Can't install supervisor on a Docker container ubuntu:trusty

I am trying to install supervisor inside a Docker ubuntu:trusty container. This is a small example Dockerfile that demonstrates my problem: FROM ubuntu:trusty MAINTAINER someone...

Install pip in docker

I'm not able to install pip in Docker. Here's my Dockerfile: FROM ubuntu:14.04 # Install dependencies RUN apt-get update -y RUN apt-get install -y git curl apache2 php5 libapache2-mod-php5...

How to install Scrapy on Ubuntu 16.04?

I followed the official guide, but got this error message: The following packages have unmet dependencies: scrapy : Depends: python-support (>= 0.90.0) but it is not installable ...

Executing Jar with "java -jar executable.jar" is OK but even with execution permission, "./executable.jar" returns a "Bad Magic Number"

I have a small application that I build with maven : <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-assembly-plugin</artifactId> ...

Why Docker container images become so large while deploying Python 3.6, Virtualenv, Flask, Gunicorn on Ubuntu 16.04?

While deploying the flask application within virtualenv python3 -m venv FLSK-ENV Dockerfile: FROM appcontainers/ubuntu:xenial MAINTAINER user <user> RUN apt-get install -y...

Using qemu Raspbian: installing libc6:i386 fails

this is my first post on this forum. I am trying to get qemu running on my Raspberry Pi 3 with Raspbian stretch installed. My brothers DCP-350C scanner driver is only available precompiled on...

How do I run a multiarch Docker image for a foreign architecture?

With the new multiarch Docker infrastructure, you can run, say, python:3.6 and it will automatically choose the right image you based on the host architecture. Now, how can I override this and run...

qemu-user cannot find shared libraries when run a dynamically linked executable

I have created a c++ app on Debian Jessie 8.10 amd64 targeted for arm architecture. I cross compiled the source code for armhf following the link...

buildozer(kivy,python) failed in copying generated apk to the home dir on docker virtual machine

I tried to run buildozer in docker virtual machine to generate andorid app package(.apk). After tried and filed sometimes, his Dockerfile(https://github.com/jedie/kivy-buildozer-docker) was...

Can't install Java9 due to download.oracle.com HTTP request sent throws 404 error

I can't install automated Java9 installation in UBUNTU16 machine which was working fine since long. Is this due to intermittent network connectivity of download.oracle.com server? It usually works...

0% [Connecting to in.archive.ubuntu.com takes too long time

whenever i run command who have to connect to archive.ubuntu.com, that command takes too long time to complete it task. sudo apt install oracle-java8-installer -y Reading package lists......

Qemu Debian x86 on RaspberryPi

I want to create i386 environment with QEMU and chroot on Raspberry Pi. I am using Raspberry Pi ver B, but I guess it should not matter much which version is used. So far I did: apt-get install...

Installation of python module using `pip` during `docker build` fails

I'm trying to build a Docker container in which I want to install some Python modules using pip (these modules will eventually be needed to build an app). I have written the following...

binfmt_misc problems in ubuntu18.04 under docker

Trying to get a cross chroot running under ubuntu:18.04 in a docker container. While trying to install binfmt-support (dependency of qemu-user-static) this happens: ~ docker run -it ubuntu:18.04...

Error running docker build for arm32v7 container on amd64 linux machine: standard_init_linux.go:207

I have an amd64 linux machine that I'm using to build an arm32v7 container. When docker build encounters the first RUN command, it errors out with: standard_init_linux.go:207: exec user process...

Dockerfile compatibility with Raspberry Pi?

I have built the image from the following Dockerfile in my Rpi Kubernetes cluster. However, I was getting status of CrashLoopBackOff for my Pods. After a bit of search on the internet, I realized...

Linux kernel on ARM Cortex-M: how to build proper executables

I need to build a complete linux development framework for a Cortex-M MCU, specifically a STM32F7 Cortex-M7. First I've to explain some background info so please bear with me. I've downloaded and...

Cannot run Flask on Docker (ModuleNotFoundError)

I have been trying to run my Python API (using Flask) with Docker for a while, but keep running into this issue: ModuleNotFoundError: No module named 'flask' Running this on Mac OS X (10.14.5)...

Bus error when attempting to run Wine under a x86 chroot environment on Raspberry Pi

After following the tutorial at https://www.novaspirit.com/2019/04/15/run-x86-arm/ with a few modifications (I used /x86/ as the chroot directory and installed wine via apt-get), attempting to run...

Docker Container Exiting With 137

I run several docker containers on a raspberry pi. After a short while two of the containers exit with 137. 137is OOM (out of memory) or Sigterm. I'm not sending Sigterm as far as I know in my...

How to link against Capstone using CMake?

I'm trying to use the Capstone disassembly framework in a C++ project on Ubuntu. I ran the following command to install the development package: sudo apt-get install libcapstone-dev This...

Docker - Cannot build multi-platform images with docker buildx

I'm trying to build a multi-platform (amd64, arm64 and armv7) image using docker buildx. Since I'm using an amd64 machine running Ubuntu 18.04, I followed the instructions on the Docker website...

How to install ansible 2.9+ on ubuntu 18.04 and utilize python3?

I'm trying to install minimal ansible 2.9.x on Ubuntu Bionic (18.04 LTS). The final goal is to build new disk image (using packer) on every commit and want the process to be as fast as...

K8S - Docker - ARM unbutu 64bits - qemu: uncaught target signal 11 (Segmentation fault) - core dumped

I installed a K8S cluster on my 4 raspberry pi 4 with 2gb of RAM and 32gb SD cards. On my master and slave nodes I installed qemu binfmt-support qemu-user-static in order to enable the support of...

can't install python3 on BeagleBoneBlack (revC)

The BeagleBoneBlack revC comes with Python2 installed. But we need to run Python3. However, trying to install python3 with apt-get fails. it seems to try to install version 3.2 which does not...

docker python flask gets " Do you want to continue" then "executor failed"

Trying a simple python flask web app in docker 20.10.2, build 2291f61. Doing the: docker build -t hello-world . starts out ok (please see below), but ends with: #6 2.866 After this operation, 305...

Install Python pip in ubuntu using ansible

I am trying to install Python-pip in ubuntu using ansible and then installing python package, But I am getting following error during Python package install task: failed: [X.X.X.X]...

pip install py-find-1st fails on ubuntu20 & centos with python3.9

This is my process. I start a new aws t2.micro ec2 on ubuntu20 and run this script sudo apt-get update sudo apt-get install gcc sudo apt-get install python3.9 sudo apt-get install...