Why is "pip install tornado" not installing the tornado module?

I am trying to install tornado onto my virtual environment, so I can get Jupyter to work. I tried pip install tornado and it seems like it runs but it only installs other modules. I even tried to...

SSL error with Python requests despite up-to-date dependencies

I am getting an SSL "bad handshake" error. Most similar responses to this problem seem to stem from old libraries, 1024bit cert. incompatibility, etc... I think i'm up to date, and can't figure...

Pipenv: Command Not Found

I'm new to Python development and attempting to use pipenv. I ran the command pip install pipenv, which ran successfully: ... Successfully built pipenv pathlib shutilwhich pythonz-bd...

Set up virtualenv using a requirements.txt generated by conda

I'm setting up a python project, using an Anaconda virtual environment. I'm generating a requirements.txt so other people can easily set up their own virtual environment for the project. I was...

Windows: Python SSL certificate verify failed

I've installed Anaconda and had SSL problems when trying to do API calls via Jupyter Notebooks: import requests import certifi r = requests.get('https://github.com/') print(r) This first...

PyTorch Cuda with anaconda not available

I'm using anaconda to regulate my environment, for a project i have to use my GPU for network training. I use pytorch for my project and i'm trying to get CUDA working. I installed cudatoolkit,...

Flask app broken after bson update in Heroku

I have a Flask app that uses mongoengine and running on Heroku, init I use the bson package and after I updateded it from 0.5.6 to 0.5.7 I started getting the following error message: [2018-11-23...

How to get messages from googles Pub/Sub sytsem by using the current pubsub subsciber

I need to receive published messages from googles Pub/Sub system by using a python based subscriber. For this I did the following steps: On the web console I created a project, a registry, a...

PortAudio library not found by sounddevice during runtime [WINDOWS]

PROBLEM: Similar to this question for Linux, I'm running into a OSError: PortAudio library not found after I package my app with pyinstaller and execute the .exe. (Note, I do not encounter any...

Why does Heroku has to install so many modules every time?

I am developing an app in Django and I am deploying it on Heroku. Why does, with each push, Heroku has to install all these modules? I know there is a way to prevent it from doing it all the...

Python Kivy won't use SDL2, insists on using pygame

I struggle to make Kivy (1.11.0) use SDL2 on Ubuntu 18.04 desktop. It keeps demanding pygame but that's been deprecated and I don't want to use it for a new project. On a fresh new Ubuntu 18.04 VM...

No matching distribution found for torch==1.5.0+cpu on Heroku

I am trying to deploy my Django app which uses a machine learning model. And the machine learning model requires pytorch to execute. When i am trying to deploy it is giving me this error ERROR:...

module 'tensorflow' has no attribute 'Session' cannot resolve

Please please please help me out here! I cannot resolve it! so... my python version is Python 3.5.6 and Anaconda version is Conda 4.8.3. I am working with Jupyter Notebook. I am working in...

ModuleNotFoundError: No module named 'extruct' (Python 3.7 Jupyter Notebook)

I installed with pip the "extruct package": pip install extruct Collecting extruct Downloading...

not able to install easyocr (pytorch error)

I am trying to install easyocr for python using pip pip install easyocr but it's not installing its givig me this in the terminal ERROR: torchvision 0.5.0 has requirement torch==1.4.0, but...

Apple M1: install psycopg2 package Symbol not found: _PQbackendPID

pg_config venv ❯ which pg_config /Applications/Postgres.app/Contents/Versions/latest/bin/pg_config pip3 install -r requirements.txt requirements.txt venv ❯ cat requirements.txt -i...

NameError: name '_mysql' is not defined -- On airflow start in MacOSX

There are numbers of articles on the titled question but none of them worked for me. The detailed error is as follows: Traceback (most recent call last): File...

How do I tell pyinstaller to use python-certifi-win32 with --onefile option

I have a small scirpt which is using the tableau rest api to download data from tableau views. As the script is running in a corporate environment, I have to use SSL. That's where the...

PyMongo [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate

I'm using Python 3.9.5 and PyMongo 3.11.4. The version of my MongoDB database is 4.4.6. I'm using Windows 8.1 I'm learning MongoDB and I have a cluster set up in Atlas that I connect to. Whenever...

Poetry hangs when installing torch

I'm trying to add pytorch_pretrained_bert package, but it hangs on downloading torch. I've been waiting for almost 30 mins already. I'm running this command: poetry add pytorch_pretrained_bert...

urllib.error.URLError: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1108)

import yfinance as yf msft = yf.Ticker("MSFT") msft.info I tried to print msft.info and got 'urllib.error.URLError: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed:...

ImportError: Could not find the DLL(s) 'msvcp140.dll or msvcp140_1.dll'. Even when the files are located in the %PATH% directory

I receive the following error when importing tensorflow (base) PS C:\Users\Rostyslav\GIt\GNN-GCP> python run_model.py --train --save Traceback (most recent call last): File "run_model.py", line...

ModuleNotFound: dateutil.parser

Here's what I'm running into: (.venv) PS C:\Users\<redacted>\onedrive\dev\python\code\kb4> py kb4.py Traceback (most recent call last): File...

Tensorflow Object Detection Api M1 Macbook Conflict Error

Machine: MacBook Air M1 2020 OS: macOs BigSur 11.4 Python version of venv: Python 3.8.6 Tensorflow version: ATF Apple Tensorflow 0.1a3 Pip version: 21.2.4 I have installed Tensorflow from...

Package streamlit app and run executable on windows

this is my first question on Stackoverflow. I hope my question is clear, otherwise let me know and don't hesitate to ask me more details. I'm trying to package a streamlit app for a personal...

Python: matplotlib.pyplot.show() is not showing the plot

import matplotlib.pyplot as plt plt.plot([1,2,3]) plt.show() input("Press enter to continue...") If I run the script above within VS Code, or even within command prompt, the plot canvas only...

Poetry | AttributeError 'Link' object has no attribute 'name'

I want to install packages from poetry.lock file; using poetry install. However, the majority of packages throw the exact same error, indicating a shared fundamental problem. What is causing this?...

Getting DLL error when running tensorflow/keras program on python gpu 3.8

I am trying to run my simple AI program but I keep getting this DLL error: ImportError: Could not find the DLL(s) 'msvcp140_1.dll'. TensorFlow requires that these DLLs be installed in a...

PIP failed to build package cytoolz

I'm trying to install eth-brownie using 'pipx install eth-brownie' but I get an error saying pip failed to build package: cytoolz Some possibly relevant errors from pip install: ...

Tensorflow Object Detection API taking forever to install in a Google Colab and failing

I am trying to install the Tensorflow Object Detection API on a Google Colab and the part that installs the API, shown below, takes a very long time to execute (in excess of one hour) and...