dpkg-shlibdeps: error: no dependency information found for

I'm compiling a deb package and when I run dpkg-buildpackage I get: dpkg-shlibdeps: error: no dependency information found for /usr/local/lib/libopencv_highgui.so.2.3 ... make: ***...

How cancel Downloading Async?

I've got a problem. How can I cancel a download ? client.CancelAsync(); Doesn't work for me, because if I cancel a download and start a new one the code still tries to access the old download...

Mount directory in Container and share with Host

I thought I understood the docs, but maybe I didn't. I was under the impression that the -v /HOST/PATH:/CONTAINER/PATH flag is bi-directional. If we have file or directories in the container, they...

sudo checkinstall - installation failed

I'm trying to install ffmpeg on Raspbian by following these steps : cd ffmpeg ./configure --prefix=/usr time make -j 8 cat RELEASE sudo checkinstall but when I do the sudo checkinstall step, it...

Update python on linux 2.7 to 3.5

So I updated python using these instructions: sudo apt-get install build-essential checkinstall sudo apt-get install libreadline-gplv2-dev libncursesw5-dev libssl-devlibsqlite3-dev tk-dev...

Python versions on Linux

Yesterday i reinstalled my Linux Mint duo similar issue I am facing right now. I installed Python 3.6 with: apt-get install build-essential checkinstall libreadline-gplv2-dev libncursesw5-dev...

ignoring ensurepip failure pip requires ssl/tls error in Ubuntu 18.04

Getting ignoring ensurepip failure pip requires ssl/tls error when trying to install python and pip in Ubuntu 18.04 Trying to run sudo make install gets the above error. # Download Python curl -O...

Installing Basemap with Python3.6 on Ubuntu 18.04

I have been trying to get Basemap up and running for the past couple of hours. Following this tutorial I run: conda install basemap in my venv on Pycharm. Installation goes as planned and I get a...

What are the steps to build LLVM from source for Ubuntu Bionic Beaver?

Not all Kaleidoscope examples compile. Some do. In the build process of LLVM Cmake complains "- Failed to find LLVM FileCheck" My interest is in developing a toy compiler using LLVM - on a Ubuntu...

Install PyQt5 on Raspberry for Python3.6

Since I found no answer for my question, neither in older posts nor in other forums, I want to ask the stackoverflow community for advice. I am using a raspberry pi 3B+, version 9.4 (lite) with...

How to install 2 python versions on ubuntu 18.04? (Without using virtual environment)

I am trying to install 2 python versions: 2.7.14 3.7.2-1 I created them by using make commands: wget https://www.python.org/ftp/python/2.7.14/Python-2.7.14.tgz tar -xvf Python-2.7.14.tgz cd...

Can't install python 3.6.5

I am trying to install python 3.6.5 from source and link it to openssl. This is my shell script: # new openssl install curl https://github.com/openssl/openssl/archive/OpenSSL_1_1_1a.zip | tar xz...

How to compile FFmpeg as static (single file)

I would like to compile FFmpeg 4.1.3 as static or single file, After compiled. It's shared binary. Here is what I do Install the dependencies apt-get -y install build-essential autoconf automake...

Source compiled OpenCV crashes on Google Colab without any error messages

I am experimenting with compiling OpenCV on Google Colab from source. My script is as follows: !pip3 uninstall -y opencv_python !pip2 uninstall -y opencv_python !apt purge --remove...

How to use nsdialogs REMOVE or REPAIR feature in NSIS script?

My installer working fine without nsdialogs, If i add nsdialogs its not working good.I can't call nsdialogs in correct place.where i need to call nsdialogs? Var hwnd Var Dialog Page custom...

docker: building opencv with cuda image size too big (22.4 GB)

After countless errors i have been able to build an image of opencv with cuda for python. But image size is way too big. I have tried to reduce the size by following some articles but failed to do...

SQL Server 2017 for Docker does not work (because of missing ipv6?)

I am working on a SQL Server 2017 Docker container. The database will never start. I have customized the image only to run the health check. Same problem occurs without using the cusotmized...

Create extension for Postgres 11 results in "could not access file $libdir/..."

I try to follow this simple example. So, I created a folder addme with four files. Makerfile looks like: MODULES = addme EXTENSION = addme DATA = addme--0.0.1.sql PG_CONFIG = pg_config PGXS :=...

Rails view rendering is slow in Docker

I'm dockerizing a Rails application, and I'm not sure why the views render so slow. It takes nearly 2 seconds to navigate between any two pages, with some pages taking longer. This problem does...

Can't connect to Snowflake with newly created Airflow environment on EC2

I have an AWS Cloudformation template that creates a basic airflow environment (one EC2 t3.small instance hosts both the webserver and scheduler, no external DB, no celery executor). This...

Custom shell script not working at boot with EC2 User Data in Launch Templates

I'm having trouble making a bash script run when adding it to the user data on an ec2 launch template. I've looked at suggestions and tried multiple approaches including AWS's suggestion using...

Building Python and OpenSSL from source, but ssl module fails

I'm trying to build Python and OpenSSL from source in a container. Both seem to build correctly, but Python does not successfully create the _ssl module. I've found a few guides online that say...

python 3.6.10 pip3 TLS/SSL not configured

I'm a begginer in Python, and some problems are happening. This is a script for installing python 3.6.10: sudo apt-get update sudo apt-get upgrade sudo apt-get install zlib1g-dev apt-get install...

How to build a ruby .deb package?

I've been searching google and I found another question on stackoverflow with no answer and some people saying they had success with checkinstall. I'm following this: sudo apt-get install uuid-dev...

pip3.7 ubuntu 16 pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available

I'm using gitbash virtualbox and ubuntu 16 and windows 10. I've installed the python 3.7 package from python.org and before I did that I installed build-essential checkinstall...

Install nodejs issue

i'm following a tutorial i found to install nodejs and nmp bash but after i tried to build the .deb package i get this message if [ ! -r node -o ! -L node ]; then ln -fs out/Release/node node;...

How to Install python3.8 using checkinstall on debian 10?

I've installed debian 10 on server. PRETTY_NAME="Debian GNU/Linux 10 (buster)" ID=debian arch: x86_64 It had python version 3.7.3 installed on it, so i tried to update it to version 3.8.5 and I...

Raspberry Pi 4 OBS Virtual camera

I wrote this bash file, but not working. I think RPI just 32bit and the package what I found 64bit. Do you have any idea, how to find 32bit version of the package or how can I solve the problem? I...

Docker openCV installation Issues

I'm currently trying to run an application using Docker but get the following error message when I start the application: error while loading shared libraries: libopencv_highgui.so.4.4: cannot...

How do I deal with an internal compiler error (cc1plus: gimplify) when installing c based python libraries (OpenCV2) on a Raspberry PI?

I've been trying to install the OpenCV2 libraries for Python 3 on my Raspberry PI 3B. I started this process by installing Python 3 through apt and using pip3 to install OpenCV. However the...