Globally available Gemfile

I have numerous gems that I use across all Rails projects, but that aren't part of the projects' Gems, for example powder for managing POW. It would make sense to me to manage these with a global...

Capistrano 3 not deploy and show this error SSHKit::Command::Failed: rake stdout: Nothing written

I have used rails 4 and Capistrano 3. When i depoly with Capistrano fail during rake assets:precompile and show following error INFO [1c9c2531] Running ~/.rvm/bin/rvm default do bundle exec rake...

Why isn't chruby saving my default Ruby?

I'm setting up a new machine and trying to install Ruby with chruby. I used ruby-install to install both ruby 2.3 and 2.1.2 because that's what everybody else on my team is running. When I run...

chruby not changing to the proper version of ruby according to the value in .ruby-version on new terminal tab

I am using source /usr/local/opt/chruby/share/chruby/auto.sh to auto change ruby to the version in .ruby-version, but unfortunately this only works on cd. When I open an new tab in my mac...

Ignoring GEM because its extensions are not built

On both my work and home computers, I recently upgraded Ruby to 2.3.1, using ruby-install. I use chruby as my Ruby switcher. I started seeing this warning in my terminal: Ignoring bcrypt-3.1.11...

Not able to run /etc/profile.d/chruby.sh while deploying using Capistrano in Rails

I have been trying to deploy my rails application on an EC2 instance. The steps which i have taken already are Locally: I installed all the gems by writing in Gemfile and bundle install: group...

How can I get bundler to use the Ruby version set by chruby and .ruby-version?

I have the pleasure of setting up a development environment for an application running Ruby 1.8.7. Unfortunately bundler is not using the version of Ruby set in .ruby-version by chruby. Also, I...

rails can't find rake gem

I have a basic Rails app running in docker. I can start it up just fine and serve responses. I can run rake -T just fine. But I cannot run a Rails generate command. It fails telling me Could...

Rails Capistrano rbenv Puma bundle: Command not found

I'm trying to run cap staging deploy to an AWS instance, which is our staging server. Everything works, including bundle install... But when it gets to running the Puma server it fails: Command:...

bundle install failed but still stop sidekiq when use capistrano deploy

When I use capistrano to deploy my rails app, the bundle install before stop sidekiq, when bundle install failed, the sidekiq should not be stopped, but in fact, the sidekiq process is...

ionic cordova run ios - Export failed with code 65

I'm done with research on this error. I get following error when trying to run ionic cordova run ios --livereload: [cordova] Non-system Ruby in use. This may cause packaging to fail. [cordova] ...

Bundler using wrong Ruby version

When I try to start my Rails server, I get the following error: $ bundle exec rails s Your Ruby version is 2.3.7, but your Gemfile specified ~> 2.3.8 I don't understand why that happens though,...

Could not find gem 'another-jekyll-plugin x64-mingw32' in any of the gem sources

I am trying to use jekyll on windows however when I run bundle exec jekyll serve I get an error saying Could not find gem 'rspec (~> 3.4) x64-mingw32' in any of the gem sources listed in your...

Error log file for deploying Rails app to Elastic Beanstalk

I've been spending the day trying to figure out how to deploy this Rails app to Elastik Beanstalk. After much research, I've finally gotten closer to deployment but keep getting this error log and...

How do I fix incompatible library version?

I have been having an issuing loading my app. I built it in an older version of rails and a few months back upgraded my rails to 5.0.7.2 With ruby 2.5.1p57. I'm using Homebrew with chruby. I'm...

Docker Compose and Rails: Bundler::GemNotFound upon launching. Is bundler not looking at the right gemset?

I'm trying to follow the instructions to setup a Rails and Postgres app with Docker Compose as stated on the documentation here -> https://docs.docker.com/compose/rails/. However, when I try to...

How to generate a missing secret_key_base on AWS

I'm trying to launch my Rails 6.0.2.1, Ruby 2.6.5 application in production using AWS EB CLI, however, I continue to encounter this issue. I've tried every solution that exists within the first...

Bundler Error - Cannot Find rake-13.0.1 even though it is installed

I have a Rails import job that run as a cron job setup through the whenever gem. It was running correctly until I recently updated the app. Now we are seeing the following Error in the logs when...

Rails bundle can't install gem ffi

Note: I gave up on this and decided to try Rails 6 and Webpacker rather than fighting this fight. Moving on to other fights. An error occurred while installing ffi (1.13.1), and Bundler cannot...

Rails server failing trying to load spring on new app (ruby v 2.7.1, rails v 6.0.3.2, MacOS 10.15.5, bundler v 2.1.4, chruby)

{9:08}~/dev/rails ➭ which ruby /Users/jay/.rubies/ruby-2.7.1/bin/ruby {9:08}~/dev/rails ➭ which rails /Users/jay/.gem/ruby/2.7.1/bin/rails {9:08}~/dev/rails ➭ rails -v Rails...

Could not find rake-13.0.1 in any of the sources while Rails Capistrano deploy

Im trying to solve it whole day. I have Ruby on Rails project and trying to deploy it on VPS server. But got same error every time (sometimes with different gems names): Run `bundle install` to...

Cannot run rails server locally wrong ruby version

I recently install ruby 2.7.1 using rbenv. I have made sure that .ruby-version and Gemfile file both have 2.7.1 as ruby version. Now i cannot run rails s locally, doing so returns the following...

"Could not find concurrent-ruby-1.1.7 in any of the sources" when deploy rails with capistrano

I saw a lot of similar questions here, but nothing of provided advises has helped. Every time I run cap production deploy I got error: ... DEBUG [9b1f0199] Running RBENV_ROOT=$HOME/.rbenv...

how to fix : Bundler could not find compatible versions for gem "nokogiri"

I'm new to ruby, I was trying to run my first app but when I start the server I get this error: Bundler could not find compatible versions for gem "nokogiri": In Gemfile: capybara (>= 2.15)...

How do I fix this error: "Your bundle only supports platforms [] but your local platforms are ["ruby", "x86_64-darwin-19"], and there's no compati..."

When I run bundle install this is the response I get "Your bundle only supports platforms [] but your local platforms are ["ruby", "x86_64-darwin-19"], and there's no compatible match between...

Rails Capistrano production deploy runs a wrong command line which leads to an error 'invalid option --daemon'

I've been trying to fix this error, but I can't find a solution yet. I'm about to deploy a Rails application to production using nginx, puma, and capistrano, but I get an error when running this...

After upgrading environment to Ruby 3.0.1, my app continues to use 2.6.3

I initially created my environment will ruby 2.6.3 via the tutorial I was following and the practice app. I started building my own custom app and when I realized via Heroku that I wasn't using...

Build fails when deploying Rails application on Amazon Linux 2

I am migrating my existing Rails application from Amazon Linux AMI to Amazon Linux 2. I was able to upgrade my Rails linux environment to AL2 but the deployment is failing. The deployment...

ruby-install fails when installing ruby 2.6.x and 3.0.x on mac osx 11.6

When running ruby-install, it fails to build. This also reported in rbenv issues (https://github.com/rbenv/ruby-build/issues/1725). for example when installing ruby 2.6.8 # installing via...

Rails new command giving errors

I've been racking my brains trying to solve these issues. Every time I try to create a new Rails app using the rails new command, I get errors. The corresponding files are created, but I really...