Run prettier from CLI with config in package.json

I'm trying to run Prettier from CLI defining the config in the package.json file as it's explained in Offical Docs > Prettier uses cosmiconfig for configuration file support. This means > you can...

Cannot find module '@expo/metro-config' after run nix react-native start

I have an error in the execution of react-native-start. The error returns this message: error Cannot find module '@ expo / metro-config' Requires battery: /.../project /...

Cannot find module '@expo/metro-config' when i run "npx react-native start

I'm trying to run the command "npx react-native start" and shows this error error Cannot find module '@expo/metro-config' Require stack: - D:\Projetos\apporto\metro.config.js -...

Suppress a specific ESLint warning: File ignored by default

Hopefully this is a reasonable question but it's possible I'm misunderstanding something. I get this warning raised on 9 seemingly random .js files in my project's node_modules dependency...

I try to get webpack working in my create-react-app but I get this massive error

I try to get webpack working in my create-react-app but I get this massive error and it's because I follow tutorial for some places. The tutorials are inconsistent because of as I understand that...

Ubuntu frozen when I try "npx create-react-app myfirstreact:

I'm not sure what to do. It just gets to this progress bar and stops at a random point. Creating a new React app in /home/cade_heinb/myfirstreact. Installing packages. This might take a couple of...

No matching version found for [email protected]^1.1.0

Dependencies for npm project: "dependencies": { "angular-chart.js": "1.1.0", "angular-cookies": "1.5.7", ...

Why is Powershell erroring after successful TAP tests?

I'm running Node test on Windows with Appveyor, and hitting a problem in one environment only: Powershell with Node 0.10. In the other Node versions I get output like this: npm test #...

Failed to run Jetifier , can't find module 'which' error in react-native

No Idea what is happening or what I need to fix. I'm writing sentences so I can post. No Idea what is happening or what I need to fix. I'm writing sentences so I can post. No Idea what is...

Error installing Angular using npm due to require-from-string

How to resolve this error as I am not able to install Angular. Please see the below exception: C:\Users\absin\node>npm install -g @angular/cli npm ERR! code ETARGET npm ERR! notarget No...

Socket timeout when trying to create a new vue project with vue-cli

I'm getting an error when I create a new Vue project using vue-cli. Each time the create fails on a "Socket timeout" but a different request? I updated node using nvm and installed the latest...

Styled components babel plugin in create-react-app with TypeScript?

Can I use the styled components babel plugin in a create-react-app application that uses TypeScript? I have read in the docs that there is a "macro [that] incorporates all the functionality of...

failing to compile when using jest in vue but test cases are passing

I'm using jest with vue.js and running my test successfully but my module building is failing. I couldn't understand why. here's my code. please help me.i'll provide more if...

Getting an error message creating a new app in Angular 5

Earlier today I created an Angular 5 app using the CLI. I do this all the time, and it worked fine. Then I downloaded some code that was already in Angular 4. I deleted the /src folder from my...

ionic apk build "Cannot find module 'caller-path'"

I have a ionic application with angular and i want to build the apk. I've run ionic capacitor add android And then when i run ionic capacitor build android i get an error An unhandled exception...

How do I install a template (CSS & JS) with Webpackers in Rails 6?

I am trying to install this theme - Cleopatra - built on Tailwind CSS in my Rails 6 app, but I can't quite make heads & tails of how to do it properly with webpacker. I am sure this should be...

Problems with npm install (Angular)

Today i try creat a new project. So i use this command: ng new NAME --style=less and in my cmder popped errors and warns. So i unistall my node and files in Roaming/npm and npm-cache. Then I...

PostCSS modules are loading from the wrong directory

I'm trying to get PostCSS CLI to work on Windows, to use with PHPStorm. I've got it working via command line options, but I want to use it with the javascript config file. Here are the commands I...

getting error on installing `@angular/cli` on mac system

I am trying to install the angular5 or later to my mac machine. but getting error(s) how to solve this? here is the error details: 03:56:57 {master} ~/arif/ng/mean-angular5$ node...

AutoPrefixer in Webpack that has SCSS not working

I'm trying to add auto prefixing to my webpack to add ie9 support. The instructions said to create a second config here: postcss.config.js module.exports = { plugins: [ ...

Starting Rails server gives error Webpacker::Manifest::MissingEntryError in Jumpstart::Admin#show

For context, I am using the JumpStart Rails Pro template as the basis for my Rails app. If it will help, the free version of JumpStart Rails can be found here. Moreover, the instructions for...

lingui macros throw error with bable-plugin-macros

I'm using lingui package in my React project with CRA and I get an error when using lingui/macro modules t method. When I build project got webpack warning message. Like this. Critical...

[email protected]^1.1.0 Error installing any package with NPM

Any package (even nodejs) results in this. I have so far taken action : Uninstalled all my dependencies Cleared my cache Reinstalled NPM / AngularCli Running any NPM command will unfortunately...

lint-staged is fine.But git commit get errors

Description When I use the lint-staged command directly everything is normal and I get no error message. But when I use git commit, it prompts me that eslint reports an error without generating...

Angular + Jest: Error: Uncaught (in promise): Failed to load C:footer.component.html

Unfortunately, I can't get Jest to work. I want to use it to build unit tests for my Angular webapp. I just noticed the following post, but nothing worked for me:...

How to Solve NPM Install error while installing the gatsby-rehype-inline-images package

I am trying to set up the ghost cms locally, I am getting an error message while adding a package to the project. using the theme provided by Jamify for this ghost cms installation process I tried...

Running in circles with errors trying to git push heroku master and yarn

I've been trying for 2 days to deploy my Rails/React app to Heroku and it's been a nightmare. I think I finally have the Rails side up but the React side is nothing but grief. The latest issue is...

Gatsby + Heroku deploy error "The path passed to gatsby-source-filesystem does not exist on your file system"

I'm trying to deploy a Gatsby application to Heroku but I got stuck in this error: error The path passed to gatsby-source-filesystem does not exist on your file...

Receiving ERROR #98123 after gatsby develop

I'm receiving this error after I run gatsby develop. I have tried following the steps from gatsby.com Not sure the reason for this error. I have tried gatsby clean, removing files that were...

Initializing private npm package generates super long dependency

I am a junior developer and got a question while packaging my react library. When I run npm init --scope="scope_name" command, it generates super long dependencies in package.json...