How to specify a port to run a create-react-app based project?

My project is based on create-react-app. npm start or yarn start by default will run the application on port 3000 and there is no option of specifying a port in the package.json. How can I specify...

How to add custom font in react native android

I want to set fontFamily to roboto thin of my toolbar title. I have added roboto thin ttf in assets/fonts folder of my android project, however it seems that it is creating issues while running...

React Native app stuck on blank white screen with remote debugging using Nuclide

Steps to Reproduce / Screenshots Apply all operations from the instruction: Create a blank React Native project with $ react-native init [project name] From the command Palette (Cmd-Shift-P)...

Trying to use fetch and pass in mode: no-cors

I can hit this endpoint, http://catfacts-api.appspot.com/api/facts?number=99 via Postman and it returns JSON Additionally I am using create-react-app and would like to avoid setting up any server...

react-navigation header has a faint line

This turned into a massive adventure and subsequently, a very large and messy post, so to spare you from having to read through the mess that I keyboard-farted out below, here's a summary: Main...

React Native + Expo : save pdf/word doc from url and use Linking to Open the file in a different app

I've been using the default create-react-native-app and would like to continue to do so as long as I can without ejecting. The feature I need for the app is to download a file to the app cache...

PSPDFKIT : Incorrect response MIME Type

I followed the PSPDFKit React tutorials available here I also copied my files to the /public directory and moved everything except pspdfkit.js from node_modules there and I updated my baseUrl...

My react project not working after deploy to firebase hosting

I'm following the instruction of this site and I'm already trying with an empty create-react-app project and It's working fine But when I'm trying with my existing project after deploy process was...

Error installing create-react-app with npm

When I try to install create-react-app (or nodemon) globally or even within a project, I get the following error. However, I can install other packages perfectly fine both globally and locally. I...

How do I setup routing for react in GAE? Directly routing to react-router-dom routes via URL fails in GAE on basic create-react-app?

ANSWER for now This was tough for me to get exactly right. Very little in the way of guidance via Google. I hope this helps others. As Dan Cornilescu pointed out, the handlers accept the first...

Create react app typescript does not load d.ts file

I have created a project using create react app typescript. I have a few d.ts files where I have defined interfaces types and enums. When I run start script. It is not able to load the d.ts...

Create SDK in React Native

I want to create an SDK for iOS and Android apps for service layer(basically backend interaction) in React Native. Output from the SDK should be either .a or .framework file, which can be imported...

create-react-app webpack configuration file

I have created a new react app using npx create-react-app and now I want to integrate a webpack.config.js file. I know I don't have to but it is a necessary step for an assignment. I have tried...

How to build bundle-stats.json in create react app?

I need to build bundle-stats.json to work with webpack-bundle-analyzer. Here how i'm trying build it , but it does not creating any file. npm run build -- --stats Could you please help me

Template not provided using create-react-app

When I type the create-react-app my-app command in my terminal, it appears to work - downloading all libraries successfully etc. At the end of that process however I get a message that a template...

create-react-app not working even when I update node

I am trying to run create-react-app and keep getting an error about updating my node version: The engine "node" is incompatible with this module. Expected version "^8.10.0 || ^10.13.0 ||...

How can I generate an AndroidManifest.xml from an existing react-native project?

I already have a react-native app created and I wanna access the user's geolocation. Well, I don't have any Android's folder and I need to add some permissions in AndroidManifest.xml. How can I...

Creating a HOC (higher order component) for cookies in nextJS

So I'm creating authentication logic in my Next.js app. I created /api/auth/login page where I handle request and if user's data is good, I'm creating a httpOnly cookie with JWT token and...

Docker and Flutter Web hot reload

I'm trying to web development environment with Flutter in docker with docker compose. *I stuck with a hot reload for Flutter, is there any way to make it work? (except installing VSCode on...

How to share QR code on react native expo?

I'm creating an app to generate a QR code, and then share it on social media. Currently, I manage to create the QR code, however, I'm lost at sharing the generated code as an image. I'm using...

(EACCES: permission denied, mkdir '/usr/app/node_modules/.cache) How can I create a docker-compose file to make node_modules a non-root folder?

I'm trying to dockerize a simple create-react-app project. (Is the initial project after running npx create-react-app test, no files were changed). The problem seems to be that in newer versions...

Problem with react-native-papere Theme using Expo and Stack Navigation

I'm working with Expo to create a mobile app with react native, I'm trying to include styles with react-native-paper and applying a custom theme to the whole project, but it doesn't apply any...

want to install react but facing spawn error

Windows PowerShell Copyright (C) Microsoft Corporation. All rights reserved. Try the new cross-platform PowerShell https://aka.ms/pscore6 PS C:\Users\Vishnu\react> npx create-react-app...

Typescript Box produces a union type that is too complex to represent

Rendering a Box produces the following error: Expression produces a union type that is too complex to represent.ts(2590) As I can see here, this is due to having both @mui/material and...

styled-components/macro isn't working with CRA

When i install a new create-react-app and add babel-plugin-styled-components and add displayName option to babel-plugin-macros.config.js it isn't adding readable classNames as in the documentation...

create-react-app says "Create React App requires Node 14 or higher." Fixing node gives "npm does not support Node.js v10.19.0"

I was trying to create a react app, but got following $ npx create-react-app react-demo npx: installed 67 in 6.045s You are running Node 10.19.0. Create React App requires Node 14 or higher....

Failed to load plugin 'flowtype' declared in 'package.json » eslint-config-react-app': Cannot find module 'eslint/use-at-your-own-risk'

I created a new React project with create-react-app. In the terminal npm start. Instantly get this error Failed to load plugin 'flowtype' declared in 'package.json » eslint-config-react-app':...

Node Sass version 7.0.0 is incompatible with ^4.0.0 || ^5.0.0 || ^6.0

I have a react project I created using create-react-app And I was trying to use sass in react by installing node-sass for react.js But I keep getting an error saying It's incompatible. Node Sass...

Errors when importing IPFS while using React

I can not import IPFS because some Webpack errors. I do not really know how to fix them but after searching some information I think that is something about Webpack 5. I did the following...

How to upgrade from tailwindcss 2 to 3 and create-react-app 4.0.3 to 5.0.0 (due to Post CSS 8 )

I created a project via create-react-app 4.0.3 which uses tailwindcss 2. I just tried to upgrade the project to tailwindcss 3, but quickly ran into troubles, since tailwindcss 3 relies on Post CSS...