how to successfully install pyproj and geopandas?

I have tried to install geopandas via I python by running !pip install geopandas, but this fails with "python setup.py egg_info" failed with error code 1 and then Path to long directory. I read...

Geopandas Installation

I am trying to install geopandas on my Mac OS X right now. What I have done: • Downloaded and installed Anaconda for Python 2.7 here. Graphical installer. • python --version returns the...

Import error of contextily package in python

I installed the package contextily with pip install contextily, it appears when I do conda list # Name Version Build Channel _ipyw_jlab_nb_ext_conf ...

Create conda environment: "Found conflicts!" when solving environment and "Finding shortest conflict path" running forever

I was provided with an environment.ubuntu.yml file to be able to create a conda environment. However, running conda create env --file environment.ubuntu.yml I get the following output: conda env...

Geopandas ImportError: The descartes package is required for plotting polygons in geopandas

I'am trying to run a simple geopandas code using ANACONDA spyder. However, I'am encountering an error. I have included the code and the error as below: -- here is the code: import geopandas as...

rpy2 ggplot2 does not plot a window in PyCharm

I am running import pandas as pd import rpy2.robjects.lib.ggplot2 as ggplot2 import rpy2.robjects as ro from rpy2.robjects import pandas2ri pandas2ri.activate() from rpy2.robjects.packages...

VS-Code doesn't plot gpd.GeoSeries().plot()

Hi I am trying to plot Geo-Data using VS-Code with geopandas My code looks as follows: import geopandas as gpd import geopandas.geoseries from shapely.geometry import Point import random import...

Plot polylines on top of OSMnx map

Using the OSMnx library, I'm trying to draw lines as polygons on top of a base map (with per-defined coordinates not adhering to the underlying network), but with no luck. I'm certain that the...

Error when installing osmnx (A GDAL API version must be specified) problem

I want to install osmnx, I wrote pip install osmnx in cmd, but it returns me an error: C:\Users\Horseman.mini>pip install osmnx Collecting osmnx Using cached ...

Display geographical points using geopandas

I want to display points on the map using a shape file as a map and a csv with coordinates. The code works but I don't understand how to show the figure map. My questions are: how to display the...

Error installing package in anaconda: Attempted to make prefix record for unknown package type

I'm getting the error below for doing any operation install, update or uninstall ERROR conda.core.link:_execute(700): An error occurred while uninstalling package '::ffmpeg-3.2.4-2'. Rolling...

Why does geopandas throw an assertion error, when the conditions seems to be met?

I am trying to make a WFS request and create a GeoDataFrame (from the geopandas library) with this data. However, when I run my code, an assert raises an error: assert len(bbox) == 4 I do not...

How can I improve the performance of my script?

I have a "seed" GeoDataFrame (GDF)(RED) which contains a 0.5 arc minutes global grid ((1802)(360*2) = 259200). Each cell contains an absolute population estimate. In addition, I have a "leech" GDF...

ImportError: cannot import name 'downsample' while importing lasagne in python 3.6

I am getting the above error with the following import statements on Google Colab GPU: import argparse #import cPickle import _pickle as cPickle import time import os import numpy as np import...

conda update InvalidSpecError

I am trying to update a conda environment: conda update --all but get the following Fetching package metadata ............. InvalidSpecError: Invalid spec: =20190808 output of conda list is as...

How to Successfully Plot a Choropleth Using gv.Polygons Instead of gv.Shape

Update 20/02/20 after further testing: I have 2 other shapefiles (one for UK by Postcode Area and one by Parl Constituency). When using gv.Shape with these I do not need to set the projection...

ModuleNotFoundError: No module named 'osmnx'

I have a github repo containing two files in the same repository. guimain.py and mapdraw.py. We're basically using tkinter and some other packages to make a GUI and for this we need maps of...

Geopandas data not plotting correctly

I don't have very much experience with GeoPandas at all, so I am a little lost. I am trying to plot this data jupyterNotebook dataframe image I have followed many references on the GeoPandas...

Retrieve data from a Polygon using osmnx

Before asking the question I am gonna show what I have done: I am using Pyhton and the packages I will soon show. I want to access the data that corresponds to Continental Portugal (the part next...

Kernel keeps dying and can't compile code (osmnx)

Good evening, I am currently trying to download data from a polygon and I can't compile the code because kernel keeps dying. Here is the code: import geopandas as gpd import pandas as pd from...

How to execute a batch script from an anaconda virtual environment (not from base)?

I want to run a batch file in a Conda environment, not in the base env, but in another virtual environment (here pylayers). I copied the activate.bat script from F:\Anaconda3\Scripts to...

Google Cloud Platform - AI Notebook is deleted after instance is stopped

I've set up an AI Platform Notebook Instance using a custom container with the below Dockerfile. I can access the notebook via the JupyterLabs interface. But, when I save everything and stop the...

vCard 4.0 doesn't display correctly, with labels ignored and wrong character decoding, among other things

I have created a vCard 4.0 file with a text editor according to RFC 6350 by IETF. It is simple, and looks kind of like this: BEGIN:VCARD VERSION:4.0 KIND:individual FN:René...

AttributeError: module 'osmnx' has no attribute 'project_gdf'

I've successfully downloaded the 0.14.0 version of osmnx. But have this error from output: AttributeError: module 'osmnx' has no attribute 'project_gdf' import matplotlib.pyplot as plt import...

Creating map with date slider to show the progression of values

I am trying to create a map showing the progressive lockdown measures globally using a date slider. So far I was able to create the map for a static date but my attempt at the slider doesn't work...

Installing cartopy from pip exits with various errors on Linux Ubuntu 18.04

The shell command pip install cartopy led to several errors. At first, the following error occurred: ERROR: Command errored out with exit status 1: command:...

How to remove edges in OSMnx

Questions about deleting edges from the osmnx network. I wrote the code below to analyze using the following example. example:...

Merge csv to shp: return with DataFrame instead of GeoDataFrame

I would like to join the table to shp and plot the Map out using Python. However, the merged DataFrame is no longer a GeoDataFrame... why??? Anyone can help please~~~ # Important library for many...

Giant IPKernelApp Error Using Hydrogen in Atom

Starting a few days ago, after months without issue, I began having a giant error box keep popping up when editing my code in Atom. I believe it is from the Hydrogen plugin, the weird thing is...

Sudden Tensorflow / Keras Google Colab dependency problems `AttributeError: module 'tensorflow._api.v1.compat.v2' has no attribute '__internal__'`

I have running a machine learning model (Matterport's Mask R-CNN) in google colab for a couple of weeks. All of a sudden today I am unable to run any of my notebooks due to I think some kind of...