What is alternative to -dpkg for Mac?

I'm trying to use dpkg command but in Mac OS X it doesn't seem to work for me dpkg -scanpackages -m . /dev/null -->Packages -bash: dpkg: command not found dns:Administrator$ man dpkg No manual...

Error install MySQL: Can't find messagefile '/usr/share/mysql/errmsg.sys'

I can't install MySQL in Ubuntu 14.04, because it always gets stuck in: apt-get install mysql-server-5.6 ... 2014-12-19 20:15:06 0 [Warning] Using unique option prefix key_buffer instead of...

dpkg error: pycompile: not found

sudo apt-get remove --purge mysql-server mysql-client mysql-common I am getting the following error as I try to remove mysql using the above command: Reading package lists... Done Building...

Automate MySQL install on Ubuntu 14.04 using Ansible

I'm trying to setup a Vagrant environment involving a few Ubuntu machines with Ansible and am having trouble writing an Ansible Playbook to automate the process. Primarily, I'm following the...

puppetlabs-java module unable to install

Using puppetlabs-java to install Java version 1.7.0_80 on Ubuntu. https://forge.puppetlabs.com/puppetlabs/java My site.pp is class { 'java': package => "java-1.7.0-openjdk-devel", ...

Where is the Postgres username/password being created in this Dockerfile?

So I was following this tutorial: https://realpython.com/blog/python/django-development-with-docker-compose-and-machine/ I have everything up and running, however theres a few things going on that...

OpenSSL 1.0.1f and "undefined reference to symbol '[email protected]@OPENSSL_1.0.0"

This morning I updated my OpenSSL version to the 1.0.1f, while compiling the project on which i am currently working i got this OpenSSL error from the linker: /usr/bin/ld: janus-dtls.o: undefined...

Python Requests - How to use system ca-certificates (debian/ubuntu)?

I've installed a self-signed root ca cert into debian's /usr/share/ca-certificates/local and installed them with sudo dpkg-reconfigure ca-certificates. At this point true | gnutls-cli mysite.local...

Cant access Postgres, getting an error about “/var/run/postgresql/.s.PGSQL.5432”

I was running a Django application with Postgres as backend database. It was working fine. All of a sudden, today I saw my database connection is refusing in the production server. So I logged...

pip3 install not working - No module named 'pip._vendor.pkg_resources'

When trying to install a package for Python 3 (in Ubuntu), using pip3 install packageName (or sudo pip3 install packageName), I get the following error message: Traceback (most recent call last): ...

Docker and Java - FontConfiguration issue

We've got a Java application that generates word documents using a 3rd party (Asposee but I don't think it matters here). The app is built from a simple Docker file: FROM openjdk:10-jdk-slim COPY...

Why does PyTorch not find my NVDIA drivers for CUDA support?

I've added an GeForce GTX 1080 Ti into my machine (Running Ubuntu 18.04 and Anaconda with Python 3.7) to utilize the GPU when using PyTorch. Both cards a correctly identified: $ lspci | grep...

VSCode on Ubuntu, clean reinstall

used Sublime Keymappings for years in vscode, but now I want to switch back to default mappings. So I tried to make a clean reinstall of vscode,following the suggestions on stackoverflow to do so...

List directory /var/lib/apt/lists/partial is missing. - Acquire (20: Not a directory)

When I executed sudo apt update I'm getting Reading package lists... Done E: List directory /var/lib/apt/lists/partial is missing. - Acquire (20: Not a directory) Also, I was getting a status...

Packaging an Electron app for Raspberry Pi 3

I cannot get an electron app I created installed on a Raspberry Pi 3 running Raspbian. I've used electron-packager to create the package, and then create a debian installer. Threw the installer on...

"Could not find the module Az.Accounts with given version" error when running Azure DevOps job in Docker

I install PowerShell and Az module in container based on ubuntu:16.04 RUN curl https://packages.microsoft.com/keys/microsoft.asc | apt-key add - && \ wget...

Yocto poky build fails on function do_rootfs

I've been following the steps on https://www.linux4sam.org/bin/view/Linux4SAM/PokyBuild to build a core-image-minimal and a microchip-headless-image for SAMA5D27 eval kit using Yocto. I am stuck...

Job for mariadb.service failed because the control process exited with error code

i deleted and reinstall mariadb and i get this error: *"Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl...

how to resolve dependency problems on ubuntu parsec?

I recently bought a raspberry pi to be able to test the Ubuntu OS. After several failures due to my limited knowledge of ubuntu, I finally succeeded. I also wanted to be able to access it from my...

Unable to get heroku started on cloud9 ide

I am running the command - curl https://cli-assets.heroku.com/install-ubuntu.sh | sh Which throws the following error - % Total % Received % Xferd Average Speed Time Time Time ...

Installing Mysql innodb cluster v8 with ansible

I want to install mysql v8 with ansible by downloading repo ( mysql-apt-config_0.8.15-1_all.deb ) and install it with dpkg,when i want to manually without ansible install, it prompts a window to...

change the docker runtime version

tl;dr Using dockerd, how do I select the v2 runtime? docker run warning suggests v2 runtime docker fails to run docker run hello-world. The only warning is consider using runtime v2 found in file...

Missing libappindicator3-1 installing Slack

Here's the output when I try to install Slack. $ sudo dpkg -i slack-desktop-4.12.2-amd64.deb Selecting previously unselected package slack-desktop. (Reading database ... 155664 files and...

GStreamer version mismatch

I needed the last GStreamer version (the 1.18.3). The thing is I'm on Ubuntu 18.04, and the default GStreamer version registered in apt is the 1.14.5. So I tried to build the version 1.18.3...

unable to install g++ and build-essentials in ubuntu 20.04

even after cleaning with apt-get clean it says there are broken packages. sudo dpkg -l | grep ^..r as mentioned in [1] returns nothing. $ sudo apt-get install build-essential Reading package...

Azure cloud-init: Failed to install packages

I have a simple cloud-init file: #cloud-config package_upgrade: true packages: - symlinks - wget - rsync - git but it is failing for my Azure (log provided at the end). This is the first...

How to install libs for R arrow package on ubuntu without internet?

I am working on Azure databricks and it's compute server is Ubuntu 18.04. I want to install arrow R package but without internet access because of security reasons. I downloaded arrow tar file on...

Python psycopg2 SCRAM authentication

I'm trying to run a python application that uses psycopg2-binary==2.9.1, but I'm hitting this error: psycopg2.OperationalError: SCRAM authentication requires libpq version 10 or above When I...

Why does nvidia-smi return "GPU access blocked by the operating system" in WSL2 under Windows 10 21H2

Installing CUDA on WSL2 I've installed Windows 10 21H2 on both my desktop (AMD 5950X system with RTX3080) and my laptop (Dell XPS 9560 with i7-7700HQ and GTX1050) following the instructions on...

CRC mismatch warning running helloworld.c from gdb on ubuntu 20.04.3

I have the most trivial program $ cat helloworld.c #include <stdio.h> int main(void){ printf("Hello World!\n"); return 0; } $ gcc -g helloworld.c -o helloworld Which I'm wanting to run under...