Custom font not working in React Native

I want to use a font from google fonts in my app. Here is the font. I have placed the .ttf file in app/fonts. package.json: { "name": "xxx", "version": "0.0.1", "private": true, "scripts":...

Webpack gives eslint errors while using npm link

I have a multi-package project set up, where I have one JavaScript package that relies on a TypeScript library. Initially I installed Sinopia and was reinstalling the library every time I made...

Error: File to import not found or unreadable: ~bootstrap/scss/bootstrap

I followed the instructions at getbootstrap.com thinking that everything would just work. It isn't so far :\ Everything seems to be fine until I try to load the page, at which point my Express.js...

Cannot find module create-react-app/script/start.js

something has changed in my program structure and due to its complexity i cannot exactly point where the problem. Ever since my application crushed and no longer working i have tried different...

Webpack: TypeError: Cannot read property 'properties' of undefined

Here is the branch and repo in question: https://github.com/Futuratum/moon.holdings/tree/dev /Users/leongaban/projects/Futuratum/moon.holdings/node_modules/webpack-cli/bin/config-yargs.js:89 ...

"ERROR command failed: npm install --loglevel error" when trying to do "vue create"

Vue CLI v3.2.1 ✨ Creating project in /home/mcaubrey511/portfolio. 🗃 Initializing git repository... ⚙ Installing CLI plugins. This might take a while... > [email protected] install...

vue-template-compiler/package.json missing module with every new project

Currently, I switched from linux to windows and started to create a programming environment. I don't remember similar problem on linux, but to the point: 1. Installed Node.js 2. npm install -g...

Module not found: Error: Can't resolve 'core-js/es6'

I've got a problem with my build process in relation to my React app. I always get the following error: Module not found: Error: Can't resolve 'core-js/es6' if I use this in a polyfill.js: import...

How to fix "FATAL ERROR: Ineffective mark-compacts near heap limit Allocation failed - JavaScript heap out of memory" error

I'm trying to deploy a reactjs application to heroku. While compiling assets, the build fails and produces this error: -----> Ruby app detected -----> Compiling Ruby/Rails -----> Using Ruby...

How to use static imports in Glitch?

For the life of me, I can't understand how to use ES6 static imports in a simple Glitch.com project. I found this project where someone uses a static import with no extra node modules or anything...

Sass Loader Error: Invalid options object that does not match the API schema

I'm using VueJS with the framework [VuetifyJS][1] (v2.0.19). I'm getting this error after running npm run serve: Sass Loader has been initialised using an options object that does not match the...

NextJS - export is broken (no CSS, no JS)

I am using NextJS (https://nextjs.org/) Version 9.0.6. My next.config.js looks like this: /* eslint-disable */ const withLess = require("@zeit/next-less"); const lessToJS =...

Nest js packaging hangs at build process of the serverless framework

So i did a fresh install of nestjs application and i am trying to add the serverless framework with it.I also added few of the packages to support the serverless framework { "name": "n1", ...

FullCalendar Vue: viewType "timeGridWeek" is not available. Please make sure you've loaded all neccessary plugins

I'm trying to use the timeGridWeek view of Fullcalendar Vue. I continually get the following error when: Error: viewType "timeGridWeek" is not available. Please make sure you've loaded all...

How to disable warn about some unused params, but keep "@typescript-eslint/no-unused-vars" rule

I want to disable no unused params warning but keep "unused vars" warning. For this code: const Query = objectType({ name: 'Query', definition(t) { t.field('test', { type: 'Test', ...

Cannot find module './App.svelte' or its corresponding type declarations

I have a setup that integrates electron with svelte along with typescript support. when I run the rollup script to compile svelte app, i am getting cannot find module ./App.svelte error as shown...

Error: PostCSS plugin tailwindcss requires PostCSS 8

I installed the new tailwindcss version 2.0 and I've got the following error. I tried to uninstall postcss and tailwindcss but it does not work. Need help. Module build failed (from...

Netlify "build.command" failed for gatsby website

I've recently updated some plugins on my Gatsby website. It works fine locally but it is failing the deploy on Netlify. The error I'm getting is: "build.command" failed - Command was killed with...

Jest + @testing-library/react throws error on a .mjs file from [dom-accessibility-api] library

I'm new to using Jest + @testing-library/react, and on my first attempt, I'm getting an error on a third-party library (probably used by the react-testing-library), which I'm not sure how to...

How to code-split webpack's vendor chunk?

I have a webpack main.bundle.js that weights 287kb thanks to codesplitting, but my vendor.js is 5mb. When the user visits the website for the firs time, he will have to download 5.2mb, which is...

Fastify: ts-node shoot error Property 'foo' does not exist on type 'FastifyInstance<...>'

I'm making a fastify plugin using fastify decorator. Following is my sample code. import { FastifyPluginAsync } from 'fastify'; import fp from 'fastify-plugin'; interface RegistFooOptions { ...

Vuetify SassError Expected identifier. .v-application .orange.#f77925{

I am trying to manage sass variables of vuetify theme, according to doc here: https://vuetifyjs.com/en/features/sass-variables/ Here is package.json { "scripts": { ... }, "dependencies":...

" npx cap add ios" fails with error "Updating iOS native dependencies with pod install - failed!"

I just created a brand new Ionic app, using command "ionic start myApp blank" I added the necessary angular dependencies to get "ionic serve" working properly. I have installed capacitor using the...

Runtime error appeared after updating to webpack 5. TypeError: Cannot read properties of undefined (reading 'default')

After upgrading my webpack from v4 to v5, I got this error that is getting me a hard time debugging. Uncaught TypeError: Cannot read properties of undefined (reading 'default') at...

FATAL ERROR: Ineffective mark-compacts near heap limit Allocation failed - JavaScript heap out of memory Angular 13 application

I have upgraded the angular application from 12 to 13 and added the eslint and Prettier. While doing the ng lint I am facing the below error [email protected]Book-Air LegalRegTech.Web.Host % ng...

Can't install package Pinia because of ERESOLVE unable to resolve dependency tree

I have a Vue3 app and want to install the package Pinia OS: Win10 and Pop!_OS 21.04 (Ubuntu) Node version: v16.13.0 npm version: 8.1.0 Vue CLI version: 4.5.15 Vue version: 3.0.0 After creating...

Getting : npm WARN using --force Recommended protections disabled

I have an old Nuxt.js package that was developed in Node 12 and I want to use it now with Node 16 (the latest stable) but when I try to install my packages by npm install I'm getting the versions...

npm ERESOLVE unable to resolve dependency tree NestJs Passport

I have following package.json { "dependencies": { "@elastic/elasticsearch": "^7.16.0", "@nestjs/common": "^8.2.4", "@nestjs/config": "^1.1.5", "@nestjs/core": "^8.2.4", ...

Angular v13 Jest with nx test - SyntaxError: Cannot use import statement outside a module at Runtime.createScriptFromCode

I tried to follow every comment with a possible solution here to the letter. I relied on an example project on github as well which works perfectly. This also started to happen to me after...

TypeError: MiniCssExtractPlugin is not a constructor

[webpack-cli] TypeError: MiniCssExtractPlugin is not a constructor at module.exports (/home/andrey/smartadmin-app/webpack.config.js:70:9) at loadConfigByPath...