Debian: dist-upgrade removes gnome and many other stuff

I am (was) running the Debian Sid and faced a major update problem few days ago. It was weekend and I was just going to upgrade stuff, did sudo apt-get update, then sudo apt-get upgrade. Then I...

how can I create a debian package to distribute python modules without using distutils?

I'm getting myself thoroughly confused how to correctly package my python3 based application. My application uses a Makefile to install stuff to the correct file locations...

QMediaPlayer doesn't play anything on Ubuntu 16.04 / Qt 5.6

I'm using the official Qt 5.6 SDK on Ubuntu 16.04 and when I try to play an mp3 file I just get: defaultServiceProvider::requestService(): no service found for -...

GStreamer installation is missing a plug-in

I hope that someone can help with this problem, been searching for a solution for the past 2 days. To describe the problem in short: I'm trying to make a simple qt5.7 application that will stream...

Register a Gstreamer1.0 Python Element? Wanting to react to bus element messages

I am new to Gstreamer, so I apologize if this question is very simple, but I've been stuck for way too long. I'm using Mopidy on my raspberry pi to play music through speakers. When Mopidy is...

GStreamer x264 on Linux (ARM)

Trying to get streaming work with x264 encoding. I am doing some black magic with stitching two images which is known to work: gst-launch-1.0 -e \ v4l2src device=/dev/video0 ! \ ...

Cannot install laravel in ubuntu (missing ext-zip)

Help, I'm completely unable to install laravel on my kubuntu system. I had to compile php7.1 from scratch to get openssl and bzip to work, and I've checked every English result on Google for the...

Broken apt dependency tree

I was upgrading Ubuntu 16.04 to 17.04, when some packaged failed to upgrade. This left the apt dependency in a broken state. I tried some other answers online, but I am afraid this only...

Not able to install new wxpython

I am working on Debian Stable Linux and python 3.5 and I am trying to install the new wxpython (phoenix) using following command: pip3 install --upgrade wxpython However, it stops with following...

Unable to play video Qt5 multimedia ubuntu 16.04

I am trying to use QMediaPlayer class to play videos, but keep getting this error - `GLib-GObject-WARNING **: cannot register existing type 'GstObject' GLib-CRITICAL **: g_once_init_leave:...

Which Gstreamer in PyQt5?

On Ubuntu 16.04 and 18.04 whenever I'm trying to use QMediaPlayer I'm being prompted with no service. >>> from PyQt5 import QtMultimedia >>> qtm =...

C++ / Gstreamer - Using gst_buffer_get_reference_timestamp_meta function

I am trying to use alternative timestamp with an existing gstreamer based video acquisition code. I am not allowed to post the code and have little expertise with Gstreamer, to provide a minimal...

Qt Multimedia: Library 'gstreamer' is not defined

I have problem building QtMultimedia with GStreamer: [email protected]:~/sources/qt/build$ /usr/local/Qt-5.12.1/bin/qmake -r GST_VERSION=1.0...

How to install Python 3.6 on Ubuntu 19.04?

I've recently installed Ubuntu 19.04 which has Python 3.7 by default. I need to work on multiple projects that use Python 3.6. Is there a way to install it on Disco Dingo? I tried which works on...

Cannot load python gstreamer elements

I'm following a guide at https://mathieuduponchelle.github.io/2018-02-01-Python-Elements.html?gi-language=undefined to create a sample gstreamer element in Python. However, I can't get GStreamer...

gstreamer: No such element or plugin 'v4l2sink'

The problem I am trying to execute a script. Part of it needs to execute v4l2sink. I tried to execute this gst-launch-1.0 videotestsrc ! v4l2sink device=/dev/video1 & mplayer -tv...

Meson : Dependency not found - Tried both pkg-config and cmake

I'm trying to compile the Pulse Effects project and I faced this issue after running meson build: Dependency gstreamer-1.0 found: NO (tried pkgconfig and cmake) src/meson.build:97:0: ERROR: ...

Difficulty getting google-coral example-object-detection to work properly

Noob here, trying to run google-coral example-object-detection on a new google mini dev board. I have followed all of the instructions for set up of the device and loading the example, models,...