How to run google chrome headless in docker?

My problem is how to run google chrome in docker container for e2e testing. I create a Dockerfile from official Jenkins image, but when try to run google chrome, it crashes and show the...

Error: "...Z Shell configuration function for new users, zsh-newuser-install(...)"

I was using normally the command line like we can see: And then suddenly all other terminal that I open shows this weird message: This is the Z Shell configuration function for new...

ChromeDriver not Launching

I had Selenium + ChromeDriver running fine a few days ago. Idk what happened but now ChromeDriver won't launch. I did not update chromeDriver or Selenium or any other packages besides the Python...

Cant launch chrome in docker linux container

I have an asp.net core application that uses the jsreport nuget packages to run reports. I am attempting to deploy it with a linux docker container. I seem to be having trouble getting chrome to...

How to update cocoapods for flutter on Mac without getting an error?

I use Flutter with Android Studio on a Mac. One day (today), I ran "flutter doctor" from the command line. It stated that my "cocoapods" was not good enough. Doctor summary (to see all details,...

Flutter project doesn't open on Chrome

It's been 5 days since I'm struggling with this problem and tried all the solution on StackOverflow but still can't open the app on Chrome : What I have tried. I really appreciate it if you can...

Flutter: CocoaPods could not find compatible versions for pod "FBSDKCoreKit"

I am build a flutter app and in that I developing logging with Facebook in a flutter. i used flutter_facebook_login: ^3.0.0 and flutter_facebook_auth: ^3.3.2 plugins, this plugin works in android...

How to solve a Flutter problem - fatal: not a git repository

I'm new in Flutter/Dart/Git and I am stuck in one place since few weeks. I have already made some simple projects using Flutter/Android Studio on few other machines and this problem doesn't exist....

Failed to load IDynamiteLoader from GmsCore: Application package com.google.android.gms not found

In My flutter app google Ad is not loading in android app but works in ios. I am using both AdMob and Firebase Database and i am using Macbook pro M1 and anroid emulator is downloaded...

how to integrate selenium driver for chrome and Firefox in gitlab ci with dotnet blazor server for e2e tests

I want to run my e2e tests which user geckodriver and chromedriver with gitlab ci and installing before with apt commands for e2e tests within in a blazor server project. I use the following...

Execution failed for task ':app:compileFlutterBuildDebug' - flutter.gradle line: 1035

I don't know what the problem with my Gradle. I tried everything. flutter pub cache repair flutter clean delete .gradle delete pubspec.lock everything, but nothing. I do not understand what could...

Flutter error: SafetyNet Attestation fails basic integrity

Check with SafetyNet fails with error (below). Instead, the recapcha fires with the browser opening. If anyone comes across, please help. All the information you need is below. Authorization...

Android Studio Flutter - WARNING: Another emulator is still running - windows 10

I am having problems restarting the emulator after turning it off. Restarting android studio - doesn't help. Restarting my computer helps. I also cannot find and [stop this process] through the...

Error after logging in Google Account[flutter][ google_sign_in]

I noticed such a problem that sometimes don't log in to Google account. In the release or debug build, the auth works, but this error often pops up. This problem did not exist before with the same...

Flutter Failed to build and run iOS app only in physical iOs device

i'm trying build and run a "Counter App" (the default app when you create a flutter project), i can run the project in android and iOs simulators, on physics devices works in android perfectly but...

Error: Problems reading data from Binary store

I am getting the Error as follows, when I try to run the flutter app. What went wrong: Could not determine the dependencies of task ':app:compileDebugJavaWithJavac'. Could not resolve all...

The operation couldn’t be completed. Unable to locate a Java Runtime. Please visit http://www.java.com for information on installing Java

I couldn't run the flutter app on android emulator or android phone. I installed the recently released android studio for arm-mac platform on m1 mac. Please answer if I am doing anything wrong...

CocoaPods requires your terminal to be using UTF-8 encoding. Consider adding the following to ~/.profile: export LANG=en_US.UTF-8

I am having a rather weird day. I get this error whenever I try to run my app on iOS simulator from Android Studio WARNING: CocoaPods requires your terminal to be using UTF-8 encoding. Consider...

A lot of errors after upgrade to flutter 2.5.0

I have updated Flutter to 2.5.0 in my project and getting a lot of errors, for example: Failed to build iOS app Error output from Xcode build: ↳ ** BUILD FAILED ** Xcode's output: ↳ ...

How to upgrade your flutter project (app) to the latest flutter version after null safety?

I want to upgrade my project which is on Flutter 2.0 to the latest version of flutter (2.5). I have already seen this question which is most relevant. How do I upgrade an existing Flutter app? In...

Uploading Flutter App to Google Play - Please upgrade to Billing Library version 3 or newer to publish this app. Learn More about Billing Library 3

When uploading a flutter App to Google Play, I get the following error: We've detected this app uses an unsupported version of Play billing. Please upgrade to Billing Library version 3 or newer...

File not found 'Flutter/Flutter.h' Fatal Error Flutter 2.5.1

I recently got a new M1 Mac and updated both the flutter version (to Flutter v2.5.1) and Xcode version (to Xcode 13.0) (Not a wise decision). I tried running on the iOS simulator and got stuck at...

Cannot get Flutter app to build - no such module 'heresdk'

I was following instructions from https://developer.here.com/documentation/flutter-sdk-navigate/4.4.0.2/dev_guide/topics/quick-start.html#try-the-example-apps both for trying example apps or...

Unable to install google-chrome-stable 95 on Centos 7

I'm trying to install the latest version of google-chrome-stable 95.0.4638.54 inside a container with CentOS 7 as base image. My Dockerfile: FROM centos:7 LABEL maintainer="[email protected]" ADD...

FlutterFirebaseCorePlugin.java uses or overrides a deprecated API?

could someone help me because I have already registered all the way through the registrar but unfortunately it still doesn't work Errors Note:...

Flutter - Keyboard not showing up in android 12 devices

Keyboard is not showing up for android 12 devices, overlay comes indicating keyboard is on but nothing is shown. It is working properly for older android versions. Keyboard is working fine in...

headless chrome on docker M1 error - unable to discover open window in chrome

I'm currently trying to run headless chrome with selenium on m1 mac host / amd64 ubuntu container. Because arm ubuntu does not support google-chrome-stable package, I decided to use amd64 ubuntu...

Selenium Python code that used to work now opens browser and then gets stuck in "data:,". Says "chrome not reachable"

EDIT: I just realised that I reinstalled Chrome recently, so that might be the problem. I think Selenium expects to find Chrome in Appdata, but it's not there. I tried copying the Application...

Firebase Crashlytics/Analytics not working with flutter

I saw a couple of duplicate questions in this similar topic. But those are either unanswered or outdated. I've been trying to figure out what I'm missing for more than a week now and I couldn't...

flutter run on iPhone simulator stucks on 'Xcode build done'. (it runs well in android emulator)

Question Hello, I'm having difficulty while running my Flutter App on iPhone simulator. It stucks on 'Xcode build done'. BTW, It runs very well on Android emulator. It's my first time to ask a...