Installing Homebrew on OS X

According to the Homebrew site, to install it, I need to type: brew install wget I get an error message: -bash: brew: command not found Found this answer. The problem, however, is I don't see...

Homebrew cask option not recognized?

I am following an online resource for installing two Mac utilities http://www.economyofeffort.com/2014/08/11/beyond-ctrl-remap-make-that-caps-lock-key-useful/ Here is the pertinent...

homebrew - how to install older versions

I'm trying to install memcached with older versions (ex: 1.4.5) but I'm not sure how to do it. brew install memcached installs the latest. I also tried brew install memecached1.4.5 but it didn't work.

Change bash without making it default shell Mac

When running bash scripts inside zsh-Terminal I want it to use the homebrew bash version 4 instead of the default 3 of OS X. How can I do that? I installed bash 4 on my MacBook. brew install...

Install PHP Extension for PHP 5.6 on OSX with deprecated homebrew/php

today I've update Brew and now I can't install the php56-extensions. On my Mac is installed "php56" and today I had need to install, "php56-redis", but when I had try to install this extension,...

Unable to install java8 with homebrew

Installing java8 with Homebrew seems to no longer be working. After running: brew install caskroom/cask/java8 I get the following error: Error: Cask 'java8' is unavailable:...

brew Error: No available formula with the name "[email protected]"

I'm getting some errors with node v12.6 so I'm trying to downgrade to [email protected] Doing a brew install [email protected] gives me the title error, and I've not found many results in Google for how to...

How to brew install java?

I'd like to setup java on a new OS X machine, and prefer to use brew for OS X package management. How can I install latest java using brew?

Install Git on Mac without Xcode

I've been using windows for software development. I'm not aware of MacOS internals. I'm aware that Xcode software is used to develop iOS/Mac apps but I don't need it. For my usecase, I was able to...

Installation of earlier versions of Python (prior to 3.8) fails on Mac with M1 Chip (ARM based Apple Silicon)

I have Macbook with Apple M1 Chip in which I have to use Python 3.6.5 for my project. It comes with Python 2.7.16 and 3.8.2 preinstalled. I used brew to install Python which by default installed...

Import pyaudio doesn't work - Symbol not found: _PaMacCore_SetupChannelMap on mac (Big Sur M1 Apple Silicon)

I am trying to install pyaudio on my new Macbook Air with the M1 chip (Big Sur). At first I couldn't get past the famous src/_portaudiomodule.c:29:10: fatal error: 'portaudio.h' file not found...

pyenv configure: error: C compiler cannot create executables

I am trying to install multiple versions of Python on my laptop running MacOS Big Sur v11.1. I initially installed xcode command line tools, homebrew, and python via instructions here xcode-select...

Installed Python 3.9.1 onto MAC OS but still says Python version is 2.7

I installed Python 3.9.1 onto my MacBook however when I use the command python --version it says its python 2.7. Here's what going on in my terminal for reference: $ python -V Python 2.7.16 $ brew...

pecl fails installing mongodb driver on Apple Silicon (M1)

I have php 7.4 installed on my macbook pro m1 % php -v PHP 7.4.15 (cli) (built: Feb 26 2021 09:28:23) ( NTS ) Copyright (c) The PHP Group Zend Engine v3.4.0, Copyright (c) Zend Technologies ...

why Updating homebrew takes forever?

this is my brew config HOMEBREW_VERSION: 3.0.10-23-g5e0b08d ORIGIN: https://github.com/Homebrew/homebrew-core HEAD: 5e0b08dd01bdce3523c7e095739641b6f33b902a Last commit: 6 hours ago Core tap...

Cannot install psycopg2 with pip3 on M1 Mac

I cannot install psycopg2 on my M1 Mac and I used pip3. When I tried to install with pip3 install psycopg2 The output like that: ERROR: Command errored out with exit status 1: command:...

Trying to install filosottile/musl-cross/musl-cross on m1 macbook

I`m trying to install filosottile/musl-cross/musl-cross via brew and facing an error at this stage: ==> /opt/homebrew/opt/make/bin/gmake install TARGET=x86_64-linux-musl Last 15 lines from...

System python version active instead of local pyenv version

How can I check if the correct python version is used after activating a virtual environment? I tried which python3 and which python but both outputs indicate the system python version and not the...

Rails & MySQL on Apple Silicon

has anyone been able to get Rails running with the MySQL via the mysql2 gem on Apple Silicon? I'm working with Ruby 2.5.3 and Rails 5.2.3 but would love to hear of any successes with any...

pyenv install 3.x BUILD FAILED (Ubuntu 20.04 using python-build 20180424) using 'python-build: use readline from homebrew'

Trying to install a new Python - version with pyenv on Ubuntu 20.04 WSL for Windows 10 fails with the following output: [email protected]:~$ pyenv install 3.9.4 Downloading...

MySQLClient won't install via pip on Macbook Pro M1 with latest version of Big Sur

I just purchased a new Macbook Pro with the M1 chip after ensuring that homebrew would work natively on it. I'm able to pip install any other library except mysqlclient, and I have no issue...

Cannot compile mediapipe via Mac OS on Android

I'm trying to build mediapipe project for the first time, reading through https://google.github.io/mediapipe/getting_started/android.html, and can't get bazel to complete successfully, so far...

Can't install nodejs version using nvm in Mac os

When I try install node version using this command nvm install or nvm install 10.6.0 I get this output : ../deps/openssl/config/archs/linux-x86_64/asm/crypto/aes/aes-x86_64.s:2:1: error: unknown...

How to install Boost.Python using homebrew (on OSX)?

I'm trying to install Robot Operating System (ROS) Melodic on my mac (macOS 11.5.1). While compiling cv_bridge package, the compiler spit out an error related to the Boost.Python: $...

Trying to set up PSQL and i get this error :

I am trying to start a Spring project using a PSQL database. I have installed PSQL using Homebrew but, When i run : brew services start postgresql I get this error: Error: Failure while executing;...

Mac M1 SQL Server SQLSrv OpenSSL library could not be loaded, make sure OpenSSL 1.0 or 1.1 is installed

I just bought a M1 Mac mini running Big Sur 11.6, I've installed PHP 7.3, msodbcsql17, mssql-tools, sqlsrv and pdo_sqlsrv. But when I try to connect using sqlsrv, the following error happens...

Unable to start minikube on Mac M1 with docker

I'm trying to start minikube on a Mac M1 (macOs Monterey V12.0.1) after installing minikube with homebrew (brew install minikube) but I am getting an error after running minikube start. The error...

wxPython not installing via PIP on Apple Silicon M1 Max

Have a project that is written in Python 3.8.x and wxPython. It was developed on an Apple MacBookPro (Intel-based). wxPython installed via PIP inside a virtual environment without problems. Life...

Unable to find code signature authority on Mac OS Monterey

I recently upgraded my Mac mini (M1, 2020) to Mac OS Monterey (12.0.1) and discovered that I had to download and code sign PHP 8.1. Having not had to code sign PHP before, I followed the...

Installing compiler on Mac M1 Monterey for Rcpp and other tools

I'm trying to use packages that require Rcpp in R on my M1 Mac, which I was never able to get up and running after purchasing this computer. I updated it to Monterey in the hope that this would...