How do you UrlEncode without using System.Web?

I am trying to write a windows client application that calls a web site for data. To keep the install to a minimum I am trying only use dlls in the .NET Framework Client Profile. Trouble is that I...

Install ImageMagick for paperclip gem in a Mac OS 10.5.8

I have been trying to install ImageMagick for one week. The documentation I found over the net it is contradictory and I didn't find the proper way to install it and configure it. As well as I am...

Where should my npm modules be installed on Mac OS X?

I was attempting to upgrade phonegap via npm when I started running into trouble. Long story short, there are two node_modules directories on my...

ionic build Android | error: No installed build tools found. Please install the Android build tools

When I run ionic build android command in root of ionic project, I am getting this error: FAILURE: Build failed with an exception. Where: Script...

cURL error 60: See http://curl.haxx.se/libcurl/c/libcurl-errors.html

Hi I am trying to fetch profile data using the google+ rest API but i,m getting this error : Fatal error: Uncaught exception 'GuzzleHttp\Ring\Exception\RingException' with message 'cURL error 60:...

Command not found go — on Mac after installing Go

I want to use Go, but I'm having trouble running the go command. I installed go1.5.2 darwin/amd64, but when I run the command go version, I get an error in the terminal zsh: command not found: go....

Set userAgent with selenium-webdriver/firefox (NodeJS)

I have a code running browser using 'selenium-webdriver'. It runs on Ubuntu. I have to override userAgent so it will look like the requests from the browser are coming from Windows (i.e. the value...

Video does not start with geckodriver

I'm working with automated tests and I'm trying to set up selenium grid for running tests in multiple environments. I've successfully ran tests with chrome driver in Mac OS X 10.11 and...

How to brew install specific version of Node?

For example I want to install either 7.9 or 7.10 but want to avoid Node 8 due to the webpack node-sass breaking bug. When I run brew search node this is what I see: ❯ brew search node leafnode...

Error when using development time IIS support

Update: this bug has been fixed for a while now I installed Visual Studio 2017.3 yesterday and was trying to used the new Development time IIS Support feature. I think I encountered a bug, and I...

Issues setting $PATH on Bash on Ubuntu on Windows (Linux Subsystem)

I am using the "Bash on Ubuntu on Windows" (Linux Subsystem) and want to add Terraform to my $PATH. Since Terraform can't be installed via apt-get, I did the following steps: Navigated to this...

Set node version with NVM or install if not available.

I'm trying to add to my bash profile something that will set my node version to a specific version, and if the node version is not installed then install it. What I have so far is: ....

CocoaPods could not find compatible versions for pod "Firebase/Core” | cloud_firestore, Flutter

I am having some issues in the pod, see below Launching lib/main.dart on iPhone X in debug mode... Running pod install... CocoaPods' output: ↳ Preparing Analyzing dependencies Inspecting...

How to tell PyTorch to not use the GPU?

I want to do some timing comparisons between CPU & GPU as well as some profiling and would like to know if there's a way to tell [tag:PyTorch] to not use the GPU and instead use the CPU only? I...

Cannot import or install pandas-profiling in Jupyter Notebook

I have technically already installed pandas-profiling using pip install pandas-profiling But when I try to import it, I get the following error: import numpy as np import pandas as pd import...

JBAS010473: Failed to load module for RA [webservice] and SSL configuration isn't working

I've been trying to work out how to retrieve data from a RESTful webservice in Red Hat JBoss Data Virtualization. Specifically I have to connect to a webservice that requires 2-way SSL/TLS. (2-way...

Xcode 11.4 Error - Failed to install one or more provisioning profiles on the device

Not able to install provisioning profiles from xcode. Ensured that all options for new versions(XCode 11 or later) are added from developer portal and downloading profile.

RSelenium: configure firefox remotedriver to use Tor network

I am trying to use RSelenium with firefox using a local proxy (Tor) on a linux machine. I had no problem in installing Tor following this tuto, and the command line wget -qO -...

How to verify flutter app with OAuth 2.0 to access Gmail api?

For the past week, I have been trying to access Gmail api but it seems impossible. It's do-able in web app but for installable app, no luck. I have used about all plug ins there is and read...

Create EC2 Userdata for AWS EC2 using Powershell with Terraform challenge

Honestly I have spent an absolute eternity trying to install the SSM Agent and get it to work on a Windows EC2 (base AMI) launched via Terraform. All I need it to do is launch a EC2 instance...

AWS System Manager start session: An error occurred (TargetNotConnected) when calling the StartSession operation: <instance_id> is not connected

Problem: When I try to locally connect to a running EC2 instance using the AWS System Session Manager CLI command: aws ssm start-session --target i-123456 I get the error: An error occurred...

Google sign-in for websites: read user's phone number

I want to obtain users' phone numbers via Google sign-in on my website. In JavaScript for the "sign in with Google" button, I'm including scope...

NU1202: Package is not compatible with net50-windows

I have a .NET 5 WPF application (x64) that references a user control library. When I reference the library directly, everything works. But when I create a Nuget package and then build the app...

Unable to Deploy ASP.NET Core 2.1 Angular Application To Azure

I have been struggling for many days now to figure out how to deploy my angular and ASP.NET Core application. The project is built using visual studio 2017's ASP.NET Core Web Application Angular...

Flutter firebase message: No message catch by iOS phone

I am trying to use flutter firebase messaging on my application . I installed these libraries on pubspec.yaml file: dependencies: ... firebase_core: ^0.5.1 firebase_messaging:...

Will modifying app capabilities invalidate any provisioning profiles that include this App ID?

I have an enterprise app already in use. And I need to add some capabilities for it. If I save the edit of the capabilities list, a popup appears: Modify App Capabilities Adding or removing any...

Mac M1 SQL Server SQLSrv OpenSSL library could not be loaded, make sure OpenSSL 1.0 or 1.1 is installed

I just bought a M1 Mac mini running Big Sur 11.6, I've installed PHP 7.3, msodbcsql17, mssql-tools, sqlsrv and pdo_sqlsrv. But when I try to connect using sqlsrv, the following error happens...

Keycloak 15.0.2: Getting started: WildFly error "Required mechanism 'KEYCLOAK' is not available in mechanisms [..] HttpAuthenticationFactory

I'm trying to follow the 'Getting Started' procedure of the latest (15.0.2) Keycloak. Using the WildFly 25.0.0.Final, updated with keycloak-oidc-wildfly-adapter-15.0.2 The WildFly error happens...

Who adds numbers to the query portion of the URL of a css background-image?

I have a mediawiki 1.37 installation with a page using some css file. In this css file I have a background-image referring to a url, such as icon.gif. The browser however issues the network...

I can't connect my MetaMask wallet to OpenSea

I can't seem to connect my MetaMask wallet to OpenSea or create an account. This is what is happening: When I try to connect my MetaMask wallet I keep getting the same screen. I either click...