libdb4.6-dev vs libdb4.7-dev

I want to install PHP 5.3 on Ubuntu Intrepid. To install apxs, I need to install libaprutil1-dev, which depends on libdb4.6-dev. When I look at installing that, apt-get wants to remove the...

GNU gettext tools not found compiling error

I was compiling linphone source code in ubuntu linux. And got the following error: GNU gettext tool not found #required for intltool I doubt that intltool is not installed or GNU tool is not in...

Using intltool with cmake

I'm writing a GNOME application and use CMake. Now I'm considering making the app translatable, for which GNU provides intltool, gettext, msgfmt, etc.. autotools supports these tools and the...

pygtk+glade+localization

Default locale in my system (Linux) - en_US. When I change locale to russian (LANG=ru_RU ./show_form.py), python string "hello to me" shows correctly (in console), other (glade form) - in english....

Install Webkit for Standalone HTML Desktop App

A few months ago I converted my web application to run as a linux app (kind of, it's just in a web browser to give the illusion that it's a full fledged linux app) I made it on Ubuntu 14.04 and...

Recursive makefile No rule to make target `all'. Stop

The project is about a root directory that contains a src directory. I created two makefiles, one at the top directory and the other at the src directory. Here is the makefile of the src...

Can't install geany debugger plugin

Using Ubuntu 14.04. I installed geany-1.27 successfully, and then tried to install geany-plugins-1.27, because debugger plugin is included When I run ./configure, I see checking for a...

Finding dgettext declaration when compiling libmypaint on osx

I have been trying to compile GIMP for the last few days from source and I am having an issue with libmypaint. I have read the REAMDME, and install all dependencies via MacPort. The autogen.sh...

configure: error: Package requirements(...) were not met

I am trying to make some tweaks to Unity Greeter. So I fetched the source code from launchpad.net. The package came with no makefile. After a bit of googling, I found they use autotools project...

Building Valama IDE on Windows using MSYS2 and MingW

I am using MSYS2 to build Valama [the next generation IDE for Vala]. what the GitHub repository says that some dependencies are required. and they are provided for Ubuntu using this command sudo...

make: *** No targets specified and no makefile found. Stop

I got this while installing gnome-calender on Ubuntu 14.04 LTS. [email protected]:~/Documents/gnome-calendar-3.22.1$ ./configure checking whether make supports nested variables... yes checking for a...

Error while installing java in ubuntu 16.04 having Cyberoam Client installed

I'm using Ubuntu 16.04 OS and also linked my pc with Cyberoam client for the security purpose. I'm trying to install java for Android Studio in it and I'm getting following error in terminal...

broken dependencies: intltool

I got a raspberry pi 3B and I'm working with it since two days. While trying to get my bluetooth headset working I stuck in a problem while installing intltool package. $ sudo apt-get install...

using GTKAgg backend on python 3.5 (anaconda) and centos 7

I tried to use GTKAgg as back-end for matplotlib package. matplotlib.use('GTKAgg') Failed to enable GUI event loop integration for 'gtk' Traceback (most recent call last): File...

Resolve Conflicts with Python 2.7 & 3.6 on MacOS Sierra

I am just starting to teach myself Python. I'm having trouble getting it set up. I'm on a MacBook Pro/Sierra. I'm moderately comfortable in command line. What I'd like to do: run Python 3.6...

GCC 6.2 build error in HP-UX

Build Environment HP-UX RX2660 B.11.31 U ia64 GCC 4.2.3 Build Target GCC 6.2 swlist Product(s) not contained in a Bundle: gcc - 4.2.3 gettext - 0.19.8.1 gmp - 6.1.2 gnutls - 3.6.0 intltool -...

Build Pulseaudio-11.1 and intltool >= 0.35.0 bug

Im trying to build pulseaudio-11.1 because firefox asks for it to play audio on video. Im using knoppix 8.1, 64 bit installation, but it runs in 32bits. When I configure the pulseaudio source, I...

How to build Nix packages from source?

I think NixOS is great, but can't figure out how to build a package from source. Understanding the Nix expression language is not the problem, but to know what to put in a default.nix in order to...

TwitteR r package: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not found

I have updated my OS to Ubuntu 18.04 recently and twitteR R package is not working anymore. I am having the following error message during setup_twitter_oauth. >...

Building on Centos, Zlib.h error while installing PerlIO::gzip

I'm using Centos6, trying to install PerlIO::gzip error that I get is gzip.xs:16:10: fatal error: zlib.h: No such file or directory #include <zlib.h> ^~~~~~~~ compilation terminated. make: ***...

Riofs - fuse device not found

I am trying to run riofs inside a docker container, however when I try to run riofs I get the following error: fuse: device not found, try 'modprobe fuse' first ERROR! Failed to mount FUSE...

New Yocto Recipe Builds but Work Directory is Deleted after Compilation

I am trying to update the recipe for zbar from 0.10.0 to 0.20.1. Here is the original...

XML Parser perl module is needed

I'm trying to install intltool on Debian (Raspberry Pi). When running ./configure The system always come back with the error: checking for XML::Parser... configure: error: XML::Parser perl...

trying to use CPAN with my MINGW version for Git Bash

I am trying to use use cpan on my windows install version of Git Bash git version 2.18.0.windows.1. I installed an Active Perl version version 24, subversion 3 (v5.24.3) built for...

FIle is not being copied in WORKDIR from Image recipe in Yocto

I am trying to install a simple file to /etc directory of target rootfs. I am building core-image-sato. "raxy_test" file(in below recipe) is not even being copied in WORKDIR also. Am I doing...

Internationalize Python project, using PyGTK3 and Glade

I am developing a Python program, using PyGTK3 and Glade for the UI. I would like to internationalize the UI, not based on locales in the system, but by languages "installed" with the program, and...

How does "make dist" command work? I'm stuck on a script which I need to update to add new file and folder

I've to add a file and a folder to the zip that is created when I run make dist command. This is an open-source project. After research, I understood I've to modify the Makefile.am but examples...

Error: configure: error: ln doesn't support --relative when building Systemd

While installing systemd version 221 on CentOS 6.9 using following steps: # wget https://www.freedesktop.org/software/systemd/systemd-221.tar.xz # tar -xJf systemd-221.tar.xz # cd systemd-221 #...

Error building python package on makefile even though I have the package installed

I am trying to run makefile for a certain project but I got lots of error during make run even when everything was successful when running make init. Currently I run this makefile on conda...

Copy folder from Dockerfile to host

I have a docker file FROM ubuntu:20.04 ################################ ### INSTALL Ubuntu build tools and prerequisites ################################ # Install build base ARG...