jQuery validate only validates one field

I am using jQuery validate to validate a form. I have two text boxes on my form and only the first one will add the "This field is required." message. If I remove the "required" class from the...

Handle mouseenter/mouseleave on a div and nested elements with jQuery

I want to display a toolbar if the mouse is over a div or any of the div's nested elements. But the following solution with jQuery 1.7 only works if the mouse is over the div directly what is only...

Remove Malware from Website

My website, 3dsforums.com, has been marked as an attack site for containing malware. According to Google Webmaster Tools, this is the suspected code that has been injected onto every...

Is it possible to use jQuery .on and hover?

I have a <ul> that is populated with javascript after the initial page load. I'm currently using .bind with mouseover and mouseout. The project just updated to jQuery 1.7 so I have the option to...

Sticky CSS Footer

Can someone help me make the original code from HTML5 Boilerplate Initializser, have the footer stick to the bottom of the browser, I've tried all manor of codes from web examples but...

What does curly brackets in the `var { ... } = ...` statements do?

Not sure if this is a Mozilla-specific JS syntax, but I often found variables being declared this way, for example, in add-on SDK docs: var { Hotkey } = require("sdk/hotkeys"); and in various...

Uncaught TypeError: Cannot read property 'Constructor' of undefined

I am getting this and a couple other weird error messages on my main ASP MVC 3 layout page. I am using the following scripts <script src="@Url.Content("~/Scripts/modernizr-1.7.min.js")"...

Add a minute to hh:mm with JavaScript

I'm a PHP programmer who seldom uses Javascript, so I need help figuring out how to accomplish this with JS or JQuery (I currently have jquery-1.7.min.js). I've created three clocks showing the...

Rspec & bundle exec: "rake spec" works but "rspec spec" gives "command not found: rspec" missing gem error

I am having problems running Rspec: My RSpec tests run properly with bundle exec rake spec, but I get a missing gem error with bundle exec rspec spec. I am using Rails 4.1.0 and Ruby 1.9.3p484...

Bundler::GemNotFound: Could not find rake-10.3.2 in any of the sources

I have been working with Rails and it sends me back this error. Please provide questions. Thanks for all the help. I will update this question with a better one because I don't know how to ask...

JBWEB000236: Servlet.service() for servlet strutsAction threw exception: java.lang.StackOverflowError

I'm migrating my application from Jboss 4 to Jboss 7(jboss eap 6.1 alpha) getting the below error, while trying to search results in my project. I'm using Java 6, Struts 1.2, EJB 2.0, Jboss 6 EAP...

Gemfile.lock contains merge conflicts

I just ran git push origin master and got this error after trying to run rails s: Your Gemfile.lock contains merge conflicts. Run `git checkout HEAD -- Gemfile.lock` first to get a clean...

Invalid block tag: 'static'

Server returned TemplateSyntaxError at / Invalid block tag: 'static' on this line: <img src="{% static 'icon/logo.png' %}">. The whold html file is like this (it's an html file {% include %}ed by...

Django admin site not showing CSS style

My Django admin website (it's completely default, not customized) is not showing the expected CSS. It looks like this: And I can log in: But it is supposed to look like this: How do I fix...

Can I Transpile for ES6-ES5 without npm, VS, Node, etc. and just the JS code itself somehow?

I am trying to get Firefox to run a Promise in ES6 but run into the 'let' keyword triggering an error; SyntaxError: let is a reserved identifier Changing the script tag to...

Is this only affecting Ubuntu? Rhino (JavaScript engine in Java SE 6 and 7) producing ConsString where String expected?

Now with an Ubuntu bug report, not yet replied to as of this writing. (It would still interest me to know whether anyone sees this behavior outside of Ubuntu.) A reproducer, and some versions...

Uncaught Error: Assertion Failed: Ember Views require jQuery between 1.7 and 2.1

I am new to ember and using the following, Ember: v1.13.3 jquery: v1.12.3 But I am getting the following error Uncaught Error: Assertion Failed: Ember Views require jQuery between 1.7 and 2.1 I...

How do I use backend variable in ejs script section?

<script> // initialize the map var map = L.map('map').setView([25.037393872113785, 121.56372070312499], 12); // load a tile layer var baseLayer =...

ant build.xml does not exist. Build failed

I am a beginner in Ant and GWT and I was creating a new Ant project in GWT by following the steps mentioned on this GWT page: [webAppCreator][1] under the Creating an Ant project section. I was...

can't add products (prestashop 1.7)

I can't add products in PrestaShop 1.7, when I want to add pictures doesn't allow me, also its show me the old categories that I had already deleted, also when I put the price doesn't give me the...

d3.scale.category20() gives Uncaught TypeError: Cannot read property 'category20' of undefined

I'm trying to embed D3 bar charts into my site, shown here: From this recipe: http://bl.ocks.org/erikvullings/51cc5332439939f1f292 But the dynamic cherrypy sever gives me an error. If I take the...

Add field in checkout in Prestashop 1.7 and handle value

I create my own module for Prestashop 1.7. For PS 1.6 version it's done. PS 1.7 works a little different ;) I have problem to handle value from this new field. Just to get this field value. I...

Prestashop 1.7.x override javascript from module with my own module

I am writing my own module that need to override ps_shoppingcart.js I try to read in...

Heroku server crashes with "JavaScript heap out of memory" when deploying 'react-admin' app

I am currently developing an admin panel using 'react-admin' which works well on my local, but as soon as I upload the app to Heroku, the build fails with the following error: "FATAL ERROR:...

How to get JavaScript Socket.IO version?

I use Flask and Flask-SocketIO inside of a Python application. Recently, when I start up the app, I am given this message: The client is using an unsupported version of the Socket.IO or Engine.IO...

Is there a way to fix Gem::LoadError in Elastic Beanstalk

I'm relatively new to Elastic Beanstalk thus was hoping for some advice. After deploying the RoR app into EB - Puma with Ruby 2.6 running on 64bit Amazon Linux, When I 'Go to environment' link it...

How to hide or disable the address bar on Edge?

My team and I are trying to enable an old application that runs on IE to be compatible with Edge. The main issue we have is we are required to either: 1- Disable the address bar so the user is...

VueJs FATAL ERROR: MarkCompactCollector: young object promotion failed Allocation failed - JavaScript heap out of memory

Building (npm run build) my VueJs project gives an error. package.json { "name": "acme-web", "version": "0.1.0", "private": true, "scripts": { "serve": "vue-cli-service...

Uploading a nextjs app to aws amplify has an error in build phase

2021-06-24T08:24:16.127Z [INFO]: # Cloning repository: [email protected]:Friel909/rivgurufrontend.git 2021-06-24T08:24:16.136Z [INFO]: Agent pid 134 2021-06-24T08:24:16.171Z [INFO]: Identity added:...

C# ASP.NET - How to detect browser type

I'm inputting the following code for detect browser type (IE, FF, Chrome, Edge) used from users, using C# ASPNET. The detected browser type working but I have verified that when the code is...