Could not create cudnn handle: CUDNN STATUS INTERNAL ERROR

I'm trying to create machinelearing in python 3. but then i trying to compile my code i got this error in Cuda 10.0/cuDNN 7.5.0, can some one help me with this? RTX 2080 I'm on: Keras...

keras.layers.TimeDistributed with hub.KerasLayer NotImplementedError

I want to use tf.keras.TimeDistributed() layer with the tf.hub inception_v3 CNN model from the latest TensorFLow V2 version (tf-nightly-gpu-2.0-preview). The output is shown below. It seemst that...

HDF5 library version error - HDF5 ver 1.10.4

I'm trying to import some packages with spyder (OS x64), Anaconda and pyton 3.x The error is pretty famous in the internet. The solution proposed is to match the version of the library 1.10.5 with...

ERROR: You must give at least one requirement to install -- when running: pip install --upgrade --no-binary hdbscan

I am trying to install hdbscan in my PC which runs Windows 10 and has installed Python 3.6. My first attempt failed: (base) C:\WINDOWS\system32>pip install hdbscan --user Collecting hdbscan ...

Keras model save and load: ValueError: Could not find matching function to call loaded from the SavedModel

System information Have written custom code: Yes OS Platform and Distribution: Windows 10 Mobile device: No TensorFlow installed from: conda install tensorflow TensorFlow version: 2.1.0 (CPU...

ValueError: No gradients provided for any variable - Tensorflow 2.0/Keras

I am trying to implement a simple sequence-to-sequence model using Keras. However, I keep seeing the following ValueError: ValueError: No gradients provided for any variable:...

LSTM Model Conversion to TFLite Work Fine, but Error When Importing to Android Project

I have read here that now tensorflow lite is able to convert from tensorflow and keras LSTM models. Everything works fine until the model is converted and I have the model.tflite file. I already...

Wrong tensorflow version used after !pip install tf-nightly

I'm using some code written by my lecturer & I'm running it on a GPU in Google Colab. At the beginning of the code the tf-nightly package is installed using !pip install tf-nightly. Afterwards,...

EDGE_TPU COMPILER ERROR: Didn't find op for builtin opcode 'RESIZE_NEAREST_NEIGHBOR' version '3' for custom YOLO

I have retrained my model on Darknet and use https://github.com/qqwweee/keras-yolo3 to convert my darknet weights to h5. I have replace relu for leaky relu for quantization purpose. My model then...

Keras Multiclass Clasification input_shape size problem

I am building a face detection AI using Keras. I have collected the data in the following form: dataset a b c d main.py In this, a,b,c, and d are the classes each containing images. I want to...

Error when running on TPU, "NotImplementedError: TPUStrategy.run(fn, ...) does not support pure eager execution....."

I am trying to train my model over a colab TPU, but I am running into NotImplementedError: TPUStrategy.run(fn, ...) does not support pure eager execution. please make sure the function passed...

Quantization not yet supported for op: 'DEQUANTIZE' for tensorflow 2.x

I am conducting QAT by keras on a resnet model and I got this problem while converting to tflite full integer model. I have tried the newest version tf-nightly, but it does not solve the...

Getting the RuntimeError: Unable to create link (name already exists) with a multi-input Keras model

I'm unable to save a Keras model as I get the error mentioned in the title. I have been using tensorflow-gpu. My model consists of 4 inputs each is a ResNet50. When I use only a single input the...

Cannot import name 'network' from 'tensorflow.python.keras.engine'

When trying to load BERT QA I get the following ImportError: "Cannot import name 'network' from 'tensorflow.python.keras.engine'" The full error log follows below Following this...

tf-nightly-gpu and Keras

So, I was able to get lucky and get my hands on an RTX 3070. Unfortunately, this isn't working out as well as I would have liked for me when it comes to tensorflow. I've spent some time on google...

Tensorflow.python.framework.errors_impl.InvalidArgumentError: Input to reshape is a tensor with 790272 values

I am trying train my images. This data's size is 50.000 images. My images properities are: If i should change my images properities, how can i do that? This is my first image classifier work so...

Issues Installing Tensorflow Probability

Error When I attempt to import Tensorflow probability: --------------------------------------------------------------------------- ModuleNotFoundError Traceback (most recent...

TypeError: Could not build a TypeSpec for <KerasTensor when using tf.map_fn and keras functional model

When I attempt to use tf.map_fn in the definition of a keras Functional model, I get the error: TypeError: Could not build a TypeSpec for <KerasTensor: ... e.g. this simple model will trigger...

ERROR: ResolutionImpossible when installing tensorflowjs_converter

When I try to install tensorflowjs_converter to convert my model.h5 to a json file it doesn't install it, I used pip3 install tensorflowjs to install it and it returns this error message: ERROR:...

How to setup Tensorflow for RTX 3070 on Windows?

Im using Windows 10 and try to setup tesnsorflow scripts to work with my new RTX 3070 GPU. Previously I had it working on GTX 980. TensorFlow installed from binary (pip3 install tensorflow) tried...

Segmentation fault (core dumped) on training the deep neural network /torch/cuda/__init__.py", line 172 in _lazy_init

python3 -q -X faulthandler test.py --model.backbone=resnet18 2021-02-07 20:14:21.198583: I tensorflow/stream_executor/platform/default/dso_loader.cc:49] Successfully opened dynamic library...

ImportError: cannot import name 'get_config' from 'tensorflow.python.eager.context'

My notebook was working up till today. At the beginning of my colab notebook I install tf-nightly, but now it is giving me this...

Sudden Tensorflow / Keras Google Colab dependency problems `AttributeError: module 'tensorflow._api.v1.compat.v2' has no attribute '__internal__'`

I have running a machine learning model (Matterport's Mask R-CNN) in google colab for a couple of weeks. All of a sudden today I am unable to run any of my notebooks due to I think some kind of...

pipenv - Pipfile.lock is not being generated due to the 'Could not find a version that matches keras-nightly~=2.5.0.dev' error

As the title clearly describes the issue I've been experiencing, no Pipfile.lock is being generated as I get the following error when I execute the recommended command pipenv lock --clear: ERROR:...

AttributeError: tensorflow_core.python.keras.api._v2.keras.layers.experimental' has no attribute 'SyncBatchNormalization'

I was trying to run a tensorflow Object Detection API and i am stuck with the error AttributeError: module 'tensorflow_core.python.keras.api._v2.keras.layers.experimental' has no attribute...

ERROR: CMake must be installed to build dlib

While using docker build -t /flask-docker to create an image to later upload it to heroku, I get the following errors: #8 417.3 ERROR: CMake must be installed to build dlib #8 417.3 #8 417.3 ...

Issues with dependencies of TensorFlow using Colab

I'm trying to use the batch ensemble model with Colab. The pip install: !pip install "git+https://github.com/google/uncertainty-baselines.git#egg=uncertainty_baselines" and got the below...

ImportError: Could not find the DLL(s) 'msvcp140.dll or msvcp140_1.dll'. Even when the files are located in the %PATH% directory

I receive the following error when importing tensorflow (base) PS C:\Users\Rostyslav\GIt\GNN-GCP> python run_model.py --train --save Traceback (most recent call last): File "run_model.py", line...

Is there any way to run `predict` of a preloaded Keras model in parallel?

I have a class in which I instance a Keras model to perform predictions. This class is organized somewhat like this: class MyClass(): def __init__(self): self.model = None def...

Getting DLL error when running tensorflow/keras program on python gpu 3.8

I am trying to run my simple AI program but I keep getting this DLL error: ImportError: Could not find the DLL(s) 'msvcp140_1.dll'. TensorFlow requires that these DLLs be installed in a...