boost library gives errors on ubuntu

I am trying to compile a package on ubuntu 8.1 when executing this command: ./configure I get the follwoing error: checking for Boost headers version >= 103700... no configure: error: cannot find...

Building a project using Boost with ArchLinux

I have installed extra/boost 1.52.0-1 extra/boost-libs 1.52.0-1 with pacman under ArchLinux. I'm trying to build autotools C++ projects which make use of parts of the Boost library. They have...

"src/common.hpp:52:32: fatal error: boost/shared_ptr.hpp: No such file or directory" when building websocket++

I know next to nothing about linux or c++. I generally followed these instructions to build boost on ubuntu 12.10...

Locating Boost Libraries in Ubuntu

I want to build an autotools project which is making use of the boost libraries program_options and iostreams. Therefor I install those libraries: sudo aptitude install libboost-iostreams-dev...

My apt got messed up installing boost

On ubuntu #> sudo apt-get install libboost-all-dev Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to...

Can I change the boost lib files' names?

I installed boost with cmd sudo apt-get install libboost-dev. I find my boost lib files under /usr/lib are these: $ ls /usr/lib | grep...

Unresolved dependencies

I am trying to install apt-get -f install ntp git build-essential libssl-dev libdb-dev libdb++-dev libboost-all-dev libqrencode-dev on Ubuntu and get dependency errors, when I try to install with...

Cannot install Boost library in Ubuntu 12.04

I am trying to install Boost library in my ubuntu 12.04 and always getting the following error: The following packages have unmet dependencies: libboost-all-dev : Depends: libboost-iostreams-dev...

Compiling graph-tool from source - no useable boost::coroutine found

I am currently in the process of compiling v1.13 dev from source. I have generated the configure file using autogen.sh. I am running the configure script now using the command ./configure...

Can't install the "Boost" prerequisite for Caffe

I'm getting into machine learning, and I recently happened upon this: Wide-Area Image Geolocalization with Aerial Reference Imagery . It's a net that predicts the GPS location of an image, from...

Build error using cmake in docker

I am currently trying to setup a Gazebo Simulation with Docker.Since i want to use a custom Gazebo Version made by Alessio Rocchi I am building everything from source. But while trying to build...

Boost bimap takes much memory

I looked into this, but not helpful to me. I have a boost bimap where I have 1 million entries of long long int. Theoretically it takes 100000082 bytes = 16 MB of memory. But I found that total...

Broken apt dependency tree

I was upgrading Ubuntu 16.04 to 17.04, when some packaged failed to upgrade. This left the apt dependency in a broken state. I tried some other answers online, but I am afraid this only...

Building Boost from sources on Linux

Description: I am trying to build the Boost library (1.68) from sources on Ubuntu...

Setting Up a Debian Docker image with older boost library

I have an already compiled Linux app which has become dated. To use it, I want to create a Docker image and an appropriate environment to work with. My problem is that is app requires an older...

Why is ./configure libbitcoin-system not finding boost library on Raspian Butch?

tl;dr: Boost was there, but had issues. The ./configure did not know the path to boost. I did clone for libbitcoin-system and did git checkout v3.6.0 and followed this (logs are below): $...

How to compile Point Cloud Library (PCL) with examples (Ubuntu)?

I'm using Ubuntu 18.04, however this questions should be pretty much the same for any reasonably recent Linux distribution. Based on this post: How to install Point Cloud Library v1.8 on Ubuntu...