SDL init failure, reason is: No available video device in ubuntu 12.04 LTS

I recently upgraded my ubuntu 10.04 LTS to ubuntu 12.04 LTS. AVD stopped working afterwards in my eclipse. ERROR message: [2012-10-03 16:16:11 - xyzapp] Android Launch! [2012-10-03 16:16:11 -...

"src/common.hpp:52:32: fatal error: boost/shared_ptr.hpp: No such file or directory" when building websocket++

I know next to nothing about linux or c++. I generally followed these instructions to build boost on ubuntu 12.10...

cmake can't find boost lib

I want to cross compile a simple main.cpp that uses boost libs (regex), The target plataform it's a raspberry pi (raspbian). I have installed from apt-get the libboost-all-dev package. So the...

g++ doesn't find the file included with -I argument

I'm compiling a package using cMake-gui/make on Ubuntu. The package needs the address to pyublas which is by default located at /usr/local/lib/python2.7/dist-packages/pyublas. After configuration...

Freeling : Unable to compile the Java API on Ubuntu

I'm currently trying to create the Java API for Freeling in order to use it on Stanbol. In this way, I followed all the instructions given by the Freeling documentation (here...

How to add boost library to Code::Blocks in Linux

How to add the boost library to a Code::Blocks project in Linux Ubuntu? For example I want to add regex lib. I've already installed the boost library with: sudo apt-get install...

My apt got messed up installing boost

On ubuntu #> sudo apt-get install libboost-all-dev Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to...

How to use cmake to find the boost pool library?

I've installed boost like this on Ubuntu 14.04: sudo apt-get install libboost-all-dev libboost-dev If I have the following in my CMakeLists.txt file: SET ( Boost_DEBUG 1 ) SET (...

Boost.Regex linkage error LUbuntu 14.04 g++ 4.8.2

Good morning! I have problem with regular expressions in C++11. I have Ubuntu Light 14.04 and this version of compiler: g++ (Ubuntu 4.8.2-19ubuntu1) 4.8.2 Copyright (C) 2013 Free Software...

Cannot install Boost library in Ubuntu 12.04

I am trying to install Boost library in my ubuntu 12.04 and always getting the following error: The following packages have unmet dependencies: libboost-all-dev : Depends: libboost-iostreams-dev...

RCSSserver 5.2.2 on ubuntu 14.04 installation error

After a day of googling and package installing, here is my last hope to solve RCSS intallation problem. First of all let me explain my software packages and versions because as I searched before...

What is the difference between libboost-XXX-dev and libboost-XXX?

Now I'm trying to use libboost-regex in my project. But I'm a little confusing because there are some relative libraries like below. I just want to use boost-regex. So in that case, what's the...

I cannot build boost_regex code because of link erros

I'm trying to use boost_regex on ubuntu 12.04 (gcc 4.8.2). I've installed boost like this. $ sudo apt-get install libboost-all-dev And I've confirmed boost_regex libraries are installed on. $...

Can't install the "Boost" prerequisite for Caffe

I'm getting into machine learning, and I recently happened upon this: Wide-Area Image Geolocalization with Aerial Reference Imagery . It's a net that predicts the GPS location of an image, from...

Docker file for building code cloned from git

I've cloned a copy of FreeCAD from github and I'm trying to create a docker file so that I can develop it locally on my machine. The objectives being that: I have a local copy of the code from...

Build error using cmake in docker

I am currently trying to setup a Gazebo Simulation with Docker.Since i want to use a custom Gazebo Version made by Alessio Rocchi I am building everything from source. But while trying to build...

Boost bimap takes much memory

I looked into this, but not helpful to me. I have a boost bimap where I have 1 million entries of long long int. Theoretically it takes 100000082 bytes = 16 MB of memory. But I found that total...

Broken apt dependency tree

I was upgrading Ubuntu 16.04 to 17.04, when some packaged failed to upgrade. This left the apt dependency in a broken state. I tried some other answers online, but I am afraid this only...

Docker container closes after starting Apache

OK, So I've set up my docker container as I need it. This is my current Dockerfile: FROM ubuntu:16.04 RUN apt-get update RUN apt-get upgrade -y RUN apt-get install -y \ build-essential sudo...

Building Boost from sources on Linux

Description: I am trying to build the Boost library (1.68) from sources on Ubuntu...

Setting Up a Debian Docker image with older boost library

I have an already compiled Linux app which has become dated. To use it, I want to create a Docker image and an appropriate environment to work with. My problem is that is app requires an older...

GnuRadio installation problem: Python module click is required for gr-modtool

I have a Mint Box mini pc with OS v.19 cinamon. I'm trying to install gnuradio + uhd. I did the following: udo apt-get update sudo apt-get upgrade sudo apt-get dist-upgrade Note: I encountered a...

How to compile Point Cloud Library (PCL) with examples (Ubuntu)?

I'm using Ubuntu 18.04, however this questions should be pretty much the same for any reasonably recent Linux distribution. Based on this post: How to install Point Cloud Library v1.8 on Ubuntu...

libtins compile with arm-linux-gnueabi-g++ cmake error

im facing a problem with cmake when trying to compile libtins library to embedded device using arm-linux-gnueabi-g++ i must say that when im compiling the library for linux (not embedded) the...