apt-get error: Sub-process /usr/bin/dpkg returned an error code (1)

I have error in apt-get install it is a error: The following packages have unmet dependencies: gcc-4.8-multilib : Depends: libc6-dev-i386 (>= 2.11) but it is not going to be installed ...

Install pip in docker

I'm not able to install pip in Docker. Here's my Dockerfile: FROM ubuntu:14.04 # Install dependencies RUN apt-get update -y RUN apt-get install -y git curl apache2 php5 libapache2-mod-php5...

Apt-get can't install anything due to broken dependencies

Whenever I run apt-get install for any package I get this error ➜ ~ sudo apt-get install clang-5.0 Reading package lists... Done Building dependency tree Reading state information......

Issue in installing php7.2-mcrypt

As I'm trying to load mcrypt extension module from PHP 7.2.X version. So I tried to make use of PECL library that is compatible to the current version of my PHP, in order to get installed and...

How to build my own custom Ubuntu ISO with docker

As a background, I have a custom Ubuntu LiveUSB that will automatically boot into "Try it" and the OS will have pre-installed apps that I have burned into the ISO itself. It works great, but I...

Alternative to openjdk:8-alpine for Kafka Streams

I am using openjdk:8-alpine for deploying Kafka Streams application. I am using Windowing and it crashes with below error: Exception in thread "app-4a382bdc55ae-StreamThread-1"...

Android SDK on docker

Im trying to run android emulator on docker but I get the following error, I have done some research but none of the answers helped me in achieving my goal, here is the error that I get and my...

How to get steam to run on Ubuntu 20.04

Steam won't run =( Here's what I've tried: I have a fresh install of Ubuntu 20.04 (via Ubuntu Server Live Installer + ubuntu-desktop package) with nvidia drivers: $ nvidia-smi Mon Jun 22 10:26:49...

I can't run apt-get commands. apt --fix-broken install doesn't work. The following packages have unmet dependencies libc6-dbg and libc6-dev

I'm new here I have Ubuntu 18.04 LTS When I run sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt...

apt get update is posting an error while using debian source

my dockerfile is as below: FROM wordpress:5.5.1-php7.4 RUN echo 'deb http://ftp.us.debian.org/debian sid main' >> /etc/apt/sources.list RUN apt-get update && \ apt-get install -y wget sudo &&...

Problems Installing Mongodb on Ubuntu 20.04

Will give a quick context. I was strict to the manual: https://docs.mongodb.com/manual/tutorial/install-mongodb-on-ubuntu/ wget -qO - https://www.mongodb.org/static/pgp/server-4.4.asc | sudo...

libgcc_s.so.1 must be installed for pthread_cancel to work

I'm on python; I am trying to shut down a function running through a ThreadPoolExecutor, but the shutdown is crashing with the error: libgcc_s.so.1 must be installed for pthread_cancel to...

How to install libstdc++6 debug symbols on Ubuntu 20.04?

For example, take the following minimal example: #include <cstdio> #include <stdexcept> int main(int argc, char* argv[]){ #ifdef __GLIBCPP__ std::printf("GLIBCPP:...

Running Headless Chrome Puppeteer and Xfvb in a Node.js Docker Container, trouble running image

Im trying to run a Puppeteer script in a docker container with Xfvb so that I can run headless: false on my production app, which is the only way my script will get the required output from the...

Headless Tor on Ubuntu + Selenium WebDriver (Kotlin) + Docker

I'm trying to build Docker image with Tor Browser and my simple Kotlin application inside. My application is functioning well locally on MacOS, but when I try to run it inside Docker container, it...

Deploying a Dockerized node app onto Heroku and using Xvfb with puppeteer, cannot launch browser

Puppeteer version: 5.5 Platform / OS version: Docker container deployed on Heroku Node.js version: latest I have set up puppeteer scripts that live in a docker container, so that they can be run...

Gitlab runner ECS fargate build docker images

I have moved my gitlab-runner infrastructure to AWS ecs fargate and now it is working fine. But I have problem, I have a .gitlab-ci.yml file and has following commands: stages: -...

Java SIGSEGV error when running from docker

I have no experience in Java and I can run my code successfully from the development. But only when I built the project and runs it from docker, I got an error like this. # # A fatal error has...

pycharm error with pyenv virtualenv: The SDK seems invalid

I am experiencing a problem with pycharm when trying to select as interpreter a python bin created through a pyenv virtualenv. Cannot set up a python SDK at Python 3.10 (remote_maax)...

Cannot install libc6 ver 2.29 /newer on debian buster

Tried to install libc6 ver 2.29 /newer on debian buster, and did get it: http://ftp.br.debian.org/debian/pool/main/g/glibc/libc6_2.31-9_amd64.deb but then $ sudo dpkg -i libc6_2.31-9_amd64.deb...

How to fix '(38)Function not implemented: AH00141: Could not initialize random number generator' after upgrading Apache from 2.4.18 to 2.4.46?

I have a running system with Ubuntu 16.04, Apache 2.4.18, PHP 7.3 and 7.4, PHP-FPM, PHP FastCGI, MPM event. I wanted to upgrade to the latest Apache version (2.4.46-2+ubuntu16.04.1+deb.sury.org+3...

Micronaut DI does not work with Graal Native Image built in Maven

I have a minimal app on Micronaut it looks like this: @Introspected public class BookRequestHandler extends MicronautRequestHandler<Book, BookSaved> { @Inject private BookService...

Unmet dependencies (venv & ensurepip) error when running erdpy-up

Trying to install erdpy fails with the following error: $ python3 erdpy-up.py INFO:installer:Checking user. INFO:installer:Checking Python version. INFO:installer:Python version:...

Install Python pip in ubuntu using ansible

I am trying to install Python-pip in ubuntu using ansible and then installing python package, But I am getting following error during Python package install task: failed: [X.X.X.X]...

libc6:amd64 current status 'half-install' POP-os

I am running POP-os on my pc. Yesterday I ran sudo apt upgrade but got the following error The following packages have unmet dependencies. locales : Depends: libc-bin (> 2.32) E: Unmet...

pip install py-find-1st fails on ubuntu20 & centos with python3.9

This is my process. I start a new aws t2.micro ec2 on ubuntu20 and run this script sudo apt-get update sudo apt-get install gcc sudo apt-get install python3.9 sudo apt-get install...

Docker build exit status 127 (Errors were encountered while processing: libc6:amd64)

Environment: Ubuntu 20.04.3 LTS Docker version 20.10.8, build 3967b7d Kernel version 5.11.0-27-generic Dockerfile FROM python:3.7-slim-buster as base RUN echo 'deb http://deb.debian.org/debian...

Docker failed with [Makefile:192: imagick_file.lo] Error 127

I try to install php in docker of w2orking project with header in Dockerfile : FROM composer:1 AS composer FROM php:7.4-fpm-alpine COPY --from=composer /usr/bin/composer /usr/bin/composer ENV...

CRC mismatch warning running helloworld.c from gdb on ubuntu 20.04.3

I have the most trivial program $ cat helloworld.c #include <stdio.h> int main(void){ printf("Hello World!\n"); return 0; } $ gcc -g helloworld.c -o helloworld Which I'm wanting to run under...

Puppeteer on Docker M1 Mac fails to open new page (`Target.createTarget`)

I'm unable to launch a new page using Puppeteer within Docker, on an M1 Mac. Versions Docker: version 20.10.11, build dea9396 Node: 16.13.1 MacOS: 12.0.1 (21A559) Puppeteer: 13.0.1 M1 Chip Error...