apt-get error: Sub-process /usr/bin/dpkg returned an error code (1)

I have error in apt-get install it is a error: The following packages have unmet dependencies: gcc-4.8-multilib : Depends: libc6-dev-i386 (>= 2.11) but it is not going to be installed ...

Install pip in docker

I'm not able to install pip in Docker. Here's my Dockerfile: FROM ubuntu:14.04 # Install dependencies RUN apt-get update -y RUN apt-get install -y git curl apache2 php5 libapache2-mod-php5...

Can't install libmysqlclient-dev package when building dockerfile with ubuntu

I have the following content on my Dockerfile: FROM ubuntu:latest RUN apt-get update RUN apt-get install -y python-pip libmysqlclient-dev And I got this output: Step 4 : RUN apt-get install -y...

Raspbian Jessie: Cannot mount NTFS external harddrive anymore after 'apt-get upgrade' (fuse device is missing)

After I used apt-get upgrade earlier today, my Raspberry Pi (Raspbian Jessie) stopped being able to automount my external harddrives anymore. Automounting worked perfectly fine before apt-get...

Apt-get can't install anything due to broken dependencies

Whenever I run apt-get install for any package I get this error ➜ ~ sudo apt-get install clang-5.0 Reading package lists... Done Building dependency tree Reading state information......

Issue in installing php7.2-mcrypt

As I'm trying to load mcrypt extension module from PHP 7.2.X version. So I tried to make use of PECL library that is compatible to the current version of my PHP, in order to get installed and...

How to build my own custom Ubuntu ISO with docker

As a background, I have a custom Ubuntu LiveUSB that will automatically boot into "Try it" and the OS will have pre-installed apps that I have burned into the ISO itself. It works great, but I...

Debian: "apt install build-essential" fails because of unmet dependencies

Using Debian Stretch v9.11. I try to install build-essential, but fails because of unmet dependencies: sudo apt install build-essential Reading package lists... Done Building dependency...

Android SDK on docker

Im trying to run android emulator on docker but I get the following error, I have done some research but none of the answers helped me in achieving my goal, here is the error that I get and my...

Custom shell script not working at boot with EC2 User Data in Launch Templates

I'm having trouble making a bash script run when adding it to the user data on an ec2 launch template. I've looked at suggestions and tried multiple approaches including AWS's suggestion using...

build 32-bit code on 64-bit linux system (kubuntu 18.04)

I'm looking into porting a 32-bit AIX app to linux - doing proof of concept on my 64-bit Kubuntu desktop system. I suppose I could build the app in 64-bit mode, but I'm afraid stuff might break...

Developing .Net core in Ubuntu using VS Code

I am developing a .net core console application where the application interact with SQL server for Linux,located locally, using Entity Framework Core. When I run the application, I get the error...

Error installing sonar scanner in Docker image

I am trying to install sonar scanner in a Docker image and I keep getting the following error in my build on Docker Hub. Tool 'dotnet-sonarscanner' failed to install. This failure may have been...

shiny docker image build failed due to ubuntu package issue

I'm trying to build docker image for my R shiny app. Below is theDockerfile. # Install R version 3.6 FROM r-base:3.6.0 # Install Ubuntu packages RUN apt-get update && apt-get install -y \ ...

How do I install Cario 1.16.0 for WeasyPrint 51 on Ubuntu 18.04

I need Cario > 1.15.4 to get weasyprint 51 working (https://weasyprint.readthedocs.io/en/latest/install.html), but the docs seem to think it as simple as running: sudo apt-get install...

Google Cloud VM startup script fails to install pip3

I'd like to pass a startup-script to my free f1-micro instance VM in GCP. The command that I'm specifying is the following: gcloud compute instances create dora-scanner --zone=us-central1-a...

I can't run apt-get commands. apt --fix-broken install doesn't work. The following packages have unmet dependencies libc6-dbg and libc6-dev

I'm new here I have Ubuntu 18.04 LTS When I run sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt...

Using puppeteer-extra with stealth mode in docker

Trying to use puppeteer-extra and puppeteer-extra-plugin-stealth in docker. When I use the recommended puppeteer Dockerfile I get the errors UnhandledPromiseRejectionWarning: Error: Failed to...

install g++-7: unmet dependencies

I would like to install gcc-7 together with g++-7. First I have installed gcc7 successfully. Of course I've done sudo apt update Then I'm unable to install g++7: [email protected]:/$ sudo apt...

apt get update is posting an error while using debian source

my dockerfile is as below: FROM wordpress:5.5.1-php7.4 RUN echo 'deb http://ftp.us.debian.org/debian sid main' >> /etc/apt/sources.list RUN apt-get update && \ apt-get install -y wget sudo &&...

How to install libstdc++6 debug symbols on Ubuntu 20.04?

For example, take the following minimal example: #include <cstdio> #include <stdexcept> int main(int argc, char* argv[]){ #ifdef __GLIBCPP__ std::printf("GLIBCPP:...

How to fix '(38)Function not implemented: AH00141: Could not initialize random number generator' after upgrading Apache from 2.4.18 to 2.4.46?

I have a running system with Ubuntu 16.04, Apache 2.4.18, PHP 7.3 and 7.4, PHP-FPM, PHP FastCGI, MPM event. I wanted to upgrade to the latest Apache version (2.4.46-2+ubuntu16.04.1+deb.sury.org+3...

Micronaut DI does not work with Graal Native Image built in Maven

I have a minimal app on Micronaut it looks like this: @Introspected public class BookRequestHandler extends MicronautRequestHandler<Book, BookSaved> { @Inject private BookService...

Unmet dependencies (venv & ensurepip) error when running erdpy-up

Trying to install erdpy fails with the following error: $ python3 erdpy-up.py INFO:installer:Checking user. INFO:installer:Checking Python version. INFO:installer:Python version:...

Install Python pip in ubuntu using ansible

I am trying to install Python-pip in ubuntu using ansible and then installing python package, But I am getting following error during Python package install task: failed: [X.X.X.X]...

pip install py-find-1st fails on ubuntu20 & centos with python3.9

This is my process. I start a new aws t2.micro ec2 on ubuntu20 and run this script sudo apt-get update sudo apt-get install gcc sudo apt-get install python3.9 sudo apt-get install...

Docker build exit status 127 (Errors were encountered while processing: libc6:amd64)

Environment: Ubuntu 20.04.3 LTS Docker version 20.10.8, build 3967b7d Kernel version 5.11.0-27-generic Dockerfile FROM python:3.7-slim-buster as base RUN echo 'deb http://deb.debian.org/debian...

Docker failed with [Makefile:192: imagick_file.lo] Error 127

I try to install php in docker of w2orking project with header in Dockerfile : FROM composer:1 AS composer FROM php:7.4-fpm-alpine COPY --from=composer /usr/bin/composer /usr/bin/composer ENV...

CRC mismatch warning running helloworld.c from gdb on ubuntu 20.04.3

I have the most trivial program $ cat helloworld.c #include <stdio.h> int main(void){ printf("Hello World!\n"); return 0; } $ gcc -g helloworld.c -o helloworld Which I'm wanting to run under...

Puppeteer on Docker M1 Mac fails to open new page (`Target.createTarget`)

I'm unable to launch a new page using Puppeteer within Docker, on an M1 Mac. Versions Docker: version 20.10.11, build dea9396 Node: 16.13.1 MacOS: 12.0.1 (21A559) Puppeteer: 13.0.1 M1 Chip Error...