jvm crash after system upgrade

We have a tomcat application that started crashing every 10-15 minutes after we upgraded the OS ("aptitude dist-upgrade" of the system, which is a 32-bit Debian Lenny). java didn't get...

How to get Readline support in IRB using RVM on Ubuntu 11.10

I have tried everything I can think of to get this to work, to no avail so here I am requesting suggestions on how to debug. Firstly, runnning Ubuntu 11.10 Installed rvm: $ bash < <(curl -s...

igraph_neighborhood "Valgrind output: blocks are indirectly lost in loss record "

The next code uses igraph_neighborhood, and it runs good, i don't know why i get #include <igraph.h> #include <fstream> #include <iostream> #include <stdlib.h> #include <vector> #include...

Using std::vector with Igraph

I've been trying to find a really function that let me convert from std::vector of vector to igraph_vector_ptr_t and the opposite way. The reason is, there are different classes like a std::sort,...

libdl.so not found on Ubuntu EC2 instance

I am new to Ubuntu and am running Ubuntu in the Amazon EC2 cloud. I am trying to compile cppunit on the Ubuntu boxes (i386 and amd64) and it will not link to libdl g++ -g -O2 -o...

How do I build my Linux c++ app to link to an old version of libc?

I have built an app on Ubuntu 12.04 and have tried running it on an embedded system. I ran apt-cache show libc6 on my dev machine which shows (amongst other things) Package: libc6 Priority:...

gcc-3.4 compilation error

I need gcc-3.4 for compilation f some software. I installed on my Ubuntu-12.4 using following instruction :-- https://superuser.com/questions/351742/how-to-install-gcc-3-4-on-ubuntu-11-10 sudo...

install valgrind, Fatal error at startup

I am installing Valgrind but encounter some problems. The info of my platform: Linux xx-ThinkPad-X61 3.2.0-39-generic-pae #62-Ubuntu SMP Wed Feb 27 22:25:11 UTC 2013 i686 i686 i386 GNU/Linux I...

Compile new kernel on debian wheezy

I'm trying to compile the 3.8.11 kernel on Debian 7.0 Wheeze. I'm using this tutorial, but have a strange issue on the last step: sudo dpkg -i...

Vim can't find C++ libavformat/libavutil library (No such file or directory)

Loading up the omxplayer.cpp file in vim and it gives me the following error: omxplayer.cpp|34 col 34| fatal error: libavformat/avformat.h: No such file or directory This is where the problem is...

memcpy backtrace no symbols available

I don't know why I can't see this backtrace. The symbols from my own binary are loaded, and the package libc6-dbg is installed. Do I need to tell gdb where to find the libc symbols? Program...

Install 32-bit libraries on a 64-bit machine via Multiarch?

I am installing Intel® C++ Composer XE for Linux on Debian Wheezy 64-bit. During the installation it reports: 32-bit libraries not found 32-bit libraries not found on this system. This product...

Ruby 2.2.0 fails to build on Ubuntu 14.04.1 LTS

I'm trying to build Ruby 2.2.0 on Ubuntu 14.04.1 and it always fails. Here are the packages I'm installing beforehand. DEPENDENCIES = %w{ build-essential bison openssl libreadline6...

Yocto, install Numpy

I am really struggling on installing numpy in my : 3.8.11-yocto-standard #1 SMP PREEMPT Tue May 13 06:46:56 PDT 2014 i686 GNU/Linux system. I apologize but I am very newbie. So I download numpy...

g++ can't locate the installed i386 packages on x64 debian

Compiling multi-arch on Debian (and presumably other Linux versions too, according to the amount of frustrating forum posts found by Google so far), really sucks. Yet I've managed to unravel some...

Cannot Compile Kernel Headers (libc6-amd64 Dependencies)

Edit: Please read the update. I was unable to compile some programs using boost libraries and I was told it was a compiler error. I compiled GCC-5.1.0 from source and placed it in /opt/gcc-5.1.0/...

mingw-w64 cannot link to boost

I have installed g++-mingw-w64-i686 to compile a c++11 application for windows on linux: sudo apt-get install g++-mingw-w64-i686 sudo apt-get install libc6-dev-i386 I am wondering why it cannot...

library stdc++ is not found

I'm trying to compile Boomerang compiler in Ubuntu 16.06. I installed gcc and g++ ver 4.8, I also got g++-4.8-multilib. When I run ./configure --host=i686-linux-gnu "CFLAGS=-m32" "CXXFLAGS=-m32"...

Opening core dump file with different executable but the same sources

I have a coredump file from a colleague's machine. We both have the same sources for the program and the same third party *.so files (like libmysqlclient18 and several in-house ones). The problem...

No include path in which to find limits.h: GCC build limits.h (#include_next limits.h)

I am building GCC for a foreign architecture on Ububtu trusty. I am on an i686 and building for i386. I am having the same problem as GCC build problem (#include_next limits.h). From the...

Error installing dependencies on Debian

I am trying to use phantomjs on a VPS, but it requires fontconfig as a dependency. So I ran apt-get install fontconfig. (The SSH session is in french, so used google translate) Root @ vps27533: ~...

How to install clang on ubuntu14.04

I want to learn llvm so I have to install clang in my ubuntu 14.04,but I encounter some problems.Here it is: when I execute command:sudo apt-get install clang-3.5 I just get some error message...

"The location of Firebird Client Library could not be determined."

I encountered a similar problem as dicussed in here: https://stackoverflow.com/questions/48035341/firebird-embedded-installation-issue-library-could-not-be-determined I'm running a python(3.5.2)...

Running Qt application under wayland

Running: ./myapp -platform wayland gives: This application failed to start because it could not find or load the Qt platform plugin "wayland" in "". Available platform plugins are: eglfs,...

Linker cc not found when cross-compiling simple crate on Travis CI

As part of one of my projects, I have to cross-compile a Rust crate from x86_64 to i686 on Linux. I'm currently using Travis CI for this, with a simple Hello World crate (the default binary...

Linux libc++ seems to be broken

Hay all! Today, i installed the deepin distro (based on debian) on my laptop. When trying to install Discord, it mentioned that the dependency libc++ was broken or impossible. When trying to...

../sysdeps/i386/i686/multiarch/strcpy.c: No such file or directory

I'm trying to debug a program with gdb and when I set a breakpoint and continue on the strcpy() function. I get the following response: [email protected]:~/Documents/theclang/programs/helloworld$ gcc...

Error while compiling gcc4.8.5 for freebsd 11 : error: unknown type name 'choke'

Steps to reproduce the error on a new Ubuntu 14.04 machine. Get include and lib folders from /usr of a previously installed freebsd machine. Set up the folder in the home directory of the ubuntu...

Fix vulnerabilities for Azure ACR

Can someone please advise on how to fix the vulnerabilities found by Klar using Clair scanner for my Azure ACR image. I'm still new to working with containers. Here is a sample of the result from...

Docker failed with [Makefile:192: imagick_file.lo] Error 127

I try to install php in docker of w2orking project with header in Dockerfile : FROM composer:1 AS composer FROM php:7.4-fpm-alpine COPY --from=composer /usr/bin/composer /usr/bin/composer ENV...