Problems installing or compiling seeks Debian Squeeze

I'm trying to install (and compile but the error is due to the same problem in the end) SeekS on my Debian Squeeze (Linux vserver 2.6.32-5-vserver-amd64) Here is the output I get...

g++ executable cannot find shared library

I was working with libevent 2.X at office. At home I have Ubuntu 10.4 which provides libevent 1.4 , so I downloaded and compiled the latest version of libevent. Now I have the header in...

How to update memcached server in Linux

I have installed memcahced server in my machine [email protected]:~$ sudo service memcached start Starting memcached: memcached. [email protected]:~$ telnet 127.0.0.1 11211 Trying 127.0.0.1... Connected to...

install needed shared library debian

XeroxPhaser3100 MFP has only 32-bit drivers. I want to use it with CUPS on my openmediavault (NAS) based on Debian. The OS is 64bit. I install drivers like in this manual...

Fatal error: Incompatible ssh peer (no acceptable kex algorithm)

Running fabric python API and seeing 'Fatal error: Incompatible ssh peer (no acceptable kex algorithm)' on host 'a-stor1' but works fine on 'rack1-app1'. Only difference that I can see is that...

How to build a './configure && make && make install' software against a custom library which I also build?

I am building tmux-2.0 from sources on a pretty regular Linux host. First attempt failed as it turned out that the version of libevent installed is older than required, so I proceeded to download...

Memcached: error while loading shared libraries: libevent-2.0.so.5: cannot open shared object file

Situation: I installed memcached on a CenTOS 5 (64 bit). I also ended up installing some PHP plugins using PECL, though they're unnecessary now. Problem:When I execute /etc/init.d/memcached...

Install cffi for python-for-android

I'm trying to develop an android app with kivy+scrapy(or mechanize) using buildozer. When I add scrapy/mechanize in required field in buildozer.spec file and run buildozer android debug, pip...

how the difference between libevent version 1.4 and 2.0 influence libpcap events?

I'm using libpcap and libevent in a program. the related source codes are: const u_int16_t RELAY_PORT = 8000; pcap_t *create_pcap(const void *dev, pcap_style_t style) { pcap_t *handle; ...

My libevent timer stops as soon as another event occurs... is that normal?

Currently I setup two events: Listen for new connections from clients (I'm a server) A timer to run some code once a second to do various background work On startup the timer works and I can...

How can I produce a Crystal executable with no dependencies?

I'm writing a program in Crystal, that I intend to compile and move to other systems for execution. Ideally, it should have no dependencies, as the target systems will be fresh installations of...

JSONCPP - segfault when declaring JSON::Reader

I have a callback function that gets called whenever it receives something from a socket. It then parses the string and turns it into a JSON object using jsoncpp. However, I'm having a strange...

make[2]: *** [libevent.la] Error 1

I'm trying to install libevent-2.0.12-stable on Centos, but when i type sudo make,error happens(I did ./configure before make): /bin/sh ./libtool --tag=CC --mode=link gcc -g -O2 -Wall...

executable file not found in $PATH when trying to connect to a container in an AWS ECS EC2 instance

I am having a hard to figuring out how to connect to my Docker container inside my EC2 instance via ssh. Basically, I can get into the server okay and list my container using docker ps. However,...

"yum -y install nfs-utils nfs-utils-lib" when installing NFS client on a CentOS vagrant machine

I was trying to "vagrant up" a CentOS machine (centos7-x64-vbox43) with VirtualBox as provider and ansible as the provisioning tool. I executed the following command: vagrant up --provision-with...

Building tmux from source

I'm trying to build tmux from source (downloaded the .tar) and I've encountered some problems with dependencies. When I run ./configure I get this error checking for LIBEVENT... no checking for...

How to check installed libevent version?

I have two different versions of libevent on my Centos 6, libevent version 1.4 (system default) in /usr/lib and version 2.0.21 (built from scratch) in /usr/local/lib (I have come to this...

Broken apt dependency tree

I was upgrading Ubuntu 16.04 to 17.04, when some packaged failed to upgrade. This left the apt dependency in a broken state. I tried some other answers online, but I am afraid this only...

install mysql linux-image-generic

when i install mysql in ubuntu16.04 kernel is 4.8.0 the system want remove two kernel 4.10.0-38 and 4.10.0-40 terminal source code is sudo apt install mysql-server Reading package lists......

Couchbase C SDK install issue

I need to install the cbc tool. On my ubuntu 16.04 host I tried to install couchbase C SDK following these instructions: # Only needed during first-time setup: wget...

Error while loading shared libraries: libevent-2.0.so.5

After upgrade ubuntu 16 to 18. I got this error when execute tmux tmux: error while loading shared libraries: libevent-2.0.so.5: cannot open shared object file: No such file or directory and...

ubuntu 16.04 mysql-server install error

I have problems installing mysql-server on my Ubuntu 16.04: Installation command: sudo apt-get install mysql-server I've tried doing a complete uninstall and purge of mysql using the following...

numpy import SystemError and segfault only through LSF (OpenBLAS blas_thread_init: pthread_create: Resource temporarily unavailable)

When I import numpy with blas 1.1 in a script running through LSF, it gives a SystemError and segmentation fault after repeated instances of OpenBLAS blas_thread_init: pthread_create: Resource...

Why does Dramatiq fail to start in Docker-container?

I am trying to do a distributed task-queue Django-project with Dramatiq as the worker-library. I'm able to run the project without errors when doing it from the dev-environment, but getting...

pg_query(): Query failed: SSL SYSCALL error: EOF detected in php script

After reading several posts (I read an issue with OpenSSL but did not understand how to solve this error), I have not found any solutions to this issue. I understand that it is a connection...

How to install Python 3.6 on Ubuntu 19.04?

I've recently installed Ubuntu 19.04 which has Python 3.7 by default. I need to work on multiple projects that use Python 3.6. Is there a way to install it on Disco Dingo? I tried which works on...

Upgrade to Ubuntu 20.04 killed pip

I upgraded to Ubuntu 20.04 from 19.10 and now I cannot use pip. zeno:~$ pip --version Command 'pip' not found, but there are 18 similar ones. Python is installed: zeno:~$ python3...

Is there a way to tell rpm manager "don't seek XXX.so, because it is included in this rpm."?

I built a RPM, which contains some executables made by me and some .so provided by 3rd SDKs If I manually do the copy work, like make install DESTDIR=/, then all ld dependence is...

Bokeh/panel won't render in-line with Jupyter Lab

I'm trying to visualize Bokeh plots and panels with a Bokeh backend in a notebook in JupyterLab. Things were running fine until I updated. Current packages and versions are below I have tried the...

Unable to Install Jenkins on Ubuntu 16.04

Unable to Install Jenkins on Ubuntu 16.04. I have installed Ubuntu on my computers and trying to configure Jenkins on it however it gives SSL error Commands which fails apt-get install...