Why did I get "Requirements installation failed with status: 1" error with RVM?

This is the message my terminal gave back to me when trying to update Ruby using RVM on a Macbook Pro, OS X Lion 10.7.5, with Command Line Tools, XCode, and Homebrew installed. Error running...

How to install cffi package on AWS Beanstalk

This question looks the same as this post, but since there was no answer, I am re-asking here. I have a Django project to be deployed on AWS Beanstalk, which is using a package cffi. When I run eb...

Cannot "pip install cryptography" in Docker Alpine Linux 3.3 with OpenSSL 1.0.2g and Python 2.7

Solved Wow, these guys are fast... It's basically this https://github.com/pyca/cryptography/issues/2750 It turned out that a security update for openssl was released (DROWN Attack) and that update...

Access Host redis database from docker conatiner

I am trying to connect to host redis database through my docker conatiner. In my dockerfile , I have redis as a requirement, which gets installed [pip install redis] and image is build using that...

PyTorch Cuda with anaconda not available

I'm using anaconda to regulate my environment, for a project i have to use my GPU for network training. I use pytorch for my project and i'm trying to get CUDA working. I installed cudatoolkit,...

Building Python3.7.3 from source missing '_ctypes'

I'm trying to build Python-3.7.3 from source with ensurepip but i'm getting this error: ModuleNotFoundError: No module named '_ctypes' All of the answers online say that libffi-dev is needed but...

docker does not installs the updated pipfile

I am using docker in my project. Initially there was following packages in Pipfile [packages] django = "*" djangorestframework = "*" celery = "*" whitenoise = "*" redis = "*" django-celery-beat =...

Emacs stop working in Mac OSX Catalina. How to fix?

I keep getting this error: emacs dyld: Library not loaded: /usr/local/opt/libffi/lib/libffi.6.dylib Referenced from: /usr/local/opt/p11-kit/lib/libp11-kit.0.dylib Reason: image not found...

resolve pipenv install weasyprint error in Docker

I'm using Alpine linux for my Docker setup. Here is the Dockerfile. # pull official base image FROM python:3.7.4-alpine # set work directory WORKDIR /usr/src/app # set environment variables ENV...

Cocoapods installation failed, Failed to build gem native extension

Cocoapods installation failed, Version: macOS Catalina 10.15.4 ruby 2.6.3p62 (2019-04-16 revision 67580) [universal.x86_64-darwin19] Homebrew 2.2.6 gem 3.1.2 gem sources -l *** CURRENT SOURCES...

How to fix XCode invivisble Headers and Clang compiler issue in MacOS?

GCC- Apple clang version 11.0.3 (clang-1103.0.32.29) is giving me weird results when I try to run any C++/C program. For example, running this code: #include <string> #include <iostream> int...

Ubuntu 20.04 upgrade, Python missing libffi.so.6

I recently upgraded my OS to Ubuntu 20.04 LTS. Now when I try to import a library like Numpy in Python, I get the following error: ImportError: libffi.so.6: cannot open shared object file: No such...

it seems that the version of the libffi library seen at runtime is different from the 'ffi.h' file seen at compile-time

This traceback mess up all my program and I still cant fix it I have tried all methods and it didn't help! Here's the problem: ffi_prep_closure(): bad user_data (it seems that the version of the...

Unable to install cocoa pods

I want to install cocoapods on MacOS to run the pod command. But on doing sudo gem install cocoa-pods I get the following: Building native extensions. This could take a while... ERROR: Error...

Why I'm getting this error while building docker image?

I got the following error while building a docker image by "docker-compose build". ERROR: Couldn't connect to Docker daemon at http://127.0.0.1:2375 - is it running? If it's at a non-standard...

Pip error installing cryptography on Big Sur

Using pip version 20.2.4, Python 3.8.2 and Big Sur 11.0.1. When I run pip install cryptography, I get this error: Building wheels for collected packages: cffi Building wheel for cffi...

Deploy Azure Function with an Alpine - Unhandled 'error' event

I want to deploy Azure function (node and/or python) from the lightest DockerFile. So I need to be able to run az login and func. For now the only one which work well is 2.27GB. I tried a lot of...

How to get rid of cryptography build error?

I am trying to build a dockerfile but the problem is when it trying to build specifically cryptography is not building. MY Dockerfile FROM python:3.7-alpine ENV PYTHONUNBUFFERED 1 RUN apk update...

How to update cocoapods for flutter on Mac without getting an error?

I use Flutter with Android Studio on a Mac. One day (today), I ran "flutter doctor" from the command line. It stated that my "cocoapods" was not good enough. Doctor summary (to see all details,...

Error installing Jekyll: Failed to build native extension | macOS BigSur

maybe someone can help me. I follow the instructions on https://jekyllrb.com/docs/installation/macos/ I have installed Ruby 3.0.1 via homebrew and set all paths. ruby 3.0.1p64 (2021-04-05 revision...

Error installing cocoapods : Failed to build gem native extension

I am trying to install cocoapods to my mac [ macOs bigSur 11.1 , Xcode 11.3 ] but after typing sudo gem install cocoapods i get the following error things i have tried : i was able to install...

Alpine image build hangs on matplotlib

I'm sure this was working a few weeks ago. I can no longer install matplotlib on an Alpine base image. A cut down version of my Dockerfile is: FROM python:3-alpine RUN apk add --no-cache...

Can not get asdf-direnv work in docker when building

I'm trying to use asdf-direnv in docker. Following the README of asdf-direnv, I make this Dockerfile FROM nvidia/cuda:10.2-devel-ubuntu18.04 RUN chsh -s /bin/bash SHELL ["/bin/bash", "-ic",...

Building wheel for cffi (setup.py) ... error while installing the packages from requirements.txt in django

I am trying to install a new Django project from git, I created a new virtual envt using python3(version: 3.8.5). When I try to install the required libraries in the requirements.txt, I get the...

Cannot pip install mediapipe on Macos M1

Hello fellows I'm using mac air with M1 chip My env sets like (CV) san  ~/work/python  conda list # packages in environment at /Users/san/miniforge3/envs/CV: # # Name ...

How does one install pytorch 1.9 in an HPC that seems to refuse to cooperate?

I've been trying to install PyTorch 1.9 with Cuda (ideally 11) on my HPC but I cannot. The cluster says: Package typing-extensions conflicts for: typing-extensions torchvision -> pytorch==1.8.1 ->...

libstdc++.so.6: version `GLIBCXX_3.4.26' not found on Linux

I was trying to load Seurat package in rstudio and got this error Error: package or namespace load failed for ‘Seurat’ in dyn.load(file, DLLpath = DLLpath, ...): unable to load shared object...

UnsatisfiableError while installing Miniconda

I wanted to reinstall Miniconda. I have first removed the entire Miniconda install directory, edited the bashrc file to remove the Miniconda directory from the PATH environment, and removed the...

Unable to install Cocoapods in macOS Monterey Version 12.0 Beta - Xcode 13.0(13A233)

unable to install Cocoapods in MacOS 12.0 Beta and Xcode Version 13.0 here is terminal output for sudo gem install cocoapods [email protected] ~ % sudo gem install...

Airflow set python library versions to improve build speed

It used to take ~5 minutes for our Airflow deployment's docker image to build, and all of a sudden it is taking over an hour. With that said we haven't had to rebuild our image in a few months, so...