Why can't I build a "hello world" for glib?

So here's the world's simplest glib program: #include <glib.h> I try to compile it with gcc test.c and I get: test.c:1:18: error: glib.h: No such file or directory So I make sure that I have...

Dependency error while installing mysql workbench on ubuntu 12.04

I am trying to install mysql workbench. I am getting below error. It seems that it looks for mysql in some default directory. I have all the required things installed, but not where mysqlworkbench...

Install Webkit for Standalone HTML Desktop App

A few months ago I converted my web application to run as a linux app (kind of, it's just in a web browser to give the illusion that it's a full fledged linux app) I made it on Ubuntu 14.04 and...

docker Unable to connect to archive.ubuntu.com:http: [IP: 209.6.3.210 80]

I'm having issues building my Dockerfile (on OS X), getting the above error for multiple libraries. I've tried adding google dns servers and the below sources.list workaround but nothing that I've...

Ubuntu 12.04: Installing MonoDevelop "broken packages"/"unmet dependencies" error

I am very new to Linux, so please forgive me if the answer to my question is obvious. Since I am running an ARM device and can't install wine, I am trying to install Mono/Develop. The problem is,...

mono-project on dreamboxn dm7080 HD

I did not find a way to install mono-project for my dream box. It would be cool, to watch official TV in Switzerland over my brand new DM7080 and it's browser. What I found on the net...

Installing MySQL 5.6 in Ubuntu 14.04 triggers removal of needed packages

So I was trying to make a fresh installation of MySQL 5.6 on Ubuntu 14.04.2 and for some reason it tried to remove needed packages, not without first complaining about some unmet dependencies....

JSZip Read Zip File and Execute from an Existing Zip File

I've been using JSZip to read and write zip files in Javascript. What I'm trying to do is load a web app (index.html, style.css, image files, and whatever else the user requires for their web app)...

C Web Browser Download File

WebkitGTK+ API Reference What I'm trying to do is run my HTML5 app on Linux that way I and my users can still use my app without relying on an internet connection. My problem is when I go to...

So much dependencies for installing the package 'nmap'

I want to install the package nmap on debian by the command apt-get, but It seems that the package nmap depends on so many dependencies! For example It depends on the packages imagemagick and...

ImportError /lib/ld-linux-armhf.so.3: version `gLIB _2.4' not found

I am currently getting an import error and it seems to happen on the requests module in python. Here is the error I am getting on my RPi Traceback (most recent call last): File...

How to increase GL_MAX_TEXTURE_SIZE for mesa drivers?

I am trying to generate a large image using WebGL and Xvfb. When the WebGL canvas size is up to 8192x8192px - it's working great and I get my image. When the WebGL canvas size is larger than...

Phalcon extension unloaded after system upgrade

So, I am using Phalcon 3.0.0 with PHP 7 on Ubuntu 16.04.1 on DO. Everything worked correctly until today, when I ran apt update and upgrade on Ubuntu. After the process finished, Phalcon plugin...

apt-get upgrade, apt-get install not working.

I recently updated Python 2.7.6 to Python 2.7.12. Since then, when I run apt-get upgrade or apt-get install or apt-get autoremove` I get the following error: Reading package lists... Done Building...

How to fix broken apt-get on debian wheezy?

I'm using a debian wheezy at work. Packages are held in specific versions. My /etc/apt/sources.list contains lines like : deb http://mycompany.com/debian/debian-main/ wheezy main non-free...

Docker container change behaviour on different hosts

I build a docker container using differents tools (sentinelsat et sen2cor) : #Modified Ubuntu docker image, adding some dependencies #Starting image FROM ubuntu #Install of...

Installing flex on fresh Debian 9

TL;DR: The error is, "Package 'flex' has no installation candidate." I can't seem to install flex on fresh, new Debian 9 install (on a VM, if that makes a difference). I have installed it on...

Broken apt dependency tree

I was upgrading Ubuntu 16.04 to 17.04, when some packaged failed to upgrade. This left the apt dependency in a broken state. I tried some other answers online, but I am afraid this only...

Dockerizing kafka gives non zero exit code

I am a newbie trying to learn docker. I am trying to dockerize kafka installation and stuck with a non zero exit code. I would like to debug the issue and find out the reason. How to debug a...

Dist Upgrade to Buster failing

I currently have a Dockerfile which has started to failing (with no changes in the Dockerfile) The Dockerfile has the following contents: FROM php:apache-stretch WORKDIR /tmp # SOFTWARE REQS RUN...

Python-opencv import error, packages installed

I've installed opencv as said here: https://docs.opencv.org/3.4/d2/de6/tutorial_py_setup_in_ubuntu.html --------------------------------------------------------------------------- ImportError ...

How to install pip into a ubuntu container while keeping layers to a minimum?

I'm interested in building a small container image which has pip-installed packages, but unfortunately, installing python3-pip via apt-get pulls in a lot of dependencies (348MB) into an otherwise...

Rails & Docker: configure bundler to run bundle install in a docker build for Rails.4.2.6?

I am having so much trouble with docker. It seems to be a pattern. I have a dockerfile which installs Node.js and Yarn from source repositories fine. I install ruby from the get-apt repositories...

Missing python packages in Docker container

I am working on a tensorflow notebook in a Docker container. I manage additional dependencies via pipenv which I install during the build phase of the container. Strangely enough some packages,...

Dockerfile compatibility with Raspberry Pi?

I have built the image from the following Dockerfile in my Rpi Kubernetes cluster. However, I was getting status of CrashLoopBackOff for my Pods. After a bit of search on the internet, I realized...

Pyppeteer fails to download headless chrome when running on AWS Lambda

Pyppeteer (python port of puppeteer) is trying to download linux-chrome but fails to download. This is a python project, that I have dockerized and used serverless to deploy into an AWS Lambda....

cannot configure qemu 4.1.1 for building

I’m trying to compile Qemu from sources and as such face the well known errors of requiring Glib-2.4 and gthread-2.0 ERROR: glib-2.40 gthread-2.0 is required to compile QEMU I’m on Linux Mint...

NodeJS 'appendFile' not creating file in Docker container

I have an application that creates a few CSV files in its working directory while it runs. The application runs fine outside of my docker container, but when I run it within, I get an...

Can't include glib library in my CMakeLists.txt - undefined reference

I installed glib2.0 library on my Linux distribution through sudo apt-get install libglib2.0. The library has been installed at /usr/include/glib-2.0. At this point, I prepared a very dummy C...

Gitlab runner ECS fargate build docker images

I have moved my gitlab-runner infrastructure to AWS ecs fargate and now it is working fine. But I have problem, I have a .gitlab-ci.yml file and has following commands: stages: -...