Problems with Gst in python program

I'm in trouble making a simple server/client socket python program. Basically, my server (RPi3) has to stream a video (with Gstreamer) to the client (Fedora 24). The problem is that in my Fedora,...

How to increase GL_MAX_TEXTURE_SIZE for mesa drivers?

I am trying to generate a large image using WebGL and Xvfb. When the WebGL canvas size is up to 8192x8192px - it's working great and I get my image. When the WebGL canvas size is larger than...

glib.h: No such file or directory

I tried installing gtk and glib using sudo apt-get install libglib2.0-dev and sudo apt-get install libgtk2.0-dev but locate glib.h does not return any path for glib results of locate glib.h...

mingw-64 - Install package

I am using mingw_64 and CLion in Windows 10 to try to use a library (https://github.com/libtrading/libtrading) in a simple project, but the library requires some packages to be installed prior the...

How can I run selenium chrome driver in a docker container?

#tl;dr How can I install all the components to run Selenium in a docker container? Question I'm starting with this image: FROM microsoft/aspnetcore-build:2 AS builder WORKDIR /source COPY ....

Can apt-get autoremove remove system files?

I tried to install Python 3 on my Ubuntu 16.04.4 LTS and while using apt i found this: The following packages were automatically installed and are no longer required: cabextract gcc-5-base:i386...

Missing python packages in Docker container

I am working on a tensorflow notebook in a Docker container. I manage additional dependencies via pipenv which I install during the build phase of the container. Strangely enough some packages,...

Error while installing libpulse-dev package in ubuntu

When i try to install libpulse-dev i am getting error as The following packages have unmet dependencies: libpulse-dev : Depends: libglib2.0-dev but it is not going to be installed E: Unable to...

Unable to locate package libcfitsio3

I am trying to install the presto pulsar software. I am at the first step in which I have to install some packages. I am entering the following command: "sudo apt-get install git libfftw3-bin...

ssl.SSLError: [SSL: UNSUPPORTED_PROTOCOL] unsupported protocol (_ssl.c:852) in Docker Python:3.6-slim

I am using Docker to setup my Python environment. For, that I am using the python:3.6-slim base image. I need to now send a get request to a URL which is only available in the intranet (let's...

Unable to install `gattlib`

I am trying to install gattlib in Python in order to use some of its Bluetooth-tools. The OS is ubuntu 18.04.4 LTS. I have by now tried the following (as e.g. here): sudo apt-get install...

Can I copy a directory from some location outside the docker area to my dockerfile?

I have installed a library called fastai==1.0.59 via requirements.txt file inside my Dockerfile. But the purpose of running the Django app is not achieved because of one error. To solve that...

CircleCI 2.1 build failing

I am having some issues setting up my CircleCI config.yml file to accommodate a Cypress e2e test after I upgraded it to version 2.1. It keeps failing with the following error: #!/bin/sh -eo...

Cannot find implementation of glib2-0 library (sudo apt-get install libglib2.0-dev)

I'm developing a C project in Eclipse that needs glib library functions. I run sudo apt-get install libglib2.0-dev and, indeed, at the path /usr/include, glib-2.0 appears. The point is that only...

How to install a specific version of Google Chrome on GitLab CI?

I use CI/CD Gitlab with this script but my Chrome webdriver version is setted in my Maven project (pom.xml): before_script: ########################## # Install gnupg2 # ...

Use openvino from docker

I am trying to use OpenVINO from docker container. I use docker file from official web site https://docs.openvinotoolkit.org/latest/_docs_install_guides_installing_openvino_docker_linux.html FROM...

ROS2 Eloquent installation failed in Ubuntu 18.04.4 LTS

Referring to this link, I am installing ROS2 Eloquent into my Ubuntu 18.04.4 LTS. My system's information is as below (via uname -a) Linux myname 5.3.0-28-generic #30~18.04.1-Ubuntu SMP Fri Jan 17...

Building Mailcore2 on linux

I'm trying to build the mailcore2 library on linux (Ubuntu 18.04) but having a hard time. (Mostly) following the directions on their repo here:...

Python code inside container fails to access Redis inside second container

Context : I'm trying to run through a Docker container a Plotly-Dash/Flask based web application that connects to a Redis server that runs inside a second container. I'm trying to achieve...

Devops CICD run ReactJS application while testing with jest + puppeteer

Scenario I'm working on getting my end-to-end tests to work in a GitLab pipeline. Currently all the tests run locally but I'm having an issue getting them to run using GitLab's continuous...

Using puppeteer-extra with stealth mode in docker

Trying to use puppeteer-extra and puppeteer-extra-plugin-stealth in docker. When I use the recommended puppeteer Dockerfile I get the errors UnhandledPromiseRejectionWarning: Error: Failed to...

Azure Function deployed via Azure DevOps pipeline not executing

I have created an azure pipeline to deploy a custom docker image with an azure function with the following config. Though the config works in terms of build but none of the functions are running...

How to fix a problem that "apt-get install" doesn't work because of python issue

I'm using Ubuntu 16.04.I'd like to install a ROS related package with "apt-get install", but it doesn't work. Terminal said like following. $ sudo apt-get install ros-kinetic-libuvc Reading...

Failed to launch Base! /app/.local-chromium/Linux-706915/chrome-linux/chrome: ... libX11.so.6

I have an instance of puppeteer-sharp running on ASP.NET Core 3.1 that works fine locally. For deployment, it gets built in a docker container and deployed to a K8 dev cluster. The docker...

Getting Symfony\Component\Process\Exception\ProcessFailedException while downloading a pdf using Puppeteer

I am using puppeteer to download a pdf. I have installed the puppeteer using the following commands. 1.curl -sL https://deb.nodesource.com/setup_12.x | sudo -E bash - 2.sudo apt-get install -y...

Firefox headless not working within Docker as non-root user

As the title says, I'm having trouble running Firefox in headless mode inside a Docker container as a non-root user. Consider the following Dockerfile, built with docker build -t firefox . FROM...

Install libgtk-3-dev on Ubuntu 20.04

I would like to write a GUI in cpp. As far as I know gtk is a nice solution for this. Sadly it appears to me that gtk is no longer available under Ubuntu 20.04. (I am using Xubuntu if this...

ValueError from detectron2 import model_zoo

I am trying to install detectron2 inside a Docker container to use it into a project, but after being able to install all the dependencies, I get an error when I try to import model_zoo. Full...

GCP Compute Engine VM startup-script and SSH Breaks after `apt-get update`

To install git on e2-medium (2 vCPUs, 4 GB memory) Debian GNU/Linux 10 (buster) instances, we run the following script defined in the startup-script-url as per the instructions seen here: GCP...

Puppeteer on Docker M1 Mac fails to open new page (`Target.createTarget`)

I'm unable to launch a new page using Puppeteer within Docker, on an M1 Mac. Versions Docker: version 20.10.11, build dea9396 Node: 16.13.1 MacOS: 12.0.1 (21A559) Puppeteer: 13.0.1 M1 Chip Error...