WARNING: erroneous pipeline: no element "rtspclientsink"

I have a gstreamer command that requires "rtspclientsink" and the error I get is: > WARNING: erroneous pipeline: no element "rtspclientsink" I tried to reinstall gstreamer using the following...

gstreamer: No such element or plugin 'v4l2sink'

The problem I am trying to execute a script. Part of it needs to execute v4l2sink. I tried to execute this gst-launch-1.0 videotestsrc ! v4l2sink device=/dev/video1 & mplayer -tv...

Qt Multimedia: Library 'gstreamer' is not defined

I have problem building QtMultimedia with GStreamer: [email protected]:~/sources/qt/build$ /usr/local/Qt-5.12.1/bin/qmake -r GST_VERSION=1.0...

Gstreamer plugins not found by gst-inspect-1.0

I'm running Ubuntu 16.04 with Anaconda Python distribution. I installed gstreamer-1.0 libraries using Synaptic. I wanted to test my installation with: gst-inspect-1.0 fakesrc (as suggested in the...

Unable to get Gstreamer1.0 plugins/features

I am having trouble working with gstreamer1.0. gst-launch-1.0 filesrc location=test.mp3 ! mad ! autoaudiosink ERROR: pipeline could not be constructed: no element "filesrc". This...

Error while installing postgresql

I've never used postgres, only MySQL, so it's new for me. I'm trying to installing it on a VM(so I can use only command line). Running the command sudo apt-get install postgresql this is my...

Which Gstreamer in PyQt5?

On Ubuntu 16.04 and 18.04 whenever I'm trying to use QMediaPlayer I'm being prompted with no service. >>> from PyQt5 import QtMultimedia >>> qtm =...

cmake kms-elements gstreamer-sctp-1.5

First i get the source of kms-element from https://github.com/Kurento/kms-elements git clone https://github.com/Kurento/kms-elements.git Then mkdir build cd build cmake .. Result package...

GStreamer installation is missing a plug-in

I hope that someone can help with this problem, been searching for a solution for the past 2 days. To describe the problem in short: I'm trying to make a simple qt5.7 application that will stream...

QMediaPlayer doesn't play anything on Ubuntu 16.04 / Qt 5.6

I'm using the official Qt 5.6 SDK on Ubuntu 16.04 and when I try to play an mp3 file I just get: defaultServiceProvider::requestService(): no service found for -...

Register a Gstreamer1.0 Python Element? Wanting to react to bus element messages

I am new to Gstreamer, so I apologize if this question is very simple, but I've been stuck for way too long. I'm using Mopidy on my raspberry pi to play music through speakers. When Mopidy is...

QT QCamera segmentation fail on setCamera

i try to run camera example for QT5 using notebook integrate camera on Ubuntu 20 ``` Camera::Camera() : ui(new Ui::Camera) { ui->setupUi(this); //Camera devices: QActionGroup...

GStreamer x264 on Linux (ARM)

Trying to get streaming work with x264 encoding. I am doing some black magic with stitching two images which is known to work: gst-launch-1.0 -e \ v4l2src device=/dev/video0 ! \ ...

Unable to play video Qt5 multimedia ubuntu 16.04

I am trying to use QMediaPlayer class to play videos, but keep getting this error - `GLib-GObject-WARNING **: cannot register existing type 'GstObject' GLib-CRITICAL **:...

OpenCV can't find Gstreamer

I had Ubuntu 18 with OpenCV and GStreamer setup correctly. After a while, OpenCV can't detect Gstreamer anymore. I don't remember what I installed in between. apt list...