To install ia32-libs on debian wheezy amd64

I'm using Debian 7 (wheezy) amd64. uname -a Linux tzwm-debian 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux And I want to install ia32-libs in my Debian. But this happens when I try to...

Ubuntu install previous version of erlang solutions package

I am trying to create a fabric script that will install the erlang solutions R15B02 package and am having some difficulty. I have the following code in my fabric script: sudo("apt-get update") ...

Vagrant error : Failed to mount folders in Linux guest

I have some issues with Vagrant shared folders, my base system is Ubuntu 13.10 desktop. I do not understand why I have this error is something that is not right configured ? Is a NFS issue or...

Qt: How to find text, while the criteria is in a QStringList?

I load a file with QTextStream, then read it line by line with readLine. Then I want to get the line which have some keywords. Then, I remove the keywords from each line, so I will get entire line...

Homestead provisioning error

Because I need LDAP functionality in my webapp need to provision my Homestead box with 'sudo apt-get install php5-ldap' So in my homestead.rb I added: # Install addons like LDAP...

No such file or directory' while attempting to get adb version

I had install Android adt bundle for linux in my computer(Ubuntu 13.04). But now when I run my eclipse in adt bundle following error appers:- 2014-11-04 13:25:50 - adb] Unexpected exception...

Update R version from 3.0.3 to 3.1.2

I want to update R with ubuntu from 3.0.3 to 3.1.2. I am working on Ubuntu 14.04LTS, 64bits. I did the following: cd /etc/apt/ sudo gedit sources.list I added the following line : deb...

mistakenly installed ImageMagick on Debian - how to remove it?

I went to install imagick PECL extension on debian. I mistakenly installed ImageMagick with 75 MB unnecessary dependencies. Could someone please help me and tell me the simplest way to remove it...

Why does building from a docker file take up all the disk space?

I am using docker-compose to build and run my application. here is the docker-compose.yml: db: image: postgres web: build: . command: sh startup.sh volumes: - .:/code ports: -...

So much dependencies for installing the package 'nmap'

I want to install the package nmap on debian by the command apt-get, but It seems that the package nmap depends on so many dependencies! For example It depends on the packages imagemagick and...

Vagrant plugin load order

I am behind corporate proxy which is using self-sign certificate to intercept ssl trafic. So I have installed vagrant-ca-certificates to have certificate in vm. I am also using vagrant-omnibus to...

Can't run vagrant up

Ok this is pretty simple: I'm on windows 10. I just downloaded Vagrant v1.8.0 and Virtualbox 5.0.12. All i did i just: vagrant init so my VagrantFile only contains this : Vagrant.configure(2) do...

Ubuntu / DigitalOcean - Unable to fetch packages to install git on a fresh install

Just started with a fresh install of Ubuntu 14.04 on my digitalocean droplet and I'm trying to install git. My first attempt failed to install some packages - [email protected]:~# sudo apt-get install...

Net::HTTPServerException causing Chef to fail

I'm attempting to set up a Rails environment with Vagrant and Chef by following this guide. I've used it in the past with success. When I run vagrant up it fails, and (I think) this is the...

dpkg: error processing archive /var/cache/apt/archives/golang-1.6-go_1.6.2-0ubuntu5~16.04.2_amd64.deb (--unpack):

When I am running sudo apt-get -f install, it shows dpkg: error processing. Please find the complete logs below and advise how to solve this. I am running VB 5.0.10 with Ubuntu 16.04 and already...

Broken apt dependency tree

I was upgrading Ubuntu 16.04 to 17.04, when some packaged failed to upgrade. This left the apt dependency in a broken state. I tried some other answers online, but I am afraid this only...

Cygwin xclip fails without cygXmu-6.dll

Tried to install xclip running as administrator, but Got this: $ apt-cyg install xclip Installing xclip xclip-0.12-2.tar.xz: OK Unpacking... Package xclip requires the following packages,...

How to minimize an ubuntu docker image which needs only git, cron and openjdk-8-jre

Testing some docker project so after playing with alpine, I would like to use ubuntu:bionic for production. I decided to roll out my own image but the problem is that it's 600MB+ . REPOSITORY ...

Use OpenCV on deployed Flask app (Heroku)

Hello I seem to be having trouble importing opencv on my deployed flask app on Heroku! I've referred to similar posts such as this this "ImportError: libSM.so.6: cannot open shared object file: No...

How to deploy an application which uses opencv on Heroku?

I have been trying to deploy my app on Heroku but I get following error: 2019-01-08T23:19:07.321214+00:00 app[web.1]: ImportError: libSM.so.6: cannot open shared object file: No such file or...

Rails & Docker: configure bundler to run bundle install in a docker build for Rails.4.2.6?

I am having so much trouble with docker. It seems to be a pattern. I have a dockerfile which installs Node.js and Yarn from source repositories fine. I install ruby from the get-apt repositories...

How to install libgtk2-dev:i386 without removing libgtk2-dev:armhf? Or what to do to cross-compile for i386 and armhf?

I'm struggling trying to cross-compile a wxWidgets app for a BBB from a Debian 9 PC. After a lot of failures, i've found what seemed to be the solution: multiarch. So i added an armhf...

how to fix php-gd failing to install debian

i know this question has already been asked, but it didn't have an answer that worked for me and i cannot comment as i do not have enough reputation. I'm not able to install php-gd extension on my...

Problems running openGL in a container

I am trying to containerize a QT-based GUI application (specifically, ITK-SNAP) with X11 forwarding. When I build an image (let's call it itk-snap:3.8) with the following Dockerfile # 16.04...

ImportError: libGL.so.1 : error when accessing Heroku app

I have a probem with accessing my heroku app because of following error 2020-09-11T10:25:09.492648+00:00 app[web.1]: ImportError: libGL.so.1: cannot open shared object file: No such file or...

NPM requires x11 during installation via apt

I running Ubuntu server 20.04 and i need to install npm. But when i run "apt install npm" i see x11 packages in requirements. The following NEW packages will be installed: gyp javascript-common...

Relevant tags