dpkg: error processing archive /var/cache/apt/archives/golang-1.6-go_1.6.2-0ubuntu5~16.04.2_amd64.deb (--unpack):

When I am running sudo apt-get -f install, it shows dpkg: error processing. Please find the complete logs below and advise how to solve this. I am running VB 5.0.10 with Ubuntu 16.04 and already...

Upgrade PostgreSQL from 9.6 to 10.0 on Ubuntu 16.10

My database is over 600 GB and my current volume is only 1 TB, so that probably limits my options. My config files are here: /etc/postgresql/9.6/main My database is...

Hyperledger fabric make error when it makes couchdb docker part?

everyone . I have a problem here. when i do the process follow the https://hyperledger-fabric.readthedocs.io/en/latest/dev-setup/build.html. With "make dist-clean all", when it runs to make...

Tensorflow only works under root after drivers update

I had a working Tensorflow for Python installation on my Ubuntu 16.04.3 LTS Xenial / nVidia GTX 1080 Ti machine. Then, the nVidia drivers got updated from 374 to 384.90 (nvidia-smi reports...

Dockerizing kafka gives non zero exit code

I am a newbie trying to learn docker. I am trying to dockerize kafka installation and stuck with a non zero exit code. I would like to debug the issue and find out the reason. How to debug a...

Unable to install CouchDB on Ubuntu 17.10

I am trying to install CouchDB on Ubuntu 17.10. I get the following error message when using apt-get: sudo apt-get install couchdb Reading package lists... Done Building dependency tree ...

cx_Freeze cannot find libicuuc.so.56 and libQt5EglFSDeviceIntegration.so.5

I'm trying to freeze and package a PyQt5 app on Ubuntu 16.04.02 into an exe file, but cx_Freeze reports that it can't find libicuuc.so.56, libicudata.so.56 and...

Upgrade .Net Core 1.0 to 2.0 Ubuntu 16.10

I'm trying to upgrade the .net core version from 1.0 to 2.0 but I'm getting some errors. I'm not good at Linux, so I don't understand well what's happening. I run: apt-get install...

Is it possible to run PowerShell Core in a Linux dotnet container?

I can see there is no Powershell present in microsoft/dotnet: C:\> docker run -it microsoft/dotnet:2.1-sdk bash [email protected]:/# pwsh bash: pwsh: command not found When I try to add it in...

Can apt-get autoremove remove system files?

I tried to install Python 3 on my Ubuntu 16.04.4 LTS and while using apt i found this: The following packages were automatically installed and are no longer required: cabextract gcc-5-base:i386...

Install dotnet core on Linux Mint 19

After following Microsoft tutorials on how to install dotnet core on linux mint 19 i got stuck to : sudo apt-get install dotnet-sdk-2.1.4 I got prompted that it needs dotnet-runtime-2.0.5 to be...

Failed Install Latest Postgres (11.1) in Linux Mint 17.3 (rosa)

I have problem while installation postresql-11 in Linux Mint 17.3, with environment: [email protected]:/home/clutax > sudo lsb_release -a [sudo] password for clutax: No LSB modules are...

Rails & Docker: configure bundler to run bundle install in a docker build for Rails.4.2.6?

I am having so much trouble with docker. It seems to be a pattern. I have a dockerfile which installs Node.js and Yarn from source repositories fine. I install ruby from the get-apt repositories...

Cannot install Posgresql on Ubuntu 19.04

Typing sudo apt-get install postgresql-11 gives me error: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the...

How can I fix a "Segmentation fault" error running "dotnet" command on RasPi?

I am trying to install the ".NET Core 3.0" runtime on my old Raspberry Pi B+ first gen but I am not able to get it run because of a Segmentation fault running the dotnet command. First of all I am...

install postgresql on ubuntu 19.10

I'm trying to install postgresql on ubuntu 19.10 (Eoan). I've tried many ways but it seems that even the newest version of postgresql (12) is not supported. Does anyone know if it can be installed...

installing dotnet core in ubuntu end up having dependency conflicts

I did install dotnetcore in ubuntu without any problem earlier. But sometime I end up having dependency issues with in earlier version but always with ubuntu 20.04. I am following the guidance...

Invalid menu directory 'Accessories/pcmanfm.desktop

Previously I installed the pytesseract lib on my Raspberry Pi, now I need more space, so I want to uninstall this lib. I used these command to uninstall the lib: sudo apt-get remove...

Dockerfile RUN call powershell on Ubuntu-based image

I have the following in my Dockerfile: # setup powershell # Download the Microsoft repository GPG keys RUN wget -q https://packages.microsoft.com/config/ubuntu/16.04/packages-microsoft-prod.deb #...