PHP 5.6 Mcrypt x64 and MIT Scheme not compatible?

I have PHP 5.6 PHP 5.6.17-1+deb.sury.org~trusty+2 (cli) installed currently, on Mint 17.2 x64 (Cinnamon). If I try to install mit-scheme, I get: sudo apt-get install mit-scheme Reading package...

can't delete broken mysql install nor fix dependencies (Kali 2)

In the process of upgrading my Kali2 distrib, I ran into a chicken-and-egg problem. When I try to install something (anything) or even to autoremove, I get this: [email protected]:~$ sudo apt-get...