Need help installing Mono framework on Raspberry Pi3 running OpenHab2 (openhabian)

I'm trying to install Mono on a Raspberry Pi3 that runs OpenHab2 (openhabian). Unfortunately I'm not familiar with Linux and need some help please. I followed Mono for RPI instructions from here...

How to successfully install full Mono Develop IDE on Debian?

I cannot install Mono for .NET on Debian. I've tried it as here (http://www.mono-project.com/docs/getting-started/install/linux/#debian-ubuntu-and-derivatives) and first three commands worked...

Building a debian package for Mono GTK# app that doesn't rely on xamarin assemblies?

I built up a debian package for my solution so that I can actually distribute the app. But when I put it on a clean machine I get the error: Dependency is not satisfiable:...

when installing mono getting various errors?

requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may...

Mono didn't find UIA Bridge, but the packages are already installed

i was searching for a long time now but cant find a solution for my problem: i compiled a c# project successfull (with monodevelop) and when i try to run it with >mono fubar.exe i get the...

Unreal Engine 4 Setup problems

I am trying to run the Unreal Engine-4 setup on Ubuntu 14.04 but when running the command sudo apt-get install build-essential mono-gmcs mono-xbuild mono-dmcs libmono-corlib4.0-cil...

Can't install libgtk2.0-dev on linux

I am trying to compile xfce-terminal, configure will not pass saying I lack gtk2 checking for gtk+-2.0 >= 2.24.0... not found *** The required package gtk+-2.0 was not found on your system. ***...

Ubuntu 13.04: how to build Monodevelop 4.0.1?

I downloaded sources from git: git clone git://github.com/mono/monodevelop.git and dependencies: cd monodevelop && git submodule init && git submodule update I setup mono 3.0.11...

mono-project on dreamboxn dm7080 HD

I did not find a way to install mono-project for my dream box. It would be cool, to watch official TV in Switzerland over my brand new DM7080 and it's browser. What I found on the net is:...

Ubuntu 12.04: Installing MonoDevelop "broken packages"/"unmet dependencies" error

I am very new to Linux, so please forgive me if the answer to my question is obvious. Since I am running an ARM device and can't install wine, I am trying to install Mono/Develop. The problem is,...

Monodevelop - Try to install on linux Precise 64 (Ubuntu 12.04 LTS)

I'm trying to install Monodevelop from http://www.mono-project.com/docs/getting-started/install/linux/#debian-ubuntu-and-derivatives. I'm using a virtual Box VM via Vagrant with an Ubuntu Precise...

Cannot cross-compile Mono for ARM

For the last three days I've been trying to cross-compile Mono 2.11.4 for the TechNexion Blizzard board (running an unknown version of Angstrom) using a virtual Ubuntu (12.04) on my Win7 32 bit...

Installing Older version of Mono Raspbian

I tried https://stackoverflow.com/questions/33763177/install-older-version-of-mono but it does not help here is what I run sudo apt-get purge mono-devel echo "deb...

Raspberry PI with latest Mono

I would like to port some existing WinForms project into Raspberry PI but I'm having little success, mainly because it seems Mono's WinForms implementation has bugs in the TextBox widget. After...

Mono Winforms application in Linux: some text is not displayed

In general, I have been having difficulties porting my .NET Windows Forms applications created in Visual Studio 2008 to Mono/Linux. The problem is that sometimes, some types of text do not get...

Getting a NullReferenceException in Xamarin.Forms on Android when backing out of app

I'm using Xamarin Forms 4.2.0 and utilizing Xamarin.Forms Shell. Pressing the back button seems to work find when navigating through the various screens in my app, however, when I press back to...

Packages have unmet dependencies when installing mono-devel in Kali (Debian)

I tried to install mono-devel and typed sudo apt-get mono-devel in the terminal. But failed and got the following results: ~# apt-get install mono-devel Reading package lists... Done Building...

How to install the latest version of Mono and MonoDevelop on Ubuntu?

I'm trying to install the latest version of the Mono framework and MonoDevelop on my system. Yesterday I tried the installation on Ubuntu (14.04 LTS) and on Debian (V8.2) today. Both installations...

Unmet dependencies when installing Mono 3 on XBMCbuntu 12.10

I am trying to install Mono 3 on a 32bit XBMCbuntu 12.10 box. I followed the instructions on http://mono-project.com/DistroPackages/Debian. I added the line deb...

Mono 3.0.6 on Raspberry PI - is it supported?

I am following instructions from this page to install Mono 3.0.6 on my Raspberry PI. Unfortunately without success: Reading package lists... Done Building dependency tree Reading state...

How do I profile a Xamarin.Mac app built with Visual Studio for Mac?

I'm trying to profile a Xamarin.Mac app with the mono profiler, but I encounter errors. The app is built locally for debugging with Visual Studio for Mac and built for the App Store using the...

Mono Compilation Error in C#

To start, I copied this code from the Microsoft website: using System; namespace HelloWorld { class Hello { static void Main() { Console.WriteLine("Hello...

Problems with msqli and mssql and broken php7.2 on linux

I have a local application with laravel 5.5 using a mysql databse on my ubuntu18.04.1. It is hosted on a server with php7.2, and I had the same version of php in my system. All was working fine....