NODEFAULTLIB nightmare in VS2010 C++ project: links fine in debug, can't find a consistent set of libraries in release

Overflowers! I've been developing a statically-linked application using Visual Studio 2010 (well, it's cross-platform, but this is just a Windows issue). I had few issues setting up the linking...

SDL init failure, reason is: No available video device in ubuntu 12.04 LTS

I recently upgraded my ubuntu 10.04 LTS to ubuntu 12.04 LTS. AVD stopped working afterwards in my eclipse. ERROR message: [2012-10-03 16:16:11 - xyzapp] Android Launch! [2012-10-03 16:16:11 -...

Can't run on android emulator which build from Corona SDK

I'm trying to run a simple code like helloworld build from Corona. It runs fine on both Corona simulator and my phone(HTC Desire HD). But when I install to Android emulator with adb and run it ,...

How does CMake use pkg-config to find packages?

I'm trying to build a package which uses CMake for the building system (i.e. libebur128), which relies on pkg-config to find the required packages in the system. After building the required...

To install ia32-libs on debian wheezy amd64

I'm using Debian 7 (wheezy) amd64. uname -a Linux tzwm-debian 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux And I want to install ia32-libs in my Debian. But this happens when I try to...

install needed shared library debian

XeroxPhaser3100 MFP has only 32-bit drivers. I want to use it with CUPS on my openmediavault (NAS) based on Debian. The OS is 64bit. I install drivers like in this manual...

Make issues with oxfRPiCameraVideoGrabber on the Raspberry Pi

I'm currently working though the CreepyPortrait tutorial from Adafruit, but I'm having trouble getting the project to Make on my RaspberryPi The terminal output is below: [email protected]

Error during install of player node module with npm

I would to play some music on my nodejs script. I try to install player module with npm. But when I launch the install,they return this : [email protected] install...

unable to install wine in ubuntu14.04 and getting dependencies error

i am using ubuntu 14.04 .i am trying to install wine but getting following dependencies error . I tried sudo apt-get install wine I got this error- The following packages have unmet dependencies: ...

Cannot connect mpg123 and ao in project with cmakelists

I am using the cmakelists.txt below, that exists in the top folder of my project, and I am trying to connect mpg123 and ao to my project. In one .cpp file of the source folder I added a code with...

Why install :i386 packages?

i use xubuntu 12.04 amd64 and today i try to install wine: sudo aptitude install wine Следующие НОВЫЕ пакеты будут установлены: attr{a}...

mpg123 decode mp3 to pcm in C++

I want to decode a mp3 file to pcm: #include <iostream> #include <mpg123.h> #include <out123.h> using namespace std; int main() { mpg123_handle *mh; unsigned char *buffer; size_t...

Error while installing java in ubuntu 16.04 having Cyberoam Client installed

I'm using Ubuntu 16.04 OS and also linked my pc with Cyberoam client for the security purpose. I'm trying to install java for Android Studio in it and I'm getting following error in terminal...

Compiler error reporting is too harsh for ./configure

So, I am trying to compile a Homebrew App for CFW Nintendo 3DS. I am doing it on Linux Mint 18.2. The compiler fails to compile some required dependencies. Here is the code from the...

Broken apt dependency tree

I was upgrading Ubuntu 16.04 to 17.04, when some packaged failed to upgrade. This left the apt dependency in a broken state. I tried some other answers online, but I am afraid this only...

Can apt-get autoremove remove system files?

I tried to install Python 3 on my Ubuntu 16.04.4 LTS and while using apt i found this: The following packages were automatically installed and are no longer required: cabextract gcc-5-base:i386...

Unresolved external symbols while building SDL2_mixer using Visual C++

I am trying to build SDL2_mixer (2.0.2) using Microsoft Visual C++ in Visual Studio, it appears that I have properly configured it. But seems that the two example projects playmus and playwave...

C++ invalid conversion from ‘char*’ to ‘unsigned char*’?

I have a code for playing audio in raspberry pi. My compiler is GCC. When I compile the code, I get the error: invalid conversion from ‘char*’ to ‘unsigned char*’. The error is triggered...

SDL_Mixer 2.0.4 "MP3 support not available" even though libmpg123 is installed

I am a beginner to programming and am trying to make a simple console MP3 player as a project. For this, I need a way to play .mp3 files. SDL Mixer provides this facility but requires libmpg123...

Can't install java 8 on linux mint

Linux Mint 19.3 I need to install jdk 8. I try this: sudo apt update result: Ign:1 http://mirrors.evowise.com/linuxmint/packages tricia InRelease Hit:2...

pygame.mixer.init() gvies weird error while loading file

I am trying to play a '.mp3' file through pygame.mixer.music at a changed frequency. It was working perfectly fine in my old PC. I have recently moved the program to my new PC and gives the...

Running apt-get install within Docker container: "Unable to connect to deb.debian.org" part-way through installing dependencies

I'm trying to build a docker container on a Raspberry Pi 3B. I need to install gpac for MP4Box. Dockerfile FROM python:3.8-buster RUN apt update && apt install curl gpac -y ENV...

Discord Bot Java (Maven) Library not found, loading failed (com.sedmelluq / lavaplayer)

I programmed a Discord bot with Java (Eclipse). If I start it via console in Eclipse, it works without problems. If I export it as a "Runnable JAR file" and start it with the start.bat file, it...

Pygame mixer does not work after .py is converted to .exe

First of all i'm on windows and i'm trying to convert my python programm to an executable. My Programm is a console based music player. I'm using the pygame mixer to play my mp3 files. I converted...

Unable to set up SDL2 to run with audio (alsa) on linux ubuntu 20.04 using conan

Depending on what I do I either get "No such audio device" if I leave determining my audio device up to SDL2 or I get Failed loading libasound.a:...

Trying to play a song through pygame but get a libmpg123-0.dll error

Going to keep this short and sweet. I am trying to play a song using pygame's mixer. I have the song titles in a dictionary and are accessing the name of the stored file using this. When I choose...