Debian: dist-upgrade removes gnome and many other stuff

I am (was) running the Debian Sid and faced a major update problem few days ago. It was weekend and I was just going to upgrade stuff, did sudo apt-get update, then sudo apt-get upgrade. Then I...

Cannot Compile Kernel Headers (libc6-amd64 Dependencies)

Edit: Please read the update. I was unable to compile some programs using boost libraries and I was told it was a compiler error. I compiled GCC-5.1.0 from source and placed it in /opt/gcc-5.1.0/...

sched_setscheduler error (EPERM) after installing libpam-systemd

Just trying to set the sched priority to max with SCHED_FIFO policy. This code started throwing error after I installed libpam-systemd. EDIT: Boils down to the two questions below, put them as...

error when install tools in docker container

I install ubuntu-14.04.4-server-amd64.iso in my VirtualBox,then I use some way to get its rootfs. after that i can the rootfs to create my docker image.the Dockerfile as following: FROM...

Not able to use systemd on ubuntu docker container

Problem It seems systemd is not active or available in Ubuntu Docker containers. Setup I'm running Docker containers from the ubuntu:16.04 and ubuntu:16.10 images. Tests If I execute: systemctl...

"rsync" was not detected as installed in your guest machine

I'm trying to setup Vagrant with docker as a provider but when running vagrant up --provider=docker --debug I get this error: "rsync" was not detected as installed in your guest machine....

Phalcon extension unloaded after system upgrade

So, I am using Phalcon 3.0.0 with PHP 7 on Ubuntu 16.04.1 on DO. Everything worked correctly until today, when I ran apt update and upgrade on Ubuntu. After the process finished, Phalcon plugin...

"vagrant halt" dies with error "The SSH connection was unexpectedly closed by the remote end..." But the machine successfully shuts down. (

I have 6 VM's running Ubuntu 16.04, the host is also Ubuntu 16.04. Vagrant version 1.8.1 When I run vagrant halt, I get the error: The SSH connection was unexpectedly closed by the remote end....

Can't upgrade R because of dependency

I want to upgrade R (version 3.0.2) to a newer version like 3.4.1 but I face a complicated problem in dependency which prevent me to do this. I typed on terminal many codes using several solutions...

Errors were encountered while processing: /var/cache/apt/archives/dpkg_1.18.25_armhf.deb

Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following NEW packages will be installed: python3-cairo...

How to install pip into a ubuntu container while keeping layers to a minimum?

I'm interested in building a small container image which has pip-installed packages, but unfortunately, installing python3-pip via apt-get pulls in a lot of dependencies (348MB) into an otherwise...

Docker Build "Could not resolve hostname" behind corporate proxy

I have Docker for Windows set up, with GIT and Node.js. While trying to run a docker build with the following command: $ docker build --no-cache -t hfc_joomla . The error is visible in Step...

Error when installing packages on AWS EC2 instance

I need to install S3FS package to mount S3 storage onto EC2 instance. To do this, I executed following commands. Update [email protected]:~$ sudo apt-get update Hit:1...

Java dependency failure for .deb file on openjdk docker base

I have been working with an opensource project. Which creates docker images with build-generated debian (.deb) packages installed on the jdk8 image. But lately I started to have error and...

Dockerfile compatibility with Raspberry Pi?

I have built the image from the following Dockerfile in my Rpi Kubernetes cluster. However, I was getting status of CrashLoopBackOff for my Pods. After a bit of search on the internet, I realized...

Issue about installing libgtk-3-dev on Debian 10 arm64

I need use OpenCV3.4.1 on Debian 10 which is arm64 embedded system. When I chroot and try to install libgtk-3-dev with command: ''' apt-get install -y libgtk-3-dev ''' I get error: ... *Err:1...

How to fix the errors encountered while processing installation

I wanted to reinstall java which was accidently deleted, using this post. As mentioned in the above post on runningsudo apt install default-jre, I got this error: Reading package lists......

docker python flask gets " Do you want to continue" then "executor failed"

Trying a simple python flask web app in docker 20.10.2, build 2291f61. Doing the: docker build -t hello-world . starts out ok (please see below), but ends with: #6 2.866 After this operation, 305...

Unmet dependencies (venv & ensurepip) error when running erdpy-up

Trying to install erdpy fails with the following error: $ python3 erdpy-up.py INFO:installer:Checking user. INFO:installer:Checking Python version. INFO:installer:Python version:...