Bitnami npm install canvas

after trying every solution on Internet i am stuck with this error node-gyp rebuild make: Entering directory `/home/bitnami/SmartDoorbell/node_modules/canvas/build' SOLINK_MODULE(target)...

Error when installing Node-Canvas on Debian

i got an error when i try to install the node-canvas modul. Already checked the required packages and installed them. i've installed the following packages. > apt-get install libcairo2-dev...

Installing canvas on ubuntu

I am installing canvas on ubuntu 16.04 LTS for installing npm package qr-js. I performed these steps - 1. sudo apt-get update 2. sudo apt-get install libcairo2-dev libjpeg-dev libpango1.0-dev...

How to building training tools for tesseract3.04 on windows platform?

I am compiling the tesseract 3.04 from source on windows 8 and have compiled it successfully,not including training tool. To build training tool,I spend a lot of time to search those additional...

docker-compose build error ubuntu mango

Docker-newbie here... I'm tracking down a docker-compose build error for the pango gem. One of the checks shown in the mkmf.log file is: have_package: checking for pango version (>= 1.14.0)......

In a Dockerfile, How to update PATH environment variable?

I have a dockerfile that download and builds GTK from source, but the following line is not updating my image's environment variable: RUN PATH="/opt/gtk/bin:$PATH" RUN export PATH I...

Segmentation Fault (Core dumped) Wt With Qt helloqt

I Wrote before but the details was not explained. I explain step by step what I do; Witty installation Guide Ubuntu I did in order what ever said in this page. sudo apt-get install gcc g++...

OSX - Compiling training tools for Tesseract 4.0 - pango libraries not found

I am having trouble getting the configure script to recognise the pango libraries i have installed via Homebrew, which are dependancies for the training tools. So far, I've followed all steps...

Weasyprint issue in django app with apache

I have a app with Weasyprint to generate pdf, in local enviroment its no problem, but in a virtual machine server with apache, static folder dont work in pdf files (image and style are not show)....

How to install opencv on Ubuntu14.04?

When I want to install opencv on Ubuntu14.04, I get problem as bellow:libopencv-dev : Depends: libopencv-objdetect-dev (= 2.4.8+dfsg1-2ubuntu1) but it is not going to be installed ...

how install OCR tesseract on opencv 3.1.0 on linux ubuntu 14.10?

I would like install correctly Opencv_contrib for Text_recognition. Have you a idea to the good process? Before I install Opencv 3.1.0 and opencv_contrib, I install leptonia-1.73, protobuf,...

Gegl color-to-alpha does not remove the white color like GIMP does

Color to Alpha The color-to-alpha operation is when a color is taken from all the pixels in the image and converted to transparent, this is especially useful to extract hand written or free...

Can't install libgtk2.0-dev on linux

I am trying to compile xfce-terminal, configure will not pass saying I lack gtk2 checking for gtk+-2.0 >= 2.24.0... not found *** The required package gtk+-2.0 was not found on your system. ***...

Problem installing libpng-dev along with libpng12-dev on Raspberry Pi Zero

I am trying to install OPENALPR on my Pi Zero and I am using the instructions on https://www.reddit.com/r/raspberry_pi/comments/baxwz5/how_to_install_openalpr_on_raspberry_pi/ After I run the...

Docker image fails to build on Live but fine on Dev

I have a strange issue with Docker. This is the Dockerfile in question. FROM python:2.7 RUN apt-get update && apt-get install -y \ build-essential \ python-lxml \ python-dev...

Installing libgtk-3-dev, unmet dependencies

I'm trying to install seahorse-3.16.0. When running ./configure, I get: configure: error: Package requirements (gtk+-3.0 >= 3.4.0) were not met: No package 'gtk+-3.0' found Consider...

Install libgtk-3-dev on Ubuntu 20.04

I would like to write a GUI in cpp. As far as I know gtk is a nice solution for this. Sadly it appears to me that gtk is no longer available under Ubuntu 20.04. (I am using Xubuntu if this...

Unable to install libgtk2.0-dev on Raspberry Pi 2

I am trying to install libgtk2.0-dev on my Raspberry Pi 2 running on latest raspbian. When I use the command sudo apt-get install libgtk2.0-dev, I get the following dependency errors: Reading...

Error on installing Rattle in Ubuntu

I'm trying to install Rattle in Ubuntu 14.04, but I'm getting this error: Error in loadNamespace(name) : there is no package called ‘RGtk2’ But when I try to install RGtk2 I get this: configure:...

Unable to import pango in python2

I am following this tutorial to set up and train the Tesseract 3 OCR tool. Some of the scripts use Pango. When I run the scripts, Python fails to import Pango. ImportError: No module named...

Installing gtk2hs on ubuntu

I am trying to install gtk for Haskell on Ubuntu. I have already installed the Haskell platform. When I run cabal install gtk2hs-buildtools, I get the following error: > Resolving...

Build tools for Tesseract Training on Windows 10

On the Tesseract Github page for training, there is mentioned to install These two additional libraries. where can we find these files for Windows 10: libpango1.0-dev libcairo2-dev

How to install libgtk2-dev:i386 without removing libgtk2-dev:armhf? Or what to do to cross-compile for i386 and armhf?

I'm struggling trying to cross-compile a wxWidgets app for a BBB from a Debian 9 PC. After a lot of failures, i've found what seemed to be the solution: multiarch. So i added an armhf...

dockerfile - adding dependencies - libjpeg error

Im trying to dockerize a nodejs project that uses the chartjs-node module for creating png images from the chartjs graphs. It has some requirements that I've added to my dockerfile full docker...

unable to install Gosu library in Ruby in Linux

I am getting this error when I am trying to install gosu on Ubuntu 13.10 Fetching gem metadata from https://rubygems.org/......... Fetching version metadata from https://rubygems.org/.. Resolving...

What it means "A breaks B and and is installed" while compiling and installing apt pkg in Ubuntu?

I have an apt package that is compiled for Ubuntu 13.04 and want to install it on Ubuntu 14.04 The package in question depends on libcogl12 which is not available on Ubuntu 14.04 (replaced by...

How can I enable Pango so ImageMagick will see it under Mint?

I'm running a Linux Mint installation that has ImageMagick installed and claims that libpango1.0-0 is installed, but ImageMagick can't see Pango: $ convert -background transparent -fill black...

I am trying to install libgtk2.0-dev on ubuntu 14 but getting some error

$ sudo apt-get install libgtk2.0-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you...

Missing package `udunits2` on CentOS

I'd like to use gganimate, but it requires the package sf. I tried to install, but I get this error. configure: error: in `/tmp/RtmpEpee0m/R.INSTALL282e663ea13f/units': configure: error:...

Gnuplot - pdfcairo

I'm trying to set my terminal to pdf output, using the line gnuplot> set terminal pdfcairo enhanced but what I get is: unknown or ambiguous terminal type; So, I tried installing the...