Can't figure out which dependencies package spynner 1.11 python 2.7.2 module needs on Ubuntu 11.10

I try to install dependencies of spynner python module, but I get : $ python -c 'import spynner' Traceback (most recent call last): File "<string>", line 1, in <module> File...

how can I force launchpad build my package with g++ 4.7 or newer

I have a c++11 source code that I need to package using launchpad for ubuntu 12.04, which contains only old 4.6 gcc. I changed the control file so that it contains: Build-Depends: debhelper (>=...

Installing OpenCV on Ubuntu 12.04

I am trying to install OpenCV 2.4.2 on Ubuntu and am running into errors as below: [ 11%] Building CXX object modules/highgui/CMakeFiles/opencv_highgui.dir/src/window_gtk.cpp.o In file included...

How to make a ubuntu executable and run it in my install file

This is the install file below (sandhi-install.sh). Currently after installing it can only be run from the terminal. I want to make it terminal independent....

Installing Orange into a virtualenv

Linux Mint 17.1 with native Python 2.7.6. All pre-reqs listed in the INSTALL.txt: python-numpy libqt4-opengl-dev libqt4-dev cmake qt4-qmake python-sip-dev python-qt4 python-qt4-dev python-qwt5-qt4...

Mint17.2 install py2exe

I tried downloading the .exe files (problem: can't find a version 2.7 of python on computer + can't add the directory) I tried using the: pip install...

How to fix error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

I'm trying to install odoo on a fresh installation of Linux on a VirtualBox machine. I have entered in the commands found here as is: Odoo Development Read the Docs. The following command is what...

Where can I find the QWebPage and pymongo in python3.4?

I'm working on some code that requires a number of packages from python qt 5. I get a missing package error upon importing the QWebPage module: from PyQt5.Qt import QWebPage,...

CentOS 7 install Octave 4.0.2 with GUI (OpenGL support)

I'm trying to install Octave 4 from source code in CentOS 7 but I got the warning messages: configure: WARNING: OpenGL libs (GL and GLU) not found. Native graphics will be disabled. configure:...

Unmet dependencies? Broken packages held?

I am trying to get a vpn up and running and am doing so through the shrew soft client. When I go to run the command: sudo apt-get install libqt4-core libqt4-dev libqt4-gui qt4-dev-tools I get...

TA-Lib Install Error

I am trying to install TA-Lib on Debian Jessie using pip. However I am encountering the following error: #include "ta-lib/ta_defs.h" ^ compilation terminated. error:...

Installing Scrapy throws exceptions again and again

I've tried to install Scrapy the usual way: Python 2, pip, pip install Scrapy I read that Python3, Windows10 and 64bit are not so good for Scrapy so I've installed 32bit Ubuntu to Oracle...

Docker file for building code cloned from git

I've cloned a copy of FreeCAD from github and I'm trying to create a docker file so that I can develop it locally on my machine. The objectives being that: I have a local copy of the code from...

Run Omnet++ inside docker with x11 forwarding on windows. SSH not working

Cannot ssh into container running on Windows hostmachine For a university project i build a docker image containing Omnet++ to provide a consistent development environment. The Image uses...

Error while installing sentry on server python

I looked up all over the google, installed many packages. sudo apt-get install build-essential autoconf libtool pkg-config python-opengl python-imaging python-pyrex python-pyside.qtopengl...

Installing/compiling OpenFOAM on a server without admin privileges

I'm trying to install/compile OpenFOAM on a remote server. As I don't have the admin privileges I have to compile it from scratch. Following the instructions here, when I try to run source...

Installing tsne in Google Colab notebook: error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

I am trying to install the tsne library in a Google Colab notebook. Based on other questions, I have tried installing the following to no avail: !apt-get install libblas-dev libatlas-base-dev...

Installing PyQT5 on Ubuntu16.04

I am trying to install python-pyqt5 in my PC with Ubuntu16.04. When I install like sudo apt install python-pyqt5 The system said, it is already installed. Reading package lists... Done Building...

Rails & Docker: configure bundler to run bundle install in a docker build for Rails.4.2.6?

I am having so much trouble with docker. It seems to be a pattern. I have a dockerfile which installs Node.js and Yarn from source repositories fine. I install ruby from the get-apt repositories...

Apache Airflow : airflow initdb results in "ImportError: No module named json"

On Ubuntu 16.04 with Python 2.7 default version, I am trying to install Apache airflow but ran into several issues and currently I see on apache initdb Traceback (most recent call last): File...

Running simple Qt GUI application in Go

I am trying to modify following simple code from here to use Qt in Go. #include <qapplication.h> #include <qpushbutton.h> int main( int argc, char **argv ) { QApplication a( argc, argv ); ...

How to install Qt4 and Qt5 alongside each other Ubuntu 1804

I have some software packages that depend on qt4. I installed Qt 4 just for those packages with the command sudo apt install qt4-default. I want to install qt5-default, but when I run the command...