Rails3 and readline problem

I'm using rails3 for the first time (i've been using rails2 for years) inside an rvm. Trying to start the console, i get this error: require': no such file to load -- readline I've googled around...

How do you create a loadable kernel module for Android?

I know there a number of walkthroughs and tutorials floating around out there which describe this activity, but after having read many of them I still can't get this working. If anyone has the...

Installing Rails 3.0.9 on Ubuntu 10.10 with RVM - no rails command in path

This seems similar to a number of other questions posted, but is actually a different problem and with different (newer) versions (hence, the new question). On a moderately fresh installation of...

rvm install ree complaining about readline on Ubuntu

I'm trying to install ree-1.8.7 on Ubuntu 11.10, but I get the following: $ rvm install ree-1.8.7 $ ... $ ERROR: Error running './installer -a $HOME/.rvm/rubies/ree-1.8.7-2011.03 ...

How to get Readline support in IRB using RVM on Ubuntu 11.10

I have tried everything I can think of to get this to work, to no avail so here I am requesting suggestions on how to debug. Firstly, runnning Ubuntu 11.10 Installed rvm: $ bash < <(curl -s...

can't get "rails console" to work on ubuntu 11.10

I want to use rails console and I'm using ubuntun 11.10 currently I have found the issue error is something : completion.rb:9:in `require': no such file to load -- readline (LoadError) and I...

Readline not working in rvm - Ubuntu 11.10

I am using rvm on my ubyntu 11.10. My readline is not working, I tried ruby extconf.rb but it is not passed. Output is bellow: $ ruby extconf.rb checking for tgetnum() in -lncurses......

No such file to load -- ftools (LoadError)

Yes, the thing is that I got a really really legacy software, which I need to use it on Ubuntu 10.10 and it requires the use of ruby 1.6.8 and gcc 3.4. I already install gcc 3.4 and verify the gcc...

Ruby - cant load bundler

I installed bundler with rvm gem install bundler. What is wrong here??? Also did reinstall with these option - apt-get install libncurses5-dev libreadline5-dev libreadline-dev librequire-dev rvm...

Ruby on Rails and SSL error

I formatted my computer and transferred all my RoR applications to my new Lubuntu System. I had Ubuntu with Unity. (still a linux system). I have installed rvm, ruby, rails, and they all work...

Python 3.2 installation on Ubuntu 12.04

I am trying to install python 3.2.3 on my ubuntu machine, which is 12.04, but I do not want to disturb the current 2.7 installation. After searching on the internet, I found a reference here. I...

SDL init failure, reason is: No available video device in ubuntu 12.04 LTS

I recently upgraded my ubuntu 10.04 LTS to ubuntu 12.04 LTS. AVD stopped working afterwards in my eclipse. ERROR message: [2012-10-03 16:16:11 - xyzapp] Android Launch! [2012-10-03 16:16:11 -...

Installing Heroku Toolbelt on Ubuntu through a proxy

I'm trying to install the Heroku Toolbelt on an Ubuntu machine that's connected to the internet through a proxy. I'm pretty new to Ubuntu and its settings but I managed to get connected to the...

libreadline5-dev has no candidate in the apt-cache

I'm trying to do this in chef: package("libreadline5-dev") do package_name "libreadline5-dev" retry_delay 2 retries 0 recipe_name "default" cookbook_name :"nginx-passenger" action...

Installed rubygems1.9.1 but it reports version 1.3.5

I installed rubygems1.9.1 on a pretty clean Lucid VM. $ sudo apt-get install rubygems1.9.1 ... The following extra packages will be installed: irb1.9.1 libreadline-ruby1.9.1 libreadline5...

Ruby installation issue on Centos6

# yum install libreadline5-dev libncurses5-dev Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: sg2plmirror01.shr.prod.sin2.secureserver.net * extras:...

How to install RHadoop on Ubuntu Natty 11.04 machine?

I need to install RHadoop on my ubuntu natty 11.04 machine. I tried doing these commands "apt-get install r-base" but i am getting unmet dependencies [email protected]:/home/rhadoop/dependency#...

Python 2.7.4 on Ubuntu 10.04, Import readline error(Tried many ways never work)

As in the title, my system version is Ubuntu 10.04. The default version of Python is 2.6.5. When I start python2.6 in command line and import readline This works well. Then I compile the python...

ruby compile with fPIC

I'm using ruby 1.9.3p392 through rbenv under Debian 7 and I'm trying to install the qtbindings gem so I can run an old ruby app which uses qt libs. Here is the error I get when typing 'gem install...

--force-yes required to install heroku toolbelt?

I've installed heroku toolbelt on many different platforms to date, and was surprised to find myself having trouble doing it on ubuntu 12.04. Some of the issues I encountered are explained, I...

Mariadb-10.0 install fails in boot2docker with "policy-rc.d denied execution" but works in Docker

I'm trying to setup a Vagrant + Docker based development environment on OS X 10.9. The first step is to create a container for MariaDB 10. However, for some reason, the Docker image won't build in...

Errors while installing Qtbindings on Ubuntu 14.04

I'm trying to install Qtbindings (for Ruby) on Ubuntu, but each try I have the same errors... I don't understand why. Here the result : /usr/bin/ld:...

Building PostgreSQL from source on Windows

I'm trying to build PosgreSQL in Eclipse CDT Mars on Windows using the MinGW-64 gcc 5.3.0 I installed MSYS2 and used pacman to update all the software that came with it and install gcc etc. I...

What are the prerequisites for ruby-qml?

I am trying to install ruby-qml on Ubuntu 15.10 (Wily). Apparently some prerequisites are missing: :#> gem install qml Building native extensions. This could take a while... ERROR: Error...

Installing ruby-qml - ERROR: Failed to build libqmlbind - What is missing?

I am trying to install ruby-qml on Ubuntu 15.10 (Wily). I had previously checked for prerequisites. There is nothing documented for Linux on the web site. I had checked some usual suspects...

Scylla 1.4 could not setup on Ubuntu 16.04

I trying to setup ScyllaDB on my Ubuntu 16.04 system. But I encounter the following error: [email protected]:~$ sudo scylla_setup sudo: /etc/sudoers.d is world writable [sudo] password for aims: Skip any...

Error (mysql) during software update ubuntu 16

I have over 100 packets to update. When I start updating and then I get an error mysql-common subprocess installed post-installation script returned error exit status 2 So, I try to uninstall...

Heroku Python3.5 Import Error : No module named ='_tkinter'

While deploying in Heroku and adding customized buildpacks such as libspatialindex, another error occurred where Python 3.5 now looks for Tkinter. Locally, by installing using sudo apt-get tk-dev...

Cant download MySQL software on Raspberry Pi

I run the command below, I have tried sudo apt-get update, --fix flag and rebooting. I have checked my internet connection as well, any help would be appreciated. Command issued: [email protected]:~...

systemd[1]: Failed to start MySQL Community Server while installing mysql-server

When I try to reinstall mysql it gives me the following error: sudo apt-get install mysql-server Leyendo lista de paquetes... Hecho Creando árbol de dependencias Leyendo la información de...