Imagick SVG cannot load the image

I am getting the trouble about converting the SVG to image by PHP Imagick library. Here is my code: $svg = '<?xml version="1.0" encoding="UTF-8" standalone="no"?> <svg style="overflow: hidden;...

Ubuntu 12.10 - Ruby gem rmagick missing dependency issue

Like many others I'm having trouble installing rmagick on Ubuntu when running bundle install. I get this error on the bundle install command: Installing rmagick (2.13.1)...

Can't install rmagick gem on Ubuntu 13.04

When I try to install rmagic with: gem install rmagic it gives error: Building native extensions. This could take a while... ERROR: Error installing rmagick: ERROR: Failed to build gem native...

SVG to CDR converter

I have an SVG file which contains rotated, semi-transparent, clipped (clip-path) elements (e.g polygons, images). This file is perfectly working in Inkscape but for further image processing I...

Rpm Build: Bad exit status from /var/tmp/rpm-tmp.hI2V3W (%install)

I'm trying to "rpm-build -ba" a package (Pike) for Fedora Linux, and it's the first time I'm doing this procedure, but I keep getting this error: "Bad exit status from /var/tmp/rpm-tmp.hI2V3W...

mistakenly installed ImageMagick on Debian - how to remove it?

I went to install imagick PECL extension on debian. I mistakenly installed ImageMagick with 75 MB unnecessary dependencies. Could someone please help me and tell me the simplest way to remove it...

Convert SVG to PNG with CSS3 matrix3d transformation support

I need to convert SVGs to PNGs from a Python script. There are plenty of tools for this, the ones I tried (I'm on Ubuntu): inkscape (Inkscape command line) rsvg-convert from librsvg2-bin convert...

Why does building from a docker file take up all the disk space?

I am using docker-compose to build and run my application. here is the docker-compose.yml: db: image: postgres web: build: . command: sh startup.sh volumes: - .:/code ports: -...

Ubuntu / DigitalOcean - Unable to fetch packages to install git on a fresh install

Just started with a fresh install of Ubuntu 14.04 on my digitalocean droplet and I'm trying to install git. My first attempt failed to install some packages - [email protected]:~# sudo apt-get install...

configure settings for Installing Octave 4.0.3 in Ubuntu 16.04

So i am following steps to install the latest version of octave from here. sudo apt-get install g++ gcc gfortran make autoconf automake bison flex gperf gzip icoutils librsvg2-bin libtool perl...

Building Valama IDE on Windows using MSYS2 and MingW

I am using MSYS2 to build Valama [the next generation IDE for Vala]. what the GitHub repository says that some dependencies are required. and they are provided for Ubuntu using this command sudo...

How to fix broken apt-get on debian wheezy?

I'm using a debian wheezy at work. Packages are held in specific versions. My /etc/apt/sources.list contains lines like : deb http://mycompany.com/debian/debian-main/ wheezy main non-free...

/dev/null doesn't seem to work on travis CI

I am running some automated test in Travis CI and I am having trouble in running two parrelel comands so basically before testing we should run main flask app by executing python app/main.py and...

extract raster and vector images from pdf with a bash script

I needed a bash script which extracts all the raster and vector images from the pdf and convert them to jpg format. I checked many posts on the web and I got most of the ideas from these How can I...

Dockerizing kafka gives non zero exit code

I am a newbie trying to learn docker. I am trying to dockerize kafka installation and stuck with a non zero exit code. I would like to debug the issue and find out the reason. How to debug a...

Error while installing postgresql

I've never used postgres, only MySQL, so it's new for me. I'm trying to installing it on a VM(so I can use only command line). Running the command sudo apt-get install postgresql this is my...

Sublime Text 3 installation with GTK library fails on AWS Ubuntu 16.04.03 instance

I tried to install Sublime Text 3 on an AWS Ubuntu 16.04.3 LTS instance according to the instructions provided by the link: Install Sublime Text 3 in Ubuntu 16.04 & Higher The Official Way. After...

Make .deb for JDK8 with JavaPackage

I'm trying to install JDK8 on Debian Stretch. The recommended way is to use JavaPackage. I have successfully packaged JDK6 and JDK7 using this method: Download the JDK archive from...

Open files from Linux bash shell on Windows 10

Using Windows 10 and I have the Linux Bash Shell to use with Jekyll. All I am looking to do is open the explorer or filesystem to copy some files. Does anyone know how you browse the file explorer...

Converting SVG to another format fail due to delegate not being found

I have PHP code running on Debian stretch with ImageMagick. It tries to convert SVG to another format. Here is how it starts $im = new Imagick(); $im->readImageBlob($svg); The variable $svg...

Nodejs installing node-canvas on ubuntu not working. Error: "internal/modules/cjs/loader.js:1122 "

I tried to install nodejs canvas on my ubuntu 18.04.5 vm. I am using nodejs v14.16.0 installed using the snap package manager. Following the instructions on the GitHub wiki from...