Ruby nubie on OSX - can't get beyond rake db:migrate - get [BUG] Bus Error

Original problem: I'm (a newbie to ruby) using RVM to manage my ruby on Mac OSX 10.6 Here's my mac OX info: $ rvm info [email protected]: system: uname: "Darwin...

WARNING: Nokogiri was built against LibXML version 2.7.7, but has dynamically loaded 2.6.16

I can’t work out why I’m getting this error from Nokogiri when I start up Rails. From the little I know, it seems like something else is causing an older version of libxml2 to be loaded, which...

Can't install Ruby under Lion with RVM – GCC issues

Most questions regarding this problem are due to missing Xcode; I have Xcode 4.2 installed. Install attempt: rvm install 1.9.3 Installing Ruby from source to:...

libruby.so.1.8: cannot open shared object file: No such file or directory

I am getting the below error while starting server of my project. I am trying to resolve since yesterday but was not able to solve it. somebody pls help me. => Booting WEBrick => Rails 2.3.14...

The compiler failed to generate an executable file. (RuntimeError)

I recently upgraded to OS Mountain Lion. A project I'm working on requires gem sys-proctable as a dependency, but when I run bundle install I get: Fetching gem metadata from...

PostgreSQL - Rails Server Crashing on Start "Library not loaded...(LoadError)"

I am setting up a Rails Project. Each time I go to start the server, I am getting a big error; rails server puma warning: ignoring extraneous `ruby-' prefix in version `ruby-2.0.0-p247' ...

Rails Nginx Passenger Cannot checkout session because a spawning error occurred

I have a Rails 3.2.14 app that deploys and operates fine on a production server. I'm working on deploying it to another server to test changes before I push out to production. I'm running the...

Rails server on Mac crashing

Background: I had rails working back when Mavericks was on the system. I have since updated to Yosemite so I assume something was broken. It now crashes. But I'm a ruby/rails n00b so...? EDIT: 2...

Setup RVM, Ruby on Mac OS X Sierra: Unable to require openssl

I've hit the problem of setup of RVM + Rubies on a new Mac laptop where after getting RVM installed plus Homebrew the install for Rails hits the error: ERROR: While executing gem ......

Could not find public_suffix-2.0.4 in any of the sources

It started when I tried to add the Google Tag Manager Gem to my local installation of Jekyll. A little background here, I'm using homebrew and rbenv. My ruby version is 2.4.1 or at least I think...

vim ruby mismatch on Mac High Sierra

I recently upgraded my Mac to High Sierra After the upgrade, Macvim (mvim) stopped working because (I assume) HighSierra upgraded ruby to 2.3, and mvim is using ruby 2.0. Following is the error I...

Ruby 99% ++ CPU Usage on Mac

I have a problem in running Ruby in my Mac machine. I've been google for a while but not found satisfying answer, so i decided to ask myself. I run some simple ruby code using Visual Studio Code...

Error running '__rvm_make -j 1'

Today I was trying to install ruby 2.5.0, but I am getting this error every time. console output with the error I got rvm install ruby-2.5.0 Searching for binary rubies, this might take some...

Error running '__rvm_make -j8' when trying to install Ruby using RVM

I am trying to use RVM to install Ruby. I have been following the Installfest guide over at RailsBridge. So far, I have installed RVM (curl -L get.rvm.io | bash -s stable) and configured RVM to...

VIM can't be used after system upgrade to ubuntu18.04

I upgraded my system from ubuntu16.04 to ubuntu18.04,once I updated my system,I fond that my VIM could not be used.Whenever I use my VIM,the following mistakes will occur. $ vim test.cpp vim:...

Unable to install any Ruby with RVM on MacOS 10.14.2 Mojave: Error running '__rvm_make -j4'

After upgrading MacOS to 10.14.2 Mojave, I'm not able to install any Ruby Version with RVM anymore. It always gives an error like this: $rvm install 2.5.3 ruby-2.5.3 - #removing...

Rails: cannot open shared object file: No such file or directory

Rails: 5 Ruby: 2.5.3 Gem: gem "ruby_mapscript" Error: /home/usermachine/.rvm/gems/ruby-2.5.3/gems/ruby_mapscript-0.3.0/lib/mapscript/mapscript_extensions.rb:3:in require: libruby-2.0.so.2.0:...

Cannot install any version of ruby on Mojave - internal ranlib command failed

I know there are a few silimar issues to this one, but I cannot find one that matches my issue. I cannot install any version of ruby with either rvm nor rbenv. Both result in the same error. For...

rbenv install 2.6.1 FAILED on Mac OS Mojave 10.14.3

PROBLEM I am trying to download ruby 2.6.1 on Mac OS Mojave 10.14.3 but I keep getting failed builds and I'm not sure what the error is. Please help! Completely lost :( Current setup: . > rbenv...

Unable to run rails server

When I am trying to run my rails server using the following command: rails s It throws the following error: /Users/babaloo/.rvm/gems/ruby-2.5.1/gems/airbrake-ruby- ...

Error: pathname contains null byte on running Vim on newly upgraded macOS Mojave

I recently upgraded to macOS Mojave 10.14.1 and when using the native Terminal or iTerm, the vim command appeared to be broken. The error will look like dudeOnMac:~ freddy$ vim file dyld: Library...

Bundler using wrong Ruby version

When I try to start my Rails server, I get the following error: $ bundle exec rails s Your Ruby version is 2.3.7, but your Gemfile specified ~> 2.3.8 I don't understand why that happens though,...

ld: library not found for -l-lruby.1.9.1 while bundle install

I am doing a bundle install operation. Facing issue when installing mysql gem ld: library not found for -l-lruby.1.9.1 clang: error: linker command failed with exit code 1 (use -v to see...

Getting BUILD FAILED when trying to install Ruby via rbenv on Mac OS X 10.14.5

I'm trying to install Ruby using rbenv but it keeps ending up with a BUILD FAILED message. I've tried reinstalling Xcode, rbenv, and homebrew without any success. I'm running: rbenv install...

2241 illegal hardware instruction rails s

Here's the problem: Unable to start an existing Rails project after upgrading to MacOS 10.15.1. The terminal shows this (below) after Rails s and going to localhost:3000. SEGV received in SEGV...

docker-compose up fails: "no such file or directory" but the file exists

I am trying to dockerize an existing ruby on rails application. I have been able to get through the build process, and build without any errors. However, when I try and docker-compose up I am...

How to fix on macOS Vim powerline error after removing Ruby

I removed Ruby on my Mac using: brew remove -f ruby brew cleanup Homebrew displayed a message that "Vim has a Ruby dependency, do I still want to remove Ruby (y/N)", and I chose "y" and Ruby was...

Can't install Ruby 2.0.0 through RVM

I have inherited a legacy codebase that requires Ruby 2.0.0 to be installed with RVM. I am on Mac OS X Catalina, and the installer for Ruby 2.0.0 simply doesn't work. Here is what my installation...

rvm install 2.6.6. on mac os 11.1 Error running '__rvm_make -j4'

I'm trying to install ruby version 2.6.6 so that I can put my rails project on Heroku, the project was built with 2.6.5 so I don't think it should be a big difference. When I run rvm install 2.6.6...

Still error trying to run libtorch helloworld pod install on apple silicon m1

When trying to create the cocoapod for ios pytorch helloworld on my mac mini m1 (big sur 11.2.1) with installed miniconda3, homebrew 3.1.1, ruby 3.0.1.p64, gem 3.2.15, pod 1.10.1 and PATH set to...