Compile PHP into Static Binary

I need to run a php script on a system with a somewhat broken PHP install. Rather than trying to workaround the issues I want to just package my code with it's own PHP binary (I can execute an...

OS X: dylib rpath wrong after compiling

I'm building cyrus sasl2 libraries from source. The libs get installed in /usr/local/lib, and the headers in /usr/local/include/sasl, which is proper. However, when I run apps that try to use...

Install pip in docker

I'm not able to install pip in Docker. Here's my Dockerfile: FROM ubuntu:14.04 # Install dependencies RUN apt-get update -y RUN apt-get install -y git curl apache2 php5 libapache2-mod-php5...

docker - using python image, add the non-free Debian repo?

Im using a python image in docker and have added some dependencies as per the below: RUN apt-get update -y \ && apt-get install -y apt-utils libsasl2-dev python3-dev libldap2-dev libssl-dev...

docker compose Django nginx

I've been following a tutorial for Django and docker using nginx here http://ruddra.com/2016/08/14/docker-django-nginx-postgres/. but I have another VM with an exposed port of 8000 so I changed it...

error while loading shared libraries: libFoundation.so: cannot open shared object file: No such file or directory

I'm on a new installed Ubuntu 18.04 machine, installed clang and llvm via apt-get and installed/downloaded Swift from swift.org test.swift file: import Foundation let s: String = ":)" let d: Date...

Error: unrecognized command line option ‘-Wno-invalid-source-encoding’ [-Werror] within building Mesos

My operating system is Ubuntu 18.10. I follow these steps on three nodes: To install Mesos I did these steps one by one without any errors, except every node has already had Open JDK 8, so I did...

Installing python-ldap fails with lber.h file not found in ubuntu 17.10 even after installing devel packages

I am trying to install python-ldap package using pip. I am getting the below error while executing pip install python-ldap. I tried installing the package corresponding to ubuntu 17.10 ( Artful )...

ldap3 'unable to open socket' when used in a docker container

I have some code that connects to my companies ldap server as such: s = Server("ldap-server", use_ssl=True, get_info=ALL) c = Connection(s, user="uid=login,ou=xx,dc=xx,dc=xx ,dc=xx,dc=xx",...

CVAT(Computer Vision Annotation Tool) installation issue

I'm trying to install CVAT and I'm following this installation guide: https://github.com/opencv/cvat/blob/develop/cvat/apps/documentation/installation.md#windows-10 I installed Docker and Git as...

Superset - Hive Connection Issue

I can connect to HIVE using sqlalchemy without any issues : [email protected]:~$ python Python 2.7.15+ (default, Jul 9 2019, 16:51:35) [GCC 7.4.0] on linux2 Type "help", "copyright", "credits" or...

Mounting Azure Blob Storage in Docker File

I am creating a dockerfile in Azure Devops and is trying to mount Azure Blob Storage Container (which contains files) into the dockerfile. I understand that there is help on microsoft regarding...

how to use pyhive in lambda function?

I've wrote a function that is using pyhive to read from Hive. Running it locally it works fine. However when trying to use lambda function I got the error: "Could not start SASL: b'Error in...

Error connecting to sql server with docker, rbase, and RODBC

I'm trying to access a SQL Server on a local intranet with R, where R is loaded in a docker file with R-base. On my desktop, I create a ODBC driver and it recognizes my windows credentials with...

R installation in Docker gets stuck in Geographic area

I am installing R in docker using the following statement. RUN apt-get update \ && apt-get install -y --no-install-recommends \ littler \ r-cran-littler \ r-base \ r-base-dev...

Trying to create a custom Docker image but getting asked for question during a RUN step

I'm trying to create a custom Docker image and during one of the RUN steps I'm getting asked to select some 'menu' choice .. which hangs/stops the image from continuing/getting made. Here's the...

how to install mongodb-c driver in ubuntu and use in coturn server

i am using coturn and i want to use mongodb as a database when i run the turnserver it shows SQLite supported, default database location is /var/lib/turn/turndb 0: Redis supported 0: PostgreSQL...

Airflow Unittest.cfg permission problems?

So, I'm setting up Airflow on EKS. Everything seems to be in place, except that I cant use the KubernetesExecutor. Everytime I try to use it, I get this error: with open(TEST_CONFIG_FILE, 'w') as...

Docker container not running (odoo with docker)

I'm trying to run odoo as SAAS service using docker .I created Odoo image successfully but when i run the image to build a container it is stopped on starting odoo stage , here is sample output of...

Failed to read dockerfile in Visual Studio Code

I need to create a Docker image from command line but its results in error when i do: docker build -t airflow-basic . failed to solve with frontend dockerfile.v0: failed to read dockerfile: open...

docker cannot find libraries that are there

I am facing a strange issue. I have a dockerfile for a executable I have created. Obviously it runs perfectly outside the docker. My docker file has several lines like: COPY libaws-cpp-sdk-s3.so...

Airflow Openshift installation with Dockerfile

I tried to install the Airflow via my own image at a public dockerhub, but it works perfect locally, but when I tried to use it on Openshift. I got this error bellow. `ERROR: Could not install...

docker python flask gets " Do you want to continue" then "executor failed"

Trying a simple python flask web app in docker 20.10.2, build 2291f61. Doing the: docker build -t hello-world . starts out ok (please see below), but ends with: #6 2.866 After this operation, 305...

Installing Mesos on ubuntu 20.04 causing makefile issue

I was trying to install mesos latest version(1.9.0) on the ubuntu 20.04 using Dockefile. FROM ubuntu:20.04 ENV MESOS_VERSION 1.9.0 ENV MESOS_ARTIFACT_FILENAME mesos-${MESOS_VERSION}.tar.gz #...

Unable to install sasl on MAC

In order to connect to Hive data warehouse from python. Using pyhive requires sasl - ModuleNotFoundError: No module named 'sasl' Installing sasl fails with errors below Python 3.9.4 installed...

Error: package or namespace load failed for ‘sf’

I am trying to install the package sf, but no success. Firstly, I thought the issue was related to the libraries GDAL, GEOS and PROJ, but all of them are installed and recognized by the...

Showing multiple errors while upgrading php-5.6 to 7.3 in centOS 6.9 (Final)

I'm trying to upgrade my php version 5.6 to 7.3 on centOS 6.9. I follow this. Everything works fine but i'm getting package errors while running following command- sudo yum install php php-common...

Copy poetry virtual env from slim-image to alpine-image and run

I would like to build packages in slim image and then copy built packages to alpine one. For that I created Dockerfile: FROM python:3.8.7-slim AS builder ENV...

How to resolve missing dependencies in Docker Alpine

I have Django application that works just fine when I build my docker image using python:3.10.0rc2-buster or python:3.10.0rc2-slim-buster without any problem. In order to decrease the image size,...

Airflow set python library versions to improve build speed

It used to take ~5 minutes for our Airflow deployment's docker image to build, and all of a sudden it is taking over an hour. With that said we haven't had to rebuild our image in a few months, so...