jvm crash after system upgrade

We have a tomcat application that started crashing every 10-15 minutes after we upgraded the OS ("aptitude dist-upgrade" of the system, which is a 32-bit Debian Lenny). java didn't get...

Unexpected segfault in memcmp

The following simple program segfaults for me: #include <string.h> int main() { void* voidp = NULL; char zeroes[sizeof(void*)]; memset(zeroes, 0, sizeof(void*)); int res =...

Hadoop (1.0.1) compile error with libssl

For some reason, I need to compile Hadoop with the follow command: $ ant compile -Dcompile.c++=true -Dlibhdfs=true Then it ended up with following info: [exec] checking for HMAC_Init in -lssl......

How can I be sure that libssl-dev includes headers from libssl 0.9.8 instead of libssl 1.0?

I'm migrating a development environment from Ubuntu 10.04 to Ubuntu 12.04. An issue is that lib openssl has been upgraded from version 0.9.8 to 1.xxx. I got a lot of useful tips from other...

Phusion Passenger Nginx module installer v3.0.17 issue on Debian 6.0.5 amd64 due to broken package

I tried default Passenger Nginx installation steps, but it couldn't succeed, I am newbie to linux and ruby on rails , so guys please help me if i am doing wrong or something is wrong, upto my...

Lazarus Indy SSL IdHTTP

I'm trying to get Indy to work with SSL and the IdHTTP component in Lazarus installed on Ubuntu 11. I know my code is right for the http post since if I remove the https and leave it as only http...

Undefine references on Ubuntu 12.04.1 LTS libssl libcrypto

I have got a series of errors I have added -l ssl and -l crypto. However I do not know which version library I need to install /usr/include/boost/asio/ssl/detail/openssl_init.hpp:48: undefined...

Riak node no longer working after changing IP address

I'm using an instanced Amazon EC2 virtual Ubuntu 12.04 server as my single Riak node. I've gone through all the proper stages of setting up Riak on the instance using the guide on the basho...

How to upgrade libssl0.9.8 to install php5-fpm

I need to setup php on server where ROR and nginx are already configured . When I am installing php5-fpm then there are one package libssl0.9.8 version dependency. I have searched a lot and tried...

Install libssl0.9.8 package

I need to install libssl0.9.8 package on my 64 bit centos 6.3 machine.I tried doing this by using this command: sudo yum install libssl0.9.8. I am getting the following error: No package...

installing libssl0.9.8 on debian 7

I'm trying to install uTorrent on debian 7 but every time I tried to run it got this error message : error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such...

Opscenter 3.2.x not working on Debian 7

After upgrading to Debian7, opscenter refuses to start with the following error: 2013-08-12 10:09:05+0200 [] INFO: Log opened. 2013-08-12 10:09:05+0200 [] INFO: twistd 10.2.0 (/usr/bin/python2.7...

C++ project fails to build due to incompatible static library

I'm trying to build a c++ project on Ubuntu 12.04 64-bit. the project is 32-bit. At the terminal output I receive such lines: ibcrypto.a(bio_b64.o)' is incompatible with i386...

Open SSL programming in C

I am trying to write a program in C, where a HTTPS client which connects to a remote SSL server, sends an encrypted HTTP request and prints out the server's response (the web page). I was...

Depends: libssl0.9.8 (>= 0.9.8m-1) but it is not installable

I'm trying to install nginx (Debian 7, amd64): apt-get install nginx But I get an error: nginx : Depends: libssl0.9.8 (>= 0.9.8m-1) but it is not installable I downloaded the deb and install...

Sudden SSL certificate failure with PHP/curl

Out of the blue, a single XML curl call in a php script stopped working complaining of a certificate problem: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL...

libcrypto.so.10: cannot open shared object file: No such file or directory

I am trying to install ODBC driver for Debian arrording to these instructions: https://blog.afoolishmanifesto.com/posts/install-and-configure-the-ms-odbc-driver-on-debian/ However trying to...

Error Loading extension section usr_cert

I am running openvpn on an Ubuntu 14.04 box. The setup was fine until an OpenSSL upgrade, then when I try to create new client cert with easy-rsa, I got this message: [email protected]:easy-rsa# ./pkitool...

MonoDevelop and libpjsipDll.so library on Ubuntu. System.DllNotFoundException

i am trying to use a dll for Linux called: libpjsipDll_v44.so I got it from here http://code.google.com/p/sipeksdk/downloads/list It's a port for Linux of the http://www.pjsip.org/ is a VOIP...

Ubuntu 15.10 lib ssl issue

I was using NCL 6.3.0 version successfully, however recently i updated my Ubuntu to version 15.10 from 15.01 and my NCL run gives and error as following. "ncl: error while loading shared...

Installing shiny server on Debian VM

I was trying to host shiny app on an offline Debian VM. So, first, I install R-version 3.1.1 with apt-get on the VM: $ sudo apt-get update $ sudo apt-get install r-base $ sudo apt-get install...

Shiny server - This package is uninstallable?

I use the command lines below to install: $ sudo apt-get install r-base $ sudo su - \ -c "R -e \"install.packages('shiny', repos='https://cran.rstudio.com/')\"" $ sudo apt-get install...

Error: incomplete type when using HMAC_CTX in C++ project

I am trying to compile this library ndn-cxx in my laptop. I already tried in another computer and it compiled successfully but now i am getting this error and i think its related somhow to...

Perl 6 Cro's stub doesn't run: HTTP/2 is requested, but ALPN is not supported

I created a stub service with Perl 6's cro but it errors out because "ALPN is not supported". $ cro stub http ds4 ds4 Stubbing a HTTP Service 'ds4' in 'ds4'... First, please provide a little more...