Error occurred while installing openstack after setting FORCE=yes

I tried installing openstack through devstack using the following commands $ git clone https://github.com/openstack-dev/devstack.git -b stable/havana devstack/ i followed this link to do it. In...

gcc g++ 4.7 install on suse never found the "rpmlib(PayloadIsLzma)

I found the rpm by google http://rpm.pbone.net/index.php3/stat/4/idpl/20369594/dir/opensuse_12.x/com/gcc47-c++-4.7.2_20130108-2.1.6.x86_64.rpm.html # wget...

pbuilder not building correctly

This is my first time packaging a debian package so i might be doing something wrong but I've followed the guidelines and after running "pbuilder create" it goes through the process of...

Install opencv AWS instance

I am using a reserved instance in AWS ec2 and am trying to install opencv on it. When I tried, sudo apt-get build-essential I got the following output Do you want to continue? [Y/n] y ...

Debian: dist-upgrade removes gnome and many other stuff

I am (was) running the Debian Sid and faced a major update problem few days ago. It was weekend and I was just going to upgrade stuff, did sudo apt-get update, then sudo apt-get upgrade. Then I...

Docker build Input/Output error

I am quite new to docker, so I am sure i have made some silly mistake. I am trying to use docker to set up an environment with my required libraries and dependencies installed for c++. However, I...

Packer/Amazon EBS/Ubuntu - Inconsistent PPAs

TL;DR; Packer is inconsistently ignoring the AWS Ubuntu PPAs, which is breaking my builds. Why? I have a job in Jenkins that uses Packer's Amazon EBS builder to create an AMI, based on the...

Vagrant plugin load order

I am behind corporate proxy which is using self-sign certificate to intercept ssl trafic. So I have installed vagrant-ca-certificates to have certificate in vm. I am also using vagrant-omnibus to...

Can't run vagrant up

Ok this is pretty simple: I'm on windows 10. I just downloaded Vagrant v1.8.0 and Virtualbox 5.0.12. All i did i just: vagrant init so my VagrantFile only contains this : Vagrant.configure(2) do...

How to use puppet APT module to install varnish server

I am trying to implement the latest version of varnish server using Puppet with APT module, however, I am getting some errors. I need to use "--force-yes". How do I go about doing that. Can anyone...

Install pip in docker

I'm not able to install pip in Docker. Here's my Dockerfile: FROM ubuntu:14.04 # Install dependencies RUN apt-get update -y RUN apt-get install -y git curl apache2 php5 libapache2-mod-php5...

How to install libc++ on Ubuntu 12.04 (precise) in Travis?

In the Travis Ubuntu-precise apt whitelist there is the package libc++-dev listed, which I try to install via # .travis.yml addons: apt: sources: - ubuntu-toolchain-r-test -...

Net::HTTPServerException causing Chef to fail

I'm attempting to set up a Rails environment with Vagrant and Chef by following this guide. I've used it in the past with success. When I run vagrant up it fails, and (I think) this is the...

cannot fetch libraries for "Unable to run mksdcard SDK tool" error on Ubuntuo 14.04

Installing android studio gives "Unable to run mksdcard SDK tool" error Then I run: sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6 Then: Reading package lists......

Error while trying to mount S3 bucket into Ubuntu 14.04 EC2 instance

I have tried the following link to mount S3 bucket into EC2 : https://forums.aws.amazon.com/message.jspa?messageID=313009 I started typing the following commands : wget...

Error to install pip on google-cloud

) I tried to install pip on a gcloud server with ubunto 16.04 I got this error massage. Hopefuly you can help me. https://pastebin.com/Pdyt5n5j maybe pastbin is better to...

Why Docker container images become so large while deploying Python 3.6, Virtualenv, Flask, Gunicorn on Ubuntu 16.04?

While deploying the flask application within virtualenv python3 -m venv FLSK-ENV Dockerfile: FROM appcontainers/ubuntu:xenial MAINTAINER user <user> RUN apt-get install -y...

Hash Sum mismatch in ubuntu 16.04.3

[email protected]:~$ sudo apt install python-pip && sudo apt install python3-pip Reading package lists... Done Building dependency tree Reading state information... Done The following...

problems about using apt-get install build-essential and make C source file

I'm going to write C code on Ubuntu 17.10, when I was about to use make command to compile, the terminal message was: [email protected]:~/Downloads/datalab-handout$ make world The program 'make' can...

Fail to install gcc-4.9 in ubuntu17.04

While trying to build llvm 3.4 from source on Ubuntu 17.04, I have encountered some problems related to gcc 6.3 (described here), so I want to use gcc-4.9. However, when I run from terminal: sudo...

Dist Upgrade to Buster failing

I currently have a Dockerfile which has started to failing (with no changes in the Dockerfile) The Dockerfile has the following contents: FROM php:apache-stretch WORKDIR /tmp # SOFTWARE REQS RUN...

Impossible to apt install on Ubuntu's bash windows 10 version

I installed Ubuntu's unix bash on Windows 10 (this : https://www.microsoft.com/fr-fr/p/ubuntu/9nblggh4msv6#activetab=pivot:overviewtab ) it installed well but I can't "apt install" (yes, on this...

Installation of python module using `pip` during `docker build` fails

I'm trying to build a Docker container in which I want to install some Python modules using pip (these modules will eventually be needed to build an app). I have written the following...

How to install pip into a ubuntu container while keeping layers to a minimum?

I'm interested in building a small container image which has pip-installed packages, but unfortunately, installing python3-pip via apt-get pulls in a lot of dependencies (348MB) into an otherwise...

Rails & Docker: configure bundler to run bundle install in a docker build for Rails.4.2.6?

I am having so much trouble with docker. It seems to be a pattern. I have a dockerfile which installs Node.js and Yarn from source repositories fine. I install ruby from the get-apt repositories...

Python3-pip install: http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gcc-7 amd64 7.3.0-27ubuntu1~18.04 Unreachable

i'm trying to install python3-pip with apt, but it seems that http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 gcc-7 amd64 7.3.0-27ubuntu1~18.04 is unreachable I have already tried...

Missing required packages in Ubuntu 18.04 pcc64el

starting from IBM's PowerAI TensorFlow docker container I try building a singularity container with additional packages on my Power 9 (ppc64el plattform). Using apt to install packages I get a lot...

How to install ansible 2.9+ on ubuntu 18.04 and utilize python3?

I'm trying to install minimal ansible 2.9.x on Ubuntu Bionic (18.04 LTS). The final goal is to build new disk image (using packer) on every commit and want the process to be as fast as...

Google Cloud VM startup script fails to install pip3

I'd like to pass a startup-script to my free f1-micro instance VM in GCP. The command that I'm specifying is the following: gcloud compute instances create dora-scanner --zone=us-central1-a...

docker python flask gets " Do you want to continue" then "executor failed"

Trying a simple python flask web app in docker 20.10.2, build 2291f61. Doing the: docker build -t hello-world . starts out ok (please see below), but ends with: #6 2.866 After this operation, 305...

Relevant tags