Going from Qt4 to Qt5 on Linux: This application failed to start because it could not find or load the Qt platform plugin "xcb"

I'm moving from Qt4 (4.8.6) to Qt5 (5.4.1) in cross-build environment (GAR environment, MiniMyth2 project). I have perfectly building and running Qt4. I already successful cross-compiled and...

Vagrant plugin load order

I am behind corporate proxy which is using self-sign certificate to intercept ssl trafic. So I have installed vagrant-ca-certificates to have certificate in vm. I am also using vagrant-omnibus to...

Can't run vagrant up

Ok this is pretty simple: I'm on windows 10. I just downloaded Vagrant v1.8.0 and Virtualbox 5.0.12. All i did i just: vagrant init so my VagrantFile only contains this : Vagrant.configure(2) do...

Ubuntu / DigitalOcean - Unable to fetch packages to install git on a fresh install

Just started with a fresh install of Ubuntu 14.04 on my digitalocean droplet and I'm trying to install git. My first attempt failed to install some packages - [email protected]:~# sudo apt-get install...

Net::HTTPServerException causing Chef to fail

I'm attempting to set up a Rails environment with Vagrant and Chef by following this guide. I've used it in the past with success. When I run vagrant up it fails, and (I think) this is the...

Get opengl version supported on linux machine

I am trying to get the opengl version supported on my linux machines.I have a linux machine which have glxinfo output as OpenGL vendor string: VMware, Inc. OpenGL renderer string: Gallium 0.4 on...

cuda 9 packages no longer required after installation

I installed CUDA 9 from the local deb but afterwards apt reports: The following packages were automatically installed and are no longer required: cuda-command-line-tools-9-0 cuda-core-9-0...

Only eglfs when cross-compiling QT static for Raspberry PI

I have cross-compiled QT static for Raspberry PI using ./configure -opengl es2 -opensource -confirm-license -release -static \ -prefix /usr/local/qt5static -hostprefix ~/raspi/qt5...

Qt-version related runtime errors in Qt application

I am using Qt Creator to develop and run an application on Linux KDE neon. My application suddenly refuses to open some URLs, a function that properly worked before. I didn't change anything so I...

Can apt-get autoremove remove system files?

I tried to install Python 3 on my Ubuntu 16.04.4 LTS and while using apt i found this: The following packages were automatically installed and are no longer required: cabextract gcc-5-base:i386...

How to minimize an ubuntu docker image which needs only git, cron and openjdk-8-jre

Testing some docker project so after playing with alpine, I would like to use ubuntu:bionic for production. I decided to roll out my own image but the problem is that it's 600MB+ . REPOSITORY ...

Rails & Docker: configure bundler to run bundle install in a docker build for Rails.4.2.6?

I am having so much trouble with docker. It seems to be a pattern. I have a dockerfile which installs Node.js and Yarn from source repositories fine. I install ruby from the get-apt repositories...

Docker OpenGL support without GPU, gl error: linking with uncompiled/unspecialized shader

In order to build up a headless simulation cluster, we're working on containerization of our existing tools. Right now, the accessible server does not have any NVIDIA GPUs. One problem, that we...

Upgrade to Ubuntu 20.04 killed pip

I upgraded to Ubuntu 20.04 from 19.10 and now I cannot use pip. zeno:~$ pip --version Command 'pip' not found, but there are 18 similar ones. Python is installed: zeno:~$ python3...

NPM requires x11 during installation via apt

I running Ubuntu server 20.04 and i need to install npm. But when i run "apt install npm" i see x11 packages in requirements. The following NEW packages will be installed: gyp javascript-common...